[BUG]RPI4 Mate Shutdown and Logout


I have a raspberry pi 4 8gb and have installed Manjaro mate which I am happy with except that using the menu to shutdown or log out takes forever. If I issue shutdown in a terminal it is instant. They both take around 30 seconds plus from the menu.


1 Like

Isn’t there a popup on the screen, that counts down, which has a “Do it now” button?

Most DE’s have one of those these days.

Yes but clicking on “do it know” closes the popup and it still takes 30 seconds plus.

1 Like

Hm. I just tested this with a MATE Pinebook Pro image. And you are right. Pressing Shutdown in the box still takes quite a while for it to actually shut down.

I wonder if X64 also has this issue?
@Darksky do you know what this could be?

1 Like

I do not have a mate image installed on a sdcard right now. Off the top of my head it sounds like it is waiting for some process to shut down. I wonder if dmesg -w via ssh in a terminal before starting the shutdown process will give any info.

No. I am running mate on my desktop

Dammit. I wished this showed up earlier in the night… Oh well. It’s all most 3 am.

I ran dmesg -w over ssh and nothing showed after I ejected my usb stick before telling it to shut down.

Thanks for looking into it fellas


Did it show anything weird after starting the shutdown routine?

I did the same on a new image and nothing new showed up with dmesg -w via ssh. I also removed all dot files/folders in the home directory to remove all configs and the 30s wait was still there.

No nothing weird showed up the message saying I had removed my usb stick was the last thing that appeared nothing after that.

Yes I am using mate and also confirm it takes a while also. I just figured it was a quirk of manjaro arm. Is this not the case on xfce for example?

I have used Manjaro xfc in the past and it has been normal no delay, I have only found it happen on mate.

Just applied all the latest updates and it is still the same takes around 30 seconds before it shuts down.

Remove matray and reboot for it to take effect. If you have an older image it could be called mntray.


Yep that fixes it odd but let me know if it gets fixed as I like to get the updates and news etc.

Many Thanks

1 Like

That would be up to the developers. The Mate environment sometimes has issues with assorted things that other DE’s do not.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.