[Bug] Mouse stop working

Hi all !

I’m becoming quite active here but only reporting bugs, and no solutions, I hope not being too annoying…

I am using the ARM Sway Edition on the testing branch with 5.10.0-rc4-1-MANJARO-ARM kernel. I noticed that this bug also occurred with the 5.4.77-1-MANJARO-ARM kernel.
This beautiful flavor is running on my RPi4.

So my problem is : the mouse stopped working at a random moment (terminal and firefox on idle). That’s just it.
I’m using a wireless mouse and keyboard, the mouse pointer crashed while the keyboard did not.

I looked around the web but didn’t found anything. I temporarily solved the problem by disconnecting and reconnecting the mouse connector.

I’m open to any suggestion to find and fix this bug. I will post the solution if I find it.

Thanks everyone and have a good day !

I’ve a Bluetooth mouse attached to my Pinebook Pro as well and noticed that after some time of inactivity the mouse goes into an idle mode, which somehow disconnects it from the laptop.

As it is using an up to date Bluetooth protocol stack (Bluetooth Low Energy) as soon as I trigger the mouse with some movements or pseudo clicks the connection gets reestablished and it continues to work.

Could you eventually check via the Bluetooth indicator in the Waybar if your mouse is still connected when it stops functioning?


My mouse use it’s own connector, then I can disable the RPi bluetooth and the mouse keep working (tried). Do you know if I can still see if it is connected (but disabled I suppose) ?

Thank you for your help !

If you have a usb drive plugged into the usb 3.0 port it will create interference if the drive is not shielded properly; per what the RPi people say and others say it is a design flaw with the pi4 board. Some monitors also cause interference.

I had to add an usb extension cable to put more distance between the drive and the pi4 board.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.