[BUG] Manjaro Deepin visual flickering after 18.01.2019 update

deepin
video

#1

video-linux drivers before & after update.

I’m 100% positive that before there was no 1 and 2, 3 was partially (there was this transparency lag like on first second to the right, but no flickering)

  1. Deepin file explorer example (flicker to transparent):

  1. Pamac example (flickers to black):

  1. Deepin settings example (noticeable to the right):

1 & 2 doesn’t happen of virtual machines, so must be driver related.

inxi -Fxxz for one of test machines:

System:    Host: x133-pc Kernel: 4.19.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Deepin 15.9 
           tk: Qt 5.12.0 wm: DeepinWM dm: LightDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Sony product: VGN-Z11VRN_B v: J003DTPY serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Sony model: VAIO serial: <filter> BIOS: INSYDE v: R5031M3 date: 11/10/2009 
Battery:   ID-1: BAT0 charge: 33.9 Wh condition: 33.9/59.5 Wh (57%) volts: 12.3/10.8 model: Sony Corporation 
           serial: N/A status: Full 
CPU:       Topology: Dual Core model: Intel Core2 Duo P9500 bits: 64 type: MCP arch: Penryn rev: 6 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 10113 
           Speed: 2527 MHz min/max: 1600/2533 MHz Core speeds (MHz): 1: 2527 2: 2527 
Graphics:  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Sony driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:2a42 
           Display: x11 server: X.Org 1.20.3 driver: modesetting alternate: fbdev,intel,vesa resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express v: 2.1 Mesa 18.3.1 direct render: Yes 
Audio:     Device-1: Intel 82801I HD Audio vendor: Sony driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:293e 
           Sound Server: ALSA v: k4.19.14-1-MANJARO 
Network:   Device-1: Intel 82567LM Gigabit Network vendor: Sony driver: e1000e v: 3.2.6-k port: 7100 bus ID: 00:19.0 
           chip ID: 8086:10f5 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR928X Wireless Network Adapter vendor: Foxconn driver: ath9k v: kernel 
           port: 7000 bus ID: 06:00.0 chip ID: 168c:002a 
           IF: wlp6s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.39 TiB used: 143.27 GiB (10.0%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541515A9E630 size: 1.36 TiB speed: 3.0 Gb/s serial: <filter> 
           ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.88 GiB serial: <filter> 
Partition: ID-1: / size: 172.02 GiB used: 8.41 GiB (4.9%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 207 Uptime: 3h 58m Memory: 3.78 GiB used: 525.0 MiB (13.5%) Init: systemd v: 239 Compilers: 
           gcc: 8.2.1 Shell: bash v: 4.4.23 running in: deepin-terminal inxi: 3.0.28 


#2

Maybe its specific to your system. Issues not present here.


#3

Most certainly it is, or specific to Intel / video-linux combination


#4

Anyone have any ideas?)

Not that i’m a fan of video-linux, but it wasn’t this way before update.

Besides, i would go Intel proprietary, but for some reason Manjaro doesn’t offer them for Intel GM45…Why? Deepin for example offered them and it worked fine.

UPD:
Just for the test i’ve booted to terminal from grub (appending 3 to the end of linux entry)

  1. Removed video-linux with mhwd
  2. Intall video-linux with mhwd
  3. Reboot

Then 1 & 2 now solved…

But 3 & questions about updates and above still remained…
And now weird diagonal screen tearing in Firefox is back…Dammit!

Hope it will help to debug problem further.


#5

3 (settings) still active after 10.02.2019 update :worried: