[BUG] Manjaro Deepin | Settings - Default apps randomness

Any time you enter Default Applications it show or hides them in complete randomness:

So…Pretty unreliable it become for switching applications based on pure luck)

P.S. Wow…Deepin screen recorder should have some quality preferences )

inxi -Fxxz from one of hardware tested computers:

System:    Host: x133-pc Kernel: 4.19.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Deepin 15.9 
           tk: Qt 5.12.0 wm: DeepinWM dm: LightDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Sony product: VGN-Z11VRN_B v: J003DTPY serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Sony model: VAIO serial: <filter> BIOS: INSYDE v: R5031M3 date: 11/10/2009 
Battery:   ID-1: BAT0 charge: 33.9 Wh condition: 33.9/59.5 Wh (57%) volts: 12.3/10.8 model: Sony Corporation 
           serial: N/A status: Full 
CPU:       Topology: Dual Core model: Intel Core2 Duo P9500 bits: 64 type: MCP arch: Penryn rev: 6 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 10113 
           Speed: 2527 MHz min/max: 1600/2533 MHz Core speeds (MHz): 1: 2527 2: 2527 
Graphics:  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Sony driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:2a42 
           Display: x11 server: X.Org 1.20.3 driver: modesetting alternate: fbdev,intel,vesa resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express v: 2.1 Mesa 18.3.1 direct render: Yes 
Audio:     Device-1: Intel 82801I HD Audio vendor: Sony driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:293e 
           Sound Server: ALSA v: k4.19.14-1-MANJARO 
Network:   Device-1: Intel 82567LM Gigabit Network vendor: Sony driver: e1000e v: 3.2.6-k port: 7100 bus ID: 00:19.0 
           chip ID: 8086:10f5 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR928X Wireless Network Adapter vendor: Foxconn driver: ath9k v: kernel 
           port: 7000 bus ID: 06:00.0 chip ID: 168c:002a 
           IF: wlp6s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.39 TiB used: 143.27 GiB (10.0%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541515A9E630 size: 1.36 TiB speed: 3.0 Gb/s serial: <filter> 
           ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.88 GiB serial: <filter> 
Partition: ID-1: / size: 172.02 GiB used: 8.41 GiB (4.9%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 207 Uptime: 3h 58m Memory: 3.78 GiB used: 525.0 MiB (13.5%) Init: systemd v: 239 Compilers: 
           gcc: 8.2.1 Shell: bash v: 4.4.23 running in: deepin-terminal inxi: 3.0.28 

Deepin forum thread:
https://bbs.deepin.org/forum.php?mod=viewthread&tid=174019&extra=page%3D1

That’s weird. It’s not happening here with Manjaro Deepin Stable. Have you made yesterday’s updates?

Yep, made updates, mine is also stable, Kernel 4.19.14-1 LTS.

That’s really weird, actually i had this before & after update both on real & virtual machines, and on virtual machine even in Linux Deepin itself…

I’m on 4.20.1-1-MANJARO. Probably won’t make any difference but you might want to try booting with 420. Also the other bug you reported here - [BUG] Manjaro Deepin file explorer crash - is something I’m not experiencing.

I still think most likely it’s DE bug, since Linux Deepin’s current Kernel even lower than mine and still has this bug…
But later will give it a try, who knows, maybe it will work.

File explorer bug is floating, means it can occur totally random and i’m still unable to detect any logic behind it, most of times it don’t happen for me also.

After all latest updates this bug still active :expressionless:

One my DELL machine with nvidia drivers i don’t see it, so probably it’s somehow connected with video-drivers, other than that i don;t know.

P.S. Just in case i’ve checked Kernel 4.20, no it’s nod connected, still there. Besides Deepin itself have this also

Still happens on this machine, after 10.02.2019 update :worried:

Fixed with 12.03.2019 Manjaro Deepin update

Thx Deepin devs :slightly_smiling_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.