Bug: can't change firefox theme

I think this is a bug at least. I encountered it too, I tried to change to downloaded themes and other themes provided, but it didn’t work, until I blew away my .mozilla which until today was just a copy of /etc/skel/.mozilla. If I had to guess, this is the problem (guessing because they’re symlinks to a root owned theme), but I don’t know much about the internal structure of firefox

manjaro% ls -laR ~/.mozilla.bak | grep "/usr"
lrwxrwxrwx   44 xeno 30 Jul 00:25 firefox-gnome-theme -> /usr/share/themes/Firefox-Gnome-Maia/chrome
lrwxrwxrwx   44 xeno 30 Jul 00:24 firefox-gnome-theme -> /usr/share/themes/Firefox-Gnome-Maia/chrome
lrwxrwxrwx   44 xeno 30 Jul 00:25 firefox-gnome-theme -> /usr/share/themes/Firefox-Gnome-Maia/chrome
lrwxrwxrwx   44 xeno 30 Jul 00:24 firefox-gnome-theme -> /usr/share/themes/Firefox-Gnome-Maia/chrome
manjaro% ls -laR /etc/skel/.mozilla | grep "/usr"
lrwxrwxrwx   44 root 30 May 16:39 firefox-gnome-theme -> /usr/share/themes/Firefox-Gnome-Maia/chrome
lrwxrwxrwx   44 root 30 May 16:39 firefox-gnome-theme -> /usr/share/themes/Firefox-Gnome-Maia/chrome
1 Like

That’s not bug, firefox-gnome-theme-maia is preinstalled and enabled by default in Gnome version you can disable or remove this theme at any moment.


except that’s the problem, I couldn’t actually change the them (and the link to the other post the OP couldn’t either), any attempt to change the theme (at least via firefox) resulted in the theme not changing. Maybe you can do it with another tool, but IMO firefox should be able to change it’s own theme, not being able to do so is unexpected behavior.

I haven’t tried this, but perhaps the theme needs to be copied and not linked? I’m really not certain, I’m just saying post creation of a user with the default manjaro settings you should be able to go into firefox → addons and themes → themes and select any theme you want and have it apply. That is not my current experience. No other tool should be necessary.

My FF work without problems (others probably also, I don’t see any problems on forum with current FF), I can change theme or anything else without external tools. Linked post is issue with old FF, it can’t be compared with current version (changed UI in 89 in March and other things). So this isn’t bug – it’s your setting or corrupted profile (rare, but may happen, you do nothing with it).

hmm, ok. I suppose I could reinstall skel and test it. Meh though. Maybe if I want to revert, but I’d rather find the author and ask them to put something to mark the active tab first, because I found it really hard to notice. I notice my setup otherwise is currently using a teal underline on the gnome-terminal tabs, so…

As far as no one else, I mean, that depends on how many fresh installs there are, that actually use firefox and change the theme. Before now I wasn’t actually using firefox, but opera finally made me mad enough to switch.

But if you have a fresh user that you’ve tested on, then I guess something happened. I did have a weird issue the other day, so maybe.

Thank you so much for this. I was wasting so much prodcutive time trying to get rid of this hipsterism gone mad FF style!.

  1. Uninstall firefox-gnome-theme-maia
  2. Disable Proton. Tip: Turn off Firefox 89-90 "Proton" Design - Applications - EndeavourOS
  3. Enable Compact mode. Compact mode workaround in Firefox | Firefox Help
  4. Optional, change the theme to a clean sensible contrast. eg Arctic Nord Arctic Nord Theme – Get this Theme for 🦊 Firefox (en-US)