Budgie menu issue with lightdm-settings


#1

Hi guys, all of my DE are released at 17.1.11 point. I’m also in order to do the Budgie 17.1.11 and i’m still working into the next Gnome 18.0 release. Well i have an annoing issue on budgie with lightdm-settings. I’m not able to open the gui via budgie menu. Already opened an issue on Solus repo a time ago


and also into lightdm-settings repo

(ok here is mentioned also Cinnamon issue but this is already solved by @oberon)
All work fine if i open via gnome-terminal: pkexec lightdm-settings

Any idea how i can trace it? It is funny but if i run
budgie-panel --replace &
it open without error only the error reported here but i’m not sure is related at my problem…
This is the only no go issue for manjaro budgie at the moment :rage:


Manjaro Budgie 17.1.11
#2

Would help as a workaround to add
budgie-panel --replace &
to autostart?


#3

Uhmmm :sweat_smile: you point me in a very easy solution… Not considered this workaround… Not know why i want find a complex solution… :joy: let me try :wink:


#4
$ budgie-desktop --version        
budgie-desktop v10.4-81-g733742a4
Copyright © 2014-2017 Budgie Desktop Developers

I get this error on my budgie:

#from run dialog
juil. 07 22:11:48 yo-gs budgie-wm.desktop[1854]: Refusing to render service to dead parents.
#from menu
juil. 07 22:11:53 yo-gs budgie-panel.desktop[1862]: Refusing to render service to dead parents.

But if I start run dialog from terminal it work flawlessly (budgie-run-dialog)


:point_up_2: this is a gif :point_up_2:

#5

Yep … this is very strange… btw also add a command for reset budgie ( budgie-panel --replace & ) not have effect … i have also tried to add a time to do it whit sleep 10 but nothing … i see budgie reset the session but lightdm doesen’t start … in terminal all is ok grrrrr :rage:

EDIT:
This seem work as expected


#6

I wanted to suggest this workaroud
Exec=budgie-panel --replace && lightdm-settings
but forgot. Good that you got the idea, too.