[Bspwm] v17.1.7 stable isos released


#1

Bspwm edition is a minimalistic manjaro edition which aims to make terminal approachable for beginners. It is very focused on efficiency of workflow and resource usage, and can adapt to many different workflows. Recently the edition has evolved to a new direction - or three directions to be exact.


First we have the successor of the previous bspwm edition. It features gtk3 and cli apps only. It has remained largely the same, with some improvements:

  • new cool wallpapers by @muser
  • new ranger based wallpaper switcher with image previews
  • syntax highlighting, icons and image/video previews in ranger
  • micro, excellent text editor
  • new rofi based menus and scripts
  • gapdrag, you resize windows by dragging the border between them with mouse
    https://www.youtube.com/watch?v=b36yB_rGsW4



Next, we have bspwm-minimal, which is even more minimalistic version of the bspwm edition. It includes no true gui applications at all, and uses instead terminal applications that feel and behave like gui ones. It uses the new and excellent rofi based mainmenu and desktop menu by @kainonergon. It is most minimalistic manjaro desktop to date, and boots under 100Mib ram used.



Finally, we have bspwm-mate, which does away with the minimalism and instead gives you the bspwm workflow from the comfort of a full desktop environment. As testament to it’s completeness, it even features graphical installer, Calamares.

The isos are available here:

https://sourceforge.net/projects/manjarolinux-community/files/bspwm/17.1.7/


Torrent link missing for bspwm
#2

#3

Why are you naming the ISO’s differently than usual?

I have to redo my torrent script to do this one. :frowning:

Edit: Script edited. Got it working.
Torrents for both Minimal and Mate are now up!


#7

#8

gapdrag looks nice!


#9

Sorry guys, where can I download the torrents for this release? Looked up on sourceforge but the 17.1.7 folder is empty. Thank you


#10

@Strit might know. I was under the impression that torrents were generated despite unconventional naming.

I made a short video featuring some of the new features in bspwm edition, as well as some of the old ones. I mainly did it because I finally euclid mode to work to my satisfaction. I have never seen euclid wm, but I made a script to emulate it based on what I read about it :smile:

Also, animated wallpapers. I did not know it was a thing.


#11

Cool! Looks totally awesome!
Updating the Download page now …


#12

I’ll look into this.

PS: There we go.


#13

@Chrysostomus
Is there a reason for using the gnome versions of apps (gedit, nautilus, eog, evince, …) instead of the mate forks (pluma, caja, eom, atril, …) in bspwm-mate?

I’d say using the mate forks would be more consistent a) regarding the iso editions name and b) in terms of a “traditional” desktop environment since the mate versions have traditional menus instead of the fancy gnome menus hidden behind one huge button.


#14

Glad you asked! Yes, there are two reasons:

  1. At the time of development mate applications had weird long delays on startup under bspwm. There was no easy solution, and since mate applications did not have any killer features to make researching the solution worthwhile beyond first two days, I just decided to use something else instead.
  2. Why gnome apps then? Mate is a gnome fork. I also considered using xfce applications, but it seemed to get too messy. Also, client side decorations are actually useful in bspwm, since they provide functionality not provided by the wm. Bspwm-mate tries to be mouse friendly, and having a close button on windows serves that purpose.

But once mate apps start working without issues, I’ll happily convert the edition to them.


#15

I just installed bspwm-mate and can see the delay you are talking about. It’s always accompanied by the output EggSMClient-WARNING **: Failed to connect to the session manager: Could not open network socket but you probably know that already. That makes the gnome apps a valid choice I guess :slight_smile: .

I don’t think client-side decorations on a small subset of apps make bspwm “mouse friendly”. Since most apps don’t have them I need to know the keyboard shortcuts anyway.

More important, I found some bugs in bspwm-mate:
Trying to install bspwm-mate using calamares failed with the following message:


The symlink is obviously broken. After /etc/.../.config/menus >>> sudo ln -sf applications-merged mate-applications-merged installing worked fine.


The mousewheel does not work in most (might be all) gtk applications.
export GDK_CORE_DEVICE_EVENTS=1 fixed it for me (Source)


On startup I get a popup from blueman complaining that /home/manjaro/Downloads does not exist. I haven’t found a way to fix this (apart from creating this folder, which doesn’t make sense).


#16

Hi there, @whole-porridge and @Chrysostomus!

I tried the symlink ‘repair’ workaround as suggested by @whole-porridge, which I think I did successfully and the installation still failed at the postcfg stage when I tried installing it on a virtual hard disk via Virtualbox:


#17

Well, that’s troublesome. I don’t usually use calamares so I have little experience in troubleshooting it. I wonder if @Ste74 or @oberon would know something of this


#18

Indeed I also run into this same problem:

Screenshot_2018-04-08_19-17-19

Will try a different edition for comarison now.
Also we should check if there’s anything in the bspwm-mate overlay that might be causing this issue…


#19

Just tried the i3 edition for comarison - no problems there, strange!


#20

@Chrysostomus what’s the deal with that file calamares is complaining about that cannot be copied?
/etc/skel/.config/menus/mate-applications-merged isn’t included in desktop-settings, nor can I see it in the profile’s overlay ??


#21

I dunno, but I’ll find out when I get home. It seems unlikely that the local iso profile would have a file not in the remote one, because I haven’t touched bspwm-mate in a long time, but have worked with other profiles.


#22

Another observation that I both ran into when installing bspwm-minimal with manjaro-architect aswell as when booting the bspwm-mate ISO in virtualbox:

I don’t know why that messages appear. vbox-guest-modules are installed and also the ISO shouldn’t boot anyway without them, right?


#23

Weird. Also, that is not bspwm-minimal in the screenshot. Seems more like bspwm-mate.

Edit: I read more carefully. Of course that is not bspwm-minimal