Bspwm installed by Architect - freezes after using hardware controls XF86

bspwm
manjaro-architect

#1

Hi,
my i3 installation got corrupted so I reinstalled my Manjaro instance with bspwm - to test things out. I really like it, but…
When I try to increase/decrease brightness using XF86 keys (volume buttons usually work) it freezes. Could you provide me with a way to debug it? Which logs should I take a look at?
Thanks, I love you guys!


#2

Would I be correct to assume that this is bspwm edition and not the unconfigured bspwm?

Look for the corresponding keys in your sxhkdrc (there is a link in the main menu). Comment those out and reload sxhkd (super + shift + esc if memory serves). If it doesn’t freeze anymore, then it is caused by those lines. If it still freezes, then it is something else.


#3

If it turns out that the issue is with sxhkdrc, then try running those commands in terminal to see the issue.

   xbacklight -dec 10
   xbacklight -inc 10

#4

If xbacklight causes things to freeze, you can try

    light 

From AUR


#5

Yes, I am using preconfigured, Manjaro version, I checked xbacklight earlier, and it works as it should, as is the Dlight (or how is the thing in status bar called). Sometimes it freezes by itself, but to make it happen instant I can just use Fn+F9 or F10 which is brightness adjustment in my laptop.
Maybe I should add, that I’m using 4.14 rc2 kernel, but freeze happened on 4.9 also, so it’s probably not it.


#6

And I just commented out key bindings, and it still freezes! Oh my.


#7

Then it is probably a kernel issue. I would try different kernels.


#8

I checked lts kernel, it didn’t work. But… I just used xdotool to simulate key strokes on XF86 buttons and it worked, so it turns out it may be hardware related - I’m downloading live image to flash it on USB and check it out… Sorry for bothering!


#9

It just got weird, because it works on Live USB XFCE Manjaro! I’m going to try more kernels then… Is there a log I can save and send here?


#10

These are the kernels I tried:
4.14rc0.e7d0c410-1 (i thought it was rc2)
4.9.48-1
4.9.47-1-rt37
3.10.107-1

It didn’t work with them. Any ideas? I’m out of them!


#11

Sorry, I needed working machine today, so I just got back to i3. bspwm loaded a lot faster, which was great, but the freezing… Might it have been because I didn’t install acpi-call kernel module? Maybe


#12

Hmm… Built a new iso and it seems that I can reproduce the issue. Also, it seems that xorg-xbacklight is not installed by default…


#13

The issue is fixed by using sxhkd-git instead of sxhkd. So, updating that should fix it for everybody. Thank you for reporting!