Brother printer not seen by the OS

I installed the driver (correct one for the printer number) from the AUR, re-booted, however all I can get when trying to print a document is “Print to PDF” no other options appear.

Is there some other setting I need to enable somewhere?

that is not enough information for me or others to check
whether that is true
whether the driver package you chose was the correct one
and whether that one does need additional steps (activating a service, for instance …)
… just not enough to go on

Brother HL-L2350DW - it is listed in the AUR - there is ONLY one there!

As with the other stuff installed from there, the system did (or seemed to do) all the configuring…I thought that was what it was for?

I even tried doing it via terminal, but it reports it is installed and nothing to do.

ok - but you did not mention the model :wink: - just Brother

without having looked for myself as of right now:
did you check the Arch wiki for possible Brother specific info/instructions?

Last time I was running Manjaro, all I did was install that driver and it all just worked. This time nothing.

seems to be a network capable printer

CUPS/Printer-specific problems - ArchWiki

the PKGBUILD is from 2020, with some comments to it

one was:

The solution to get USB working was to uninstall the ipp-usb package.

of course I don’t know what to make of it - I can’t test as I don’t have that printer

AUR (en) - brother-hll2350dw

perhaps the Brother site has more info or a newer driver

Thanks for that.

Yeah I had a look at the Brother site, but later found conflicting reports from users. afaik, cups is installed correctly, I can use print settings app - although it advises no printers configured, and again no Brother printer is listed anyway.

I know it works as I used this same printer the last time on Manjaro - had to go back to windows for a while.

… you still have backups from that?
I tend to keep at least the /etc directory from previous installations - for later reference of how things where configured
… keeping all of /etc in an archive is not much data …

How is it connected to your system? Through USB or network?

Do you have manjaro-printer installed?

via USB - and afaik it is installed.
At least, when I check the installed in Add/Remove it has the red bin icon, so I guess it means it is installed.

FWIW, if I yay -Ss Brother or look in the “Add/Remove Software” GUI app for “Brother” in the AUR repository, I get screenful upon screenful of Brother printer drivers.

Notwithstanding that you’ve previously had capability that’s gone missing, what makes you certain there is only one associated driver?

[I happen to have a Brother B&W Laser printer (wireless) that I connect via wi-fi from my Manjaro laptop … frankly, it’s an often misbehaving connection that I blame on the Brother printer, as my wife suffers from similar intermittent issues via her iMac. We resort to the “turn the printer off and on again” routine more than I’d like to admit.]

It’s mentioned by that exact name Brother HL-L2350DW in the Arch wiki:

CUPS/Printer-specific problems - ArchWiki

and this is the PKGBUILD that exists for it:

AUR (en) - brother-hll2350dw

1 Like

Ah, I see your point. No doubt I misinterpreted the OP’s statement up above about there only being one.

@pax-eterna Is your Brother printer not seen listed as a choice in the GUI System Settings>>Hardware>>Printers?

Have you configured it in CUPS?

Nope, not there

… a known good cable
… the printer switched on

that may seem obvious, but
“ich hab schon Pferde kotzen sehen” … meaning:
just making sure, you never know …

then you can
open a terminal
and issue:
journalctl -f
then watch the output as you plug and unplug the USB cable of your printer

you can do the same with:
sudo dmesg -w
in a terminal

is the printer even recognized?

I checked the wiki, and all the software it recommends to be installed is already installed. I’ll check the cable by running a print on the Microsoft Surface Pro…worked last time I used it. Although tbh, in my experience, it has never been the usb cable haha!

Oh and fwiw, when I run lsusb the Brother printer is in the list…so that’s just more confusing haha!

Have you added it in Print Settings? I think I had to do that.

…wrong thread

Followed this step by step : How to set up a printer on Manjaro most of the Linux software/drivers etc had already been installed, however the thing I didn’t realise was that the Printer Config box shows an unlocked padlock…I THOUGHT that meant it was unlocked…however after following the tips on that links, the unlocked padlock means it was locked, once I entered the password and the symbol changed to a locked padlock (confusing !!!) it was easy after that.

Printed a test page so all working…I’ll mark the thread OP as solved.

Thanks to all who offered tips, very much appreciated!!