Broken sound controls and sound

Why is it that bad? And each time it gets worse, I’ve been using Ubuntu for 3 years and thought it was bad (no multi-touch gestures, no fingerprint login), and now I’ve been told that Manjaro is stable and cool, but

At first sound controls didn’t work and the sound was always on max, but they did work if I put in headphones, but with headphones some nasty cracking noise appears. I’ve tried some advices here, and pretty sure restored everything as it was since nothing worked, but now the sound stopped working completely for both speakers and headphones. The most weird and creepy thing is that if, while something is playing, you click through sound devices and headphones/speakers in setting you’ll hear distorted and fainting sound for a few seconds until it gone again. Creepy.

I’ve got tons of other problems, and I just wonder, can it possibly be due to BTRFS filesystem I chose? That’s the only thing that’s changed since Ubuntu.

To get back sound, restart or log out → log in won’t help, but closing the lid (I’m on laptop) and opening it back again restores the sound. What kind of magic is that?

Welcome to Manjaro forum

If, while something is playing, you click through sound devices and headphones/speakers in setting you’ll hear distorted and fainting sound for a few seconds

I suspect the sound is from clicking on speaker test buttons

can it possibly be due to BTRFS filesystem I chose?

That is a possibility. BTRFS is not recommended for professional/lowlatency audio
But on KDE there may also be an audio issue with sound servers PulseAudio and Pipewire running concurrently

Please post response to this command to show system information

inxi -Fazy

Issues with volume controls or loss of audio output might be due to the audio codec not being detected correctly, or misconfigured in ALSA

Please post response to this command to show ALSA information

sudo --upload

Thank you for your reply!

Kernel: 5.10.36-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.10-x86_64
root=UUID=5e1ea6bc-9a09-4a58-8672-207bbf93889f rw rootflags=subvol=@ quiet
apparmor=1 security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: UX550VE v: 1.0 serial:
Mobo: ASUSTeK model: UX550VE v: 1.0 serial:
UEFI: American Megatrends v: UX550VE.307 date: 04/19/2019
ID-1: BAT0 charge: 54.9 Wh (96.7%) condition: 56.8/73.8 Wh (77.0%)
volts: 15.4 min: 15.4 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: Not charging cycles: 104
Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP
arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: DE
cache: L2: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 44817
Speed: 3428 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3428 2: 3431
3: 3477 4: 3473 5: 3471 6: 3445 7: 3474 8: 3473
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: ASUSTeK
driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0302
Device-3: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-4:3 chip-ID: 13d3:5755 class-ID: 0e02 serial:
Display: x11 server: X Org 1.20.11 compositor: kwin_x11 driver:
loaded: intel,modesetting unloaded: nouveau alternate: fbdev,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5")
diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.0.3
direct render: Yes
Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
Sound Server-1: ALSA v: k5.10.36-2-MANJARO running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.28 running: no
Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: e000
bus-ID: 03:00.0 chip-ID: 8086:24fd class-ID: 0280
IF: wlp3s0 state: up mac:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-9:4 chip-ID: 8087:0a2b class-ID: e001
Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: see --recommends
Local Storage: total: 476.94 GiB used: 14.91 GiB (3.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLW512HMJP-00000
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 rotation: SSD serial: rev: CXY7501Q temp: 36.9 C
scheme: GPT
ID-1: / raw-size: 59.46 GiB size: 59.46 GiB (100.00%) used: 8.7 GiB (14.6%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
used: 604 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p7 maj-min: 259:7
ID-3: /home raw-size: 111.33 GiB size: 111.33 GiB (100.00%)
used: 6.21 GiB (5.6%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 59.46 GiB size: 59.46 GiB (100.00%)
used: 8.7 GiB (14.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Alert: No swap data was found.
System Temperatures: cpu: 75.0 C mobo: N/A gpu: nouveau temp: 49.0 C
Fan Speeds (RPM): cpu: 3600
Processes: 291 Uptime: 4h 49m wakeups: 19 Memory: 15.52 GiB
used: 8.7 GiB (56.1%) Init: systemd v: 247 tool: systemctl Compilers:
gcc: 10.2.0 Packages: pacman: 1237 lib: 355 flatpak: 0 Shell: Bash v: 5.1.8
running-in: konsole inxi: 3.3.04

And the second one:
alsa-project org/db/?f=6c6f6b6d293d593e76bd50649e0a0d3fa71c9dab