Broken Nvidia Hybrid mode after envycontrol installation

My hardware: i5 7300HQ, with uhd 630 iGPU and gtx 1050 dGPU with no mux switch

The problem : I booted in with proprietary drivers installed (kde), no problem. It was in Hybrid mode. Tried to test out a few games with lutris and gamescope is broken, well I did expect that much from nvidia. So I tried to use gamescope using my iGPU. And then realized that one aint working. --prefer_vk_device didnt work so I installed envycontrol and moved to integrated mode. Turned out I didn’t have vulkan drivers for intel installed. And then stuff worked. The problem is… I can’t move back to hybrid mode. After reboot, blackscreen is all I get.

Can still move back to integrated mode from tty but hybrid mode is broken. Also uninstalled the vk drivers so that doesn’t seem to be the issue.

Can anyone help me out ?

remove envycontrol and its configs, reboot and see if it helped

Welcome to the forum! :wave:

No, it’s not.

Why? :thinking:

You should be using your dGPU for gaming.

Did you read any documentation? Did you search the web? What did you find and what did you try?

Please post your system info as outlined here:

Please also see:

“Gamescope is broken”

Sorry, that didn’t come out right. I meant gamescope is kinda broken on gtx 1050.
And I wanted to try using gamescope through iGPU, just gamescope (and maybe FSR) and THEN use the prime render offload prefix to render the actual games through the dGPU.

Update btw: removing the linux61-nvidia driver and installing the dkms driver somehow allowed me to boot into the hybrid mode again. lspci confirms that its does detect GTX 1050 among the VGA hardwares. BUT now DRI_PRIME=1 or prime-run don’t work. Also some other stuff broke due to my weird trial and error tinkerings. Doing a full system upgrade rn. Lets see if stuff improve.

You need to post your system information like @Yochanan asked so we can see what’s going on. We need to see which drivers are actually installed and how you did it. I’m presuming you installed the Nvidia prime drivers with mhwd and then switched to aur and tried to switch back? Either way if you upload some system information and logs you’ll get help

System Kernel: 6.1.31-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1

ManjaroLinux 23.0.0 UltimaThule (KDE Plasma, wayland)

CPU Vendor ID:               GenuineIntel
CPU Model name:            Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz

lspci -k | grep VGA  returns:                                                                                          1 ✘ 
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)

relevant would be:

                                                                                        ✔ 
nvidia-dkms 530.41.03-4                                                                                         ✔ 
nvidia-utils 530.41.03-4

mesa 23.0.4-1
vulkan-intel 23.0.4-1
envycontrol 3.2.0-2

But, here’s a problem, my nvidia card seems to be running through noveau for some reason:

01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Acer Incorporated [ALI] GP107M [GeForce GTX 1050 Mobile]
	Flags: bus master, fast devsel, latency 0, IRQ 255
	Memory at a3000000 (32-bit, non-prefetchable) [size=16M]
	Memory at 90000000 (64-bit, prefetchable) [size=256M]
	Memory at a0000000 (64-bit, prefetchable) [size=32M]
	I/O ports at 4000 [disabled] [size=128]
	Expansion ROM at a4080000 [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel modules: nouveau

Also did a full system upgrade last night hoping that would fix something. Seems it didn’t.

also this, if it’s any help:

> All PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
  video-virtualmachine            2021.07.26                true            PCI
          video-voodoo            2017.03.12                true            PCI
           video-linux            2018.05.04                true            PCI
          video-sisusb            2020.01.18                true            PCI
video-hybrid-amd-nvidia-prime            2023.03.23               false            PCI
      video-openchrome            2020.01.18                true            PCI
          video-nvidia            2023.03.23               false            PCI
     video-modesetting            2020.01.13                true            PCI
    video-nvidia-390xx            2023.03.23               false            PCI
video-hybrid-amd-nvidia-470xx-prime            2023.03.23               false            PCI
              video-s3            2020.01.18                true            PCI
            video-vesa            2017.03.12                true            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
       video-rendition            2020.01.18                true            PCI
     network-rt3562sta            2013.12.07                true            PCI
       network-slmodem            2013.12.07                true            PCI
         network-r8168            2016.04.20                true            PCI
   network-broadcom-wl            2018.10.07               false            PCI

normally doing glxinfo | grep “OpenGL renderer” returns:

OpenGL renderer string: Mesa Intel(R) HD Graphics 630 (KBL GT2)

And found an error here I think (?), running it with prime render offload:

 prime-run glxinfo | grep "OpenGL renderer"          
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  50
  Current serial number in output stream:  51

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text