Broken installation after big upgrade

This is a 4.1GB upgrade since the last upgrade which was in 10 december 2021. There are a few irrelevant packages that could not be upgraded. Now, after booting, Manjaro puts me in tty1 (and I checked all the ttys available through the F-keys) and on a login prompt I can log in using my username and password. I did a pacman -Syyu and rebooted and still, after logging in, it tells me that

Cannot open display “default display”

Please advice. I want to be able to login into GNOME.

Actually we had 6 updates since 2021/12/10. You should first check each announcement, see if anything is relevant to your system.

I’ve taken a look on the updates but I did not see anything interesting.

What commands can I use to login into GNOME from this prompt?

If I type gnome-shell and press Return it tells me:

Failed to configure: Unsupported session type^J

Started gdm service manually and it works. When I try to enable gdm service in GNOME Terminal I get:

$ sudo systemctl enable gdm.service
Failed to enable unit: File /etc/systemd/system/display-manager.service already exists and is a symlink to /usr/lib/systemd/system/gdm-plymouth.service.

I am wondering what is the solution to this, so that I have GDM start automatically on startup.


Check the tutorial i linked earlier in order to provide meaningful information.

At some point you enabled plymouth. To disable, disable the unit.

systemctl disable gdm-plymouth

And then enable the gdm.service as you tried before.

(Removing Plymouth might need additional steps which I don’t know.)

By removing gdm-plymouth you have to do what i described here

also the early KMS thing …

$ sudo systemctl status gdm-plymouth
Unit gdm-plymouth.service could not be found.

I hope @bogdancovaciu 's solution works.

disable not status

The result will be the same… :point_down:

I did with disable and that printed:

Removed /etc/systemd/system/display-manager.service.

I am currently working out through the steps in @bogdancovaciu 's answer.

$ sudo pacman -R libgdm-plymouth
se verifică dependențele...
eroare: eșec la pregătirea tranzacției (nu pot fi satisfăcute dependențele)
:: removing libgdm-plymouth breaks dependency 'libgdm' required by gdm
:: removing libgdm-plymouth breaks dependency 'libgdm' required by gnome-shell

The plymouth package is not installed.
I just installed this normal gdm: sudo pacman -S gdm (it was not installed previously).

In /etc/mkinitcpio.conf there is no plymouth occurence.

I wonder what the gdm package does since I already have started the gdm.service through sudo systemctl start gdm and I am using GNOME.

Just ran:

$ sudo mkinitcpio -P

with a few warnings.

I am wondering if these steps are enough to restart the system successfully.

Please advice.

I would not go by -R, but simply replace libgdm-plymouth with libgdm
sudo pacman -Syyu libgdm gdm

should replace both without breaking dependencies … just confirm the install when asked.

1 Like

After doing this I tried sudo systemctl enable gdm and it worked (I have checked the behaviour). Just one more thing: I am wondering why the boot graphics are not there. I like it more this way since I can see those green [ OK ] shown before the login screen shows up and I think this is helpful in case of errors, but why are they not hidden by a HP logo just like until that point in the boot process?

Because that was done by plymouth.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.