Broke my Manjaro installation... again

dual-boot
i3

#41

I will in a bit, I’m currently unavailable. Though I should have been connected, I’ll try again when I get connected (it shouldn’t take too long, a long half an hour maximum)
EDIT: Ok, definitely lomgee

I meant “in my GNOME desktop”. I do see I am on manjaro, as I’ve seen the name I gave my system somewhere in the output and it has my keyboard layout (Spanish Default), which I don’t get in grub.

I did reboot, but I still got to the same prompt once again. I will try again soon though.


#42

Ok, I ran wifi-menu but it said I needed dialog installed to be able to use it. Obviously, i tried installing it, but it work (couldn’t access the repository).
I went to get an ethernet cable to be able to ignore the possible internet problems and what? It turns out my laptop doesn’t have an ethernet cable entry. So I can’t test if the wifi is connected, or make sure it is?

That caught me off guard.


#43

Use smartphone tethering for internet, if available…


#44

I mean, I currently have internet connection, but I don’t know if it is detected when using linux, or how to know if I’m connected to the internet, because, nevertheless, I can’t get the packages from the repositories.

I’m on Windows 10 for the moment, trying to learn about i3 on Virtual Box as, if I have to reinstall completely Manjaro, I may as well find out first if I’d like to try i3 or to stuck with gnome

(God, this thread is becoming so huge I’m feeling anxious.)


#45

In terminal

ping -c3 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=122 time=24.0 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=122 time=15.8 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=122 time=15.5 ms

TL;DR :wink:
You all talk all the time from Virtual Box in Windows?


Network can connect locally, but not to external locations
#46

ping -c3 8.8.8.8
connect: Network is unreachable

This is what comes out when I try out the command you suggested (8.8.8.8 is. Google, right?)

Now that we know that I can’t connect to the internet, what do I do? Can I load the files I need from an USB?


#47

Try:

ping -c3 google.com

#48

Isn’t that the same as 8.8.8.8?

I’m still trying it though, give me a second


#49
ping -c3 localhost

No it’s not the same, because sometimes you can resolve by domain name, but not by IP address.


#50

Oh, I didn’t know that

I tried a couple of domains, but still couldn’t connect

I did get some output from localhost. Photo coming up soon


#51

If localhost is working than the problem is your configuration, not your network adapter.

You should really open a separate support thread for your networking issue, as this was not the subject of this thread.


#52

Ok, but what is exactly the issue then? I don’t really understand what we were trying to acomplish, so I don’t know what’s the specific problem. I mean, for me, my installation is still broken, so if I open a new thread, what should I call this one, and what should I call the next one?


#53

Network can connect locally, but not to external locations.


#54


You future readers can follow the issue over here


#55

You should have a Linux Live ISO USB. If not, then go find one, or stop your adventure with Linux here.

Boot your Live ISO and get info from your drive with OS installed

inxi -SMGDpuoxxxz

If your Live ISO doesn’t have inxi installed, search the web on how to install it in your current Live ISO system.

Alternatively, mount the Linux partitions of your drive and find and post these from each partition (if any). Use your brain to convert the commands to match the proper path values according to each current mount point (like /mnt/partition1):

sudo cat /boot/grub/grub.cfg | grep -A 20 -E "10_linux"
cat /etc/os-release
cat /etc/lsb-release
cat /etc/fstab
ls -l /usr/share/xsessions/*