Broke my Manjaro installation... again

dual-boot
i3

#21

I mean that, from grub, I didn’t select any partition, I just pressed c and entered the command line. So I don’t know which partition I’m getting the information from.


#22

Oh… it doesn’t matter as long as you get to grub>

What matters is if your (hd0,2) is gnome.
Do you know this?


#23

This is what i got after running efibootmgr -v

root@amnesia:~# efibootmgr -v
BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 2001,0001,0002,2002,2003
Boot0000* EFI USB Device (TOSHIBA TransMemory)	PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,GPT,7b3e0c67-a881-4e66-b03e-ee49ea0b3e7a,0x800,0x1000000)RC
Boot0001* Windows Boot Manager	HD(1,GPT,92cdf802-3e4b-40ef-bb9c-31b6f70526b7,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...B................
Boot0002* Manjaro	HD(1,GPT,92cdf802-3e4b-40ef-bb9c-31b6f70526b7,0x800,0x32000)/File(\EFI\Manjaro\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

This is from TAILS I have isntalled on a pendrive, I don’t know if this is what you meant


#24

Do post 16.


#25

I do not, sorry. I didn’t know I should have written that down


#26

The whole thing, or just the last commands?

TAILS is based on Debian, do I even have pacman?



# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I found nothing of what you talked abuout. Do I just apehend it?


#27

All of them! All commands. Do not miss any.
Important to do all!
When (if) booted it will Manjaro, not Debian tails.


#28

Ok, I’m logging out of TAILS and onto grub again. I will follow up in this same reply, but with a mention


Done, I ran all commands with no errors returned. Do I turn off the computer now and try to boot again or do I just exit the command line? I took a picture of every step btw


#29

Reboot.


#30


Nothing…
grub changed though, now there is only one Manjaro and Windows


#31

Okay, noted. Now that looks like another issue.
You’ve got your grub, it tries to boot. Good.
Okay, now try to boot to fallback (since the error is not loading modules). At grub menu, select that not the default entry.
And put in a ‘3’ (no appostrophes just 3) at the linux line.
Boot to prompt. Let us know if it can boot to prompt.
If it boots to prompt, login with passwaord, do (as root, sudo)

pacman -Syyuu
mkinitcpio -P

Let ius know if that boots to prompt (my job is done here) and let us know if the commands work to boot normally (else others will have to come in to help).


Network can connect locally, but not to external locations
#32

Other than that (kernel modules), there is something in your fstab (media/shared ?) that is preventing your boot. Comment that out in your fstab and check if it boots.
If there are other entries in fstab that is not necessary (other than /, swap (check that too), /boot/efi, /home, if any, comment out anything not necessary for the OS)


#33

What do you mean by linux line?


And I have booted to a command prompt successfully. Do I continue with the commands?


#34

Yahoo!!

Yes!! the 2 commands are good. Do them.


#35

I ran pacman -Syyuu and this outputs. Ain’t looking good


#36

That is your repositories not syncing.
Sync it first!!

The long sure way…
sudo pacman-mirrors -c all
sudo pacman -Syyuu
sudo mkinitcpio -P

If you haven’t done ‘pacman-Syu’ for some time (looks like it) do this at the prompt.
Follow the method you booted to prompt to do the commands.


#37

Ok, I ran all commands, but it still shows all of the error messages on my last post, and I’m not booted in. It did show something for sudo mkinitcpio -P. Do I reboot?


#38

Er…? What? You need to be booted in Manjaro to do this.
Go boot to prompt as you did last time.
Errors when booting, never mind. But when booted (to prompt), do the commands.
sudo pacman-mirrors -c all
sudo pacman -Syyuu
sudo mkinitcpio -P

Yes. After doing the above at prompt.


#39

run wifi-menu for wifi internet connection


#40

Ah… manzoorahmed reminded us…
it could just be that you are not connected.
Reboot to try again.
wifi is for non-ethernet
if wired, you could still not be connected.
Try reboot.