Broke my Manjaro installation... again

dual-boot
i3

#1

So, I may have actually really messed up my gnome installation.

I’ve been watching some videos on i3 so I decided to give it a try. I have a laptop with 2 SSD, one of 250GB which came with Windows 10 and another of 500GB. I originally had it with Manjaro GNOME on 250 GB and another partition of 250GB for storage, though I didn’t use it that much. That’s why I thought it would be perfect to repurpose it for a brand new Manjaro i3wm.

I installed it, but after restarting my laptop, and trying to access Manjaro i3, I was greeted by this (Sorry for the image, had no other way to get it)

I tried to get to my other partition and this showed up

And I now officially don’t know what to do. Help


Network can connect locally, but not to external locations
#2
sudo pacman -S wgetpaste
inxi -Fxxxz | wgetpaste
dmesg | grep error | wgetpaste
journalctl -xb | wgetpaste

#3

You should put the password in, enter maintenance mode and run systemctl status systemd-modules-load.service to see which module failed to load.

Basically…just do what it tells you to do on the screen :wink:

Can you explain what you did here and how your disks are setup.


#4

I forgot to tell :smiley:


#5

Ok. I have 2 SSDs in my laptop:
• A 250GB with Windows 10
• A 500GB one I added later
From this last SSD, half of it was being used by Manjaro, and the other half as a separate storage partition I was using to be both accessed from the Linux and Windows OS.

After installing Manjaro i3, I turned off the laptop and went to choose my previously working Manjaro Gnome partition.

This is what I’m usually greeted with.


And the text you are talking about is what I got from entering the upper Manjaro, Manjaro GNOME.


#6

You appear to have different issues with each installation. As long as you didn’t accidentally install over your other install, they both should be fixable.

In order to reduce confusion. Which install do you want to work on first?


#7

I’m more worried about my GNOME installation, because it is the actual one I use. I wouldn’t mind uninstalling and reinstalling i3


#8

Chroot in your gnome installation, update the system and make gnome 1st boot, using efibootmgr.
Check the tutorial.


#9

This is an interesting read. May help you :stuck_out_tongue:

When you are in the chroot environment, run fsck -fy on all your partitions.


#10

Ok, something big happened. Before I could try any of your suggestions, I can no longer access the terminal. This is what I’m greeted with now.

Because I can still access the GRUB command line, I’ll try petsam’s solution, but I don’t know if this changes anything

Btw, I didn’t touch anything, I just booted up the machine again. Though I accidentally booted to Windows at first because my laptop redirected me there.


Network can connect locally, but not to external locations
#11

Looks like your gnome is installed in uefi and your i3 in bios-legacy (or in a msdos disk).
Using petsam’s link above, make sure you boot liveusb in uefi mode, select the gnome partition

grub> search.file /etc/manjaro-release

There will be multiple output of your manjaro partitions, use the right one (say (hd2,5)) you want to boot into as follows

grub> set root=(hd2,5)

and boot into gnome not i3.

Then follow the rest of the instructions there.
Reminder - you need to do following as well as the other commands there.

sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create
sudo grub-editenv - set boot_success=0
sudo grub-install /dev/sda
sudo update-grub

We’ll worry about the i3 installation later. Most likely (without your data) you will need to redo/reinstall your i3.


#12

I tried following both procedures, and none worked.


I must say, I’m not really that technical, so I may be ignoring something obvious


#13

What’s output of

search.file /etc/manjaro-release 

#14

At first, I remember it printing out (without the “)
" hd0,gpt2 hd0,gpt2”

Now, it prints this (The file is more than 1MB):


#15

Boot a Live ISO in UEFI and try to “Find EFI bootloaders”.
Or in the Live session check

efibootmgr -v

#16

So your gnome is (hd0,gpt2)
If that is your i3, abort.

If gnome is (hd0,gpt2), continue as per that link (below the [Simple First Start]),

grub> set root=(hd0,2)
grub> probe -u $root --set=abc
grub> ls ($root)/boot/

Copy down kernel and initrd file, say vmlinuz-4.14-x86_64 and initramfs-4.14-x86_64.img
Use the right kernel below like 4.18 or 4.19 or…

grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.19-x86_64.img
grub> boot

When booted up to manjaro installed OS, at terminal
Make sure you have version grub 2.03.2-1 or later (check with pacman -Q grub)
Otherwise, to get it

pacman -Syyuu

In /etc/default/grub, make sure you have one of the following specified.
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT_STYLE=countdown

Also in /etc/default/grub, make sure you have
GRUB_TIMEOUT=5 (or more; suggest 10, change to 5 later on when you feel more confident)

  1. At terminal,
sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create
sudo grub-editenv - set boot_success=0
sudo grub-install /dev/sda
sudo update-grub


#17

How do I know if it is the Gnome or the i3 one? I just pressed down c, I didn’t select any


#18

You don’t know what partitions you installed to?
Then follow petsam’s detect efiboot loader above.
If that is your i3, abort.

Did you install i3 over your gnome?


#19

Ok.
Seriously though, should I know the name of my partitions? I thought it was orientative, not something someone should know.

I absolutely did not. I installed it over a FAT32 partition, and before installing I saw it on the UI of the installer.


#20

I don’t understand this. petsam, you know what’s Ayhon is talking about? Explain please if you know.
Anyway, continue from my last post.,
BTW petsam’s detect efibootefi will also fail because it won’t boot.
My method will also fail if your manjaro is totally messed up which is possible.