Broke my display driver!

Hello,
yesterday I was playing with display driver and actually tried to install AMD driver by ViOLO :neutral_face:. I don't know why I did that :frowning_face:. Anyway I installed

  1. vulkan-radeon-noglvnd 18.3.2-1
  2. vulkan-intel-noglvnd 18.3.2-1
  3. opencl-mesa-noglvnd 18.3.2-1
    But after that some problem were occurring while starting Manjaro. It wont start in the first time but after a hard reboot It'll start normally so I thought I'll remove what I installed. But now after removing those 3 drivers, the desktop effects is no longer working. No animation is working.

Here is what my looks like,

System:    Host: sobuj-pc Kernel: 5.3.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           Desktop: KDE Plasma 5.17.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP ProBook 440 G1 v: A3009E510000 
           serial: <root required> 
           Mobo: Hewlett-Packard model: 1944 v: KBC Version 12.F4 serial: <root required> 
           BIOS: Hewlett-Packard v: L74 Ver. 01.49 date: 08/29/2019 
Battery:   ID-1: BAT0 charge: 39.9 Wh condition: 40.6/40.6 Wh (100%) model: Hewlett-Packard Primary 
           status: Unknown 
CPU:       Topology: Dual Core model: Intel Core i3-4100M bits: 64 type: MT MCP arch: Haswell rev: 3 
           L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19962 
           Speed: 1690 MHz min/max: 800/2500 MHz Core speeds (MHz): 1: 1690 2: 2184 3: 1841 4: 1878 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Hewlett-Packard driver: i915 
           v: kernel bus ID: 00:02.0 
           Device-2: AMD Mars [Radeon HD 8670A/8670M/8750M] vendor: Hewlett-Packard driver: radeon 
           v: kernel bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: intel,radeon FAILED: ati unloaded: modesetting
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.2.6 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.3.12-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
           driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 
           IF: enp3s0 state: down mac: a0:1d:48:ab:88:17 
           Device-2: Intel Wireless 3160 driver: iwlwifi v: kernel port: 3000 bus ID: 04:00.0 
           IF: wlo1 state: up mac: a0:88:69:be:63:a1 
Drives:    Local Storage: total: 465.76 GiB used: 148.75 GiB (31.9%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680 size: 465.76 GiB 
Partition: ID-1: / size: 97.45 GiB used: 50.92 GiB (52.2%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 62.0 C mobo: 0.0 C gpu: radeon temp: 56 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 215 Uptime: 10m Memory: 11.59 GiB used: 1.53 GiB (13.2%) Init: systemd Compilers: 
           gcc: 9.2.0 Shell: bash v: 5.0.11 inxi: 3.0.36

I've tried to force reinstall display driver using sudo mhwd -a pci nonfree 0300 but it gives me `

Skipping already installed config 'video-linux' for device: 0000:01:00.0 (0300:1002:6600) Display controller ATI Technologies Inc Mars [Radeon HD 8670A/8670M/8750M]
Skipping already installed config 'video-linux' for device: 0000:00:02.0 (0300:8086:0416) Display controller Intel Corporation 4th Gen Core Processor Integrated Graphics Controller`

I tried restoring from time shift backup but that didn't work as well.
I'd really appreciate if anyone could guide me regarding how to fix the problem.
Thank you.
Sobuj53

check which drivers mhwd has installed, you should only have video-linux
mhwd -li

manually remove whatever video drivers are listed and install video-linux again instead of just reinstalling it. both amd and intel drivers are part of the "free" package, dont try to use nonfree

sudo mhwd -r pci video-linux
sudo mhwd -a pci free 0300

and also check these 2 directories to make sure that aur package didnt leave behind a xorg configuration that might be causing issues

/etc/X11/
/etc/X11/xorg.conf.d/

Hi Thank you for the reply. Sorry couldn't reply you earlier. I had re-installed Manjaro again and you know the rest :grinning: it's solved. Now a days I'm doing all the testing stuff in VM and if it works then I implement them on my main machine.

Forum kindly sponsored by