Broadcom 4360 wifi issue on MacBook Air 2013

While I found a solution after scouring the posts, I simply wish to report an issue:

I install manjaro on the MacBook air 2013 a while ago.
At first the wifi did work, I believe I connected while using a live USB.
Then the WiFi did not work after I installed a minimal GNOME desktop.
Somehow I got it to work through a guide I found, without needing install packages etc. myself (not easy for beginners, such as the person whose device I installed linux on).

Needing to switch to KDE due to necessary packages, there were conflicts with packages and settings, and the default guide to install the KDE desktop did not work super well. Manjaro customization was not possible for me to install.

So I figured to just reinstall the OS, with the KDE desktop.
I did, and suddenly the wifi did not work. Nor when I used the hardware detection etc…

I found the linux5…-rt-broadcom-wl package to solve the issue, as concluded in another thread.

I do not know why it was so much more difficult on the KDE default installation than GNOME, but figured to report it.

#Hi @ithxi, and welcome!

If that is correct, it look like a real time kernel driver. Which is only necessary for certain things. Generally, it’s not recommended to use.

Furthermore, I recommend that you use the -dkms driver package, since it gets rebuilt with kernel updates. And I see a broadcom wireless dkms driver in the community repository:

$ pamac search broadcom | grep --ignore-case dkms
broadcom-wl-dkms-248                          AUR
broadcom-wl-dkms                             community

So try installing it, rather:

pamac build broadcom-wl-dkms

…and see if that works.


And kudos for figuring it out to there on your own!

Thanks for the reply.

Turned out that while the adapter now was interfaced with, and could scan for networks, there was another issue. The device was unable to connect with the router, claiming something about no secrets beings exchanged… I tried some suggested solution to remove randomization of mac address, and that led to NetworkManager being unable to start/not working. Reverting from that, the WiFi suddenly no longer worked. Admittedly, somewhere along the way, I had tried removing packages I had installed that led nowhere…

Anyway, I tried the broadcom-wl-dkms as suggested again. It does not work.
Any suggestions are more than welcome…

In that case, please provide more information:

Hope you manage!


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:


pasted text


This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

Most likely it is a problem of WPA2 WPA3 or a mixed Mode WPA2/3. Try switching to WPA2 only on the Router or explictly use WPA3. Mixed mode does not work correctly.

Thanks, I got it working tho!

A so-so solution!
First, I needed install “linux headers” (I guess it will be necessary to install headers, if the kernel is upgraded?). Then the wifi showed with the dkms package.

The “no secrets …” issue, is slightly embarrasing. I’ll report it anyway: I changed the user-password for ease of administration. This caused loss of access to the KDE wallet - and I got this annoying pop-up which I had closed earlier. Apparently, the wifi keys are stored in the wallet, that was passworded with the users pw that I did not have access to. I guess it is a good thing, even if I was confused…

So the solution…: Linux headers + dkms packages and entering the password in the keyring

Forgive me, I did not use linux for a few years. Let alone a laptop/PC…

Thanks for the support

1 Like

After a lot of searching, I came across this:

…for what it’s worth.

So, according to that solution:

  1. Install the kernel headers:
pamac install $(pamac list --quiet --installed | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

This will install the headers for all installed kernels.

  1. Install the driver (probably rebuild in your case):
pamac install broadcom-wl-dkms

3 Reboot.

Hope this helps!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.