Broadcast message (systemd-journald) each time Dolphin opens a mountpoint folder

Hi everyone, I always get the same error each time I open a mountpoint (folders in /media/) with Dolphin. Despite I can see the files and use them, it's annoying to have the same notification each time I open those folders.

The errors are like this (they're always due to lost+found):

Broadcast message from systemd-journald@matias-pc (Mon 2019-11-18 23:33:08 -03):
kdeinit5[3609]: inotify_add_watch(/media/files/lost+found) failed: (Permission denied)

Should I run something like sudo chown matias lost+found or sudo chown matias:matias lost+found? Is it secure to do that to the lost+found folder?

PS: the error is solved by running the commands mentioned before, but I don't know if it's a good practice or if it's secure to chown lost+found.

/media/ isnt a default location - so I suppose this comes from somewhere else ?
who owns /media/files/lost+found ?

(usually mounts would go under /run/media/USERNAME/)

... And what filesystem is on there? Is it a UNIX-style filesystem or a Microsoft filesystem?

Thanks for your fast responses.

I mounted manually three ext4 partitions on /media (backups, development, files), by creating that folder as root. Right now that folder has this structure:

$ ls -l /media
total 12
drwxr-xr-x  4 matias matias 4096 nov 18 14:00 backups
drwxr-xr-x 10 matias matias 4096 nov 18 23:28 development
drwxr-xr-x 13 matias matias 4096 nov 18 02:19 files

The three lost+found folders have the same permissions (note that there are files I have to restore in one of them):

drwx------ 29 root   root   61440 nov 14 13:50  lost+found

Why don't you add them to /etc/fstab? You can still have them in there without that they get mounted automatically at boot time, if you add noauto,nofail to the mount options.

They are mounted via /etc/fstab, but without the nofail option. Will try that now to see how it goes.

Same... Added the nofail option and rebooted but the error keeps showing up.

Maybe there is an option to make inotify_add_watch ignore the lost+found folders?

I think it's the Directory Watcher service from KDE what causes the problem... Will look into that.

Yes, that's what inotify is/does. I don't have that enabled here, so perhaps disabling it will solve your problem.

Maybe, how did you disabled it? In "Settings > Startup and Shutdown > Background services" there is a service called Directory Watcher (running) but I can't stop/disable it. :cold_sweat:

I didn't, actually. It has never been enabled here.

Background_Services

Well that's weird o.o.

Maybe there's a problem with my setup since sometimes there are lots of random dumps.

An example from just now:
Broadcast message from systemd-journald@matias-pc (Tue 2019-11-19 01:05:25 -03):
 
systemd-coredump[3166]: Process 224 (systemd-udevd) of user 0 dumped core.

Stack trace of thread 224:
#0  0x00007f239191115b open (libc.so.6)
#1  0x0000564f740830cc n/a (systemd-udevd)
#2  0x0000564f7408380d n/a (systemd-udevd)
#3  0x00007f2391606758 n/a (libsystemd-shared-242.so)
#4  0x00007f2391606a0b sd_event_dispatch (libsystemd-shared-242.so)
#5  0x00007f2391606bd1 sd_event_run (libsystemd-shared-242.so)
#6  0x00007f2391606e10 sd_event_loop (libsystemd-shared-242.so)
#7  0x0000564f74064d70 n/a (systemd-udevd)
#8  0x00007f2391848153 __libc_start_main (libc.so.6)
#9  0x0000564f7406592e n/a (systemd-udevd)

systemd-udevd is your device manager. If that dumps its core, then there's something seriously wrong with your system. :thinking:

Forum kindly sponsored by