Brightness control not working

  Kernel: 6.1.26-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1 Desktop: GNOME v: 43.5
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05 serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <superuser required>
    UEFI-[Legacy]: LENOVO v: EUCN19WW date: 05/12/2020
  ID-1: BAT0 charge: 42.4 Wh (100.0%) condition: 42.4/60.0 Wh (70.7%) volts: 17.1 min: 15.4
    model: Celxpert L19C4PC0 status: full
  Info: 8-core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
    rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 8 MiB
  Speed (MHz): avg: 1533 high: 3528 min/max: 1400/2900 boost: enabled cores: 1: 1400 2: 3528
    3: 1400 4: 1400 5: 1400 6: 1400 7: 1400 8: 1400 9: 1397 10: 1397 11: 1400 12: 1400 13: 1397
    14: 1396 15: 1417 16: 1397 bogomips: 92668
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Lenovo driver: nvidia v: 530.41.03
    arch: Turing bus-ID: 01:00.0
  Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 bus-ID: 05:00.0
    temp: 42.0 C
  Device-3: Chicony Integrated Camera driver: uvcvideo type: USB bus-ID: 1-3:2
  Display: x11 server: v: with: Xwayland v: 23.1.1 driver: X:
    loaded: amdgpu,nvidia dri: radeonsi gpu: amdgpu resolution: 1920x1080~120Hz
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A bus-ID: 05:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 05:00.6
  API: ALSA v: k6.1.26-1-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.70 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
    v: kernel port: 2000 bus-ID: 03:00.0
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
  IF: wlp4s0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB bus-ID: 3-3:3
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 340.33 GiB (71.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L2 size: 476.94 GiB temp: 40.9 C
  ID-1: / size: 459.72 GiB used: 340.33 GiB (74.0%) fs: ext4 dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p2
  System Temperatures: cpu: 57.1 C mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (RPM): N/A
  Processes: 360 Uptime: 7m Memory: available: 15 GiB used: 3.21 GiB (21.4%) Init: systemd
  Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1697 Client: gnome-shell v: 43.5 inxi: 3.3.27

The brightness slider doesn’t change the brightness. Even on the Fn keys it doesn’t work. The slider just moves without changing the brightness. I’ve tried three kernels, 6.1, 6.2 and 6.3.

Maybe have a look here: Backlight - ArchWiki

I tried these three:


Still can’t change brightness.

Probably, you are affected by the revamp of the subsystem since kernel 6.1. Try an older one. I would advise you to report that to the developer:

Recently there was a similar issue: Laptop display detected but not working

I tried 5.15. It still doesn’t work. Also, anything older than 6.1 breaks vulkan.

Only thing I could suggest is updating the firmware and use UEFI instead of Legacy. Otherwise no idea, since you read the wiki article.

How do I update the BIOS? The vendor’s website has the file as .exe

Well, you know what most people do: Install Windows, but if you are smart you would use something like that: since Lenovo supports only Windows on this Laptop. :man_shrugging:

Sigh yet another reason to go back to Windows.

Do what ever you like. My vendor HP has online update in the UEFI integrated, I just need a network cable connected. Fully independent of the OS. Just update, and you are safe. :man_shrugging: Maybe Lenovo has something similar?

It is also not so old:

  Type: Desktop System: HP product: HP EliteDesk 800 G4 DM 65W v: N/A
    serial: <filter> Chassis: type: 6 serial: <filter>
  Mobo: HP model: 845A v: KBC Version 07.D2.00 serial: <filter> UEFI: HP
    v: Q21 Ver. 02.22.00 date: 11/29/2022