Brightness buttons not working on HP EliteBook 8570p (Budgie)

When I press the brightness button with "fn" buton or without, the brighness keys on my elitebook have no function. I can't see any setting for that. I run Budgie. It works otherwise very well. Any idea?

[mx@hp-laptop ~]$ inxi -Fxzc0
System:
  Host: hp-laptop Kernel: 5.1.8-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: Budgie 10.5 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP EliteBook 8570p 
  v: A1029D1103 serial: <filter> 
  Mobo: Hewlett-Packard model: 17A7 v: KBC Version 42.38 serial: <filter> 
  UEFI: Hewlett-Packard v: 68ICF Ver. F.62 date: 04/07/2015 
Battery:
  ID-1: BAT0 charge: 59.0 Wh condition: 59.0/59.0 Wh (100%) 
  model: Hewlett-Packard Primary status: Full 
CPU:
  Topology: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19960 
  Speed: 1197 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1198 2: 1197 
  3: 1197 4: 1197 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.org 1.20.5 driver: intel unloaded: modesetting 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.0.6 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.1.8-1-MANJARO 
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard 
  driver: e1000e v: 3.2.6-k port: 2060 bus ID: 00:19.0 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM43228 802.11a/b/g/n 
  vendor: Hewlett-Packard BCM943228HM4L driver: bcma-pci-bridge v: N/A 
  port: 2040 bus ID: 03:00.0 
  IF-ID-1: wlp3s0b1 state: up mac: <filter> 
Drives:
  Local Storage: total: 232.89 GiB used: 52.43 GiB (22.5%) 
  ID-1: /dev/sda vendor: Western Digital model: WDS250G2B0A-00SM50 
  size: 232.89 GiB 
Partition:
  ID-1: / size: 227.91 GiB used: 52.43 GiB (23.0%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 193 Uptime: 10m Memory: 11.59 GiB used: 977.2 MiB (8.2%) 
  Init: systemd Compilers: gcc: 8.3.0 Shell: bash v: 5.0.7 inxi: 3.0.34 
[mx@hp-laptop ~]$ 

you need to add a kernel parameter to grub config

sudo nano /etc/default/grub
edit and add acpi_backlight=vendor to this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor"

save/exit, then
sudo update-grub
reboot and test. that should do it but if it's still not working, also add acpi_osi=Linux

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor acpi_osi=Linux"

save/exit
sudo update-grub
reboot

2 Likes

Perfect! I did it in the past and forgot. It seems I have to document all this stuff. :wink:

1 Like

good, glad it worked out. did you need the acpi_osi parameter or just the acpi_backlight?

Forum kindly sponsored by Bytemark