Brightness and Nightmode is not working, xbacklight no devices found

OK so first of all my system specs :-

  • i3 3220
    -gtx 1050ti
    display connector type - HDMI-0

I realize that nvdia and opensource aint great friends but alteast for now i cant switch.
First i replaced my current kernel driver from nouveau to nvdia.

nvidia-settings: version 455.45.01

My problems arises when I want to update my system brightness along with turning Night Light on ( Basically i need to adjust screen temparature to act as a blue light filter).
xbacklight seems out of the question as the arch wiki points it only works with intel kernel.
For now i am using “brightness - settings” from LXQt but this is just a software solution, moreover whenever i launch this application , KDE’s built in night color control stops working.

All I need is a way to lower screen brightness while still keeping night Color scheme.
A terminal solution is preffered over software solution but i am not chosing.

I have used windows 7, 10, pop os , linux mint , heck even a hackintosh but never encountered such a issue most have built in brightness solution.
Also this is my first arch distro so still figuring things out.

I am replying to my question myself maybe this is wierd but its 14h already and nobody has answered yet, that was a bit sad.

Anyways tired of waiting i tried out almost everything, turns out the solution is not is not xbacklight or a aur repo.
Its actually simple.
Get latest nvdia drivers from pamac/yay -> reboot -> install redshift and dependencies required.
then magic type this in the terminal -> redshift -P -O 3500 -b0.57

i.e. -> redshift -P -O “TEMPARATURE” -b"brightness value"

b(max) = 1
b(min) = 0

Works flawless, make sure night color is turned of or else you will get flickering effect.
Also if an instance of redshift is running close is from the tray ( mutiple instances cause flicker).
If possible remove other brightness control solutions.

If you want more customization check out redshift arch page, this thing is real mighty.
Keep in mind you have to create a startup script if you want this setting for every boot on.

There seems to be someting different with the i915 kernel driver. After adding:

i915.enable_dpcd_backlight=0

To GRUB_CMDLINE_LINUX in /etc/default/grub
and doing a sudo update-grub

It worked again.

I found my answer on this forum but cannot add links :-s

Always amazed to see this kind of messages lol

“How dare people not respond as quickly as I want!!”

:rofl: