Brave Browser stopped working

Anybody any ideas what to do about this?

[4029:4029:0724/] execv /usr/lib/brave-beta/crashpad_handler: Permission denied (13)

Happened today after it was upgraded from 1.25.62-1 to 1.28.88-1.
Downgraded from beta to main ( 1.27.108-1) but the error remains the same and neither version starts.

That browser is quite unstable … which is why it has been removed from the Manjaro repo - at least that what I read previously on the forum - and your update must have been compiled from AUR PKGBUILD.

This user reported the same error with Chromium. Apparently it’s an Apparmor issue:

Thanks you both for the prompt replies.

Both Brave and Brave-beta are from the community repo not AUR.
That certainly looks like the same issue. Pity he didn’t reveal how to fix it! I see apparmor was last updated in May and Brave has certainly worked well enough between then and now so it isn’t update related.

There is no urgency over this, Brave is not my main browser only a secondary one.

Not sure how you’re using Apparmor, but I’m using aa-logprof to update my Apparmor profiles. It’s the easiest way to do this and you should be asked, if you want to allow the blocked library.

Hi Ares, just checking on that and I stopped and disabled apparmor via systemctl but it made no difference to the error message so maybe apparmor is not the answer?

I’m not a Apparmor expert, but when something doesn’t work you should set the profile to complain mode aa-complain [path to profile]. After that you could check the logs, update the profile and put it in enforce mode again.

I suggest you to read some guides if you want to stay independent from third party profiles :slightly_smiling_face:
For example

Thanks for the link, but as I am using firejail and have been for a long time, I prefer not to use apparmor at the same time as they are thought to sometimes conflict with each other. I must admit that it was so long ago I disabled apparmor I had forgotten about it.

Why does the manjaro maintainer suggest Vivaldi in the post which is partly proprietary? Also I had never had Brave crash. Its just under active development and there are too many releases as its a quite young browser.


About Brave, just do a forum or a Web search. There has been several proofs of mistrust about it along the years.

Ok I get it

Well, I have found a temporary work round for this problem which is to install brave-beta-bin from AUR, version number 1.28.90-1. It installs as a completely new browser though and does not recognise the currently installed version so if you have customised the settings/addons etc you will have to repeat all that, you can’t just import them. I will use this temporarily until the version from community sorts itself out.

Thanks for replies.

A few minutes ago, i updated my system, but when i tried to access brave, it said /var/log/syslog cant be accessed or something along those lines, I was getting irritated so, I thought of doing something that usually fixed my previous issues with updates, using pamac-manager. I got the brave-bin and there! It worked just like before, no data lost and the extensions are still there. So I suggest try using the pamac-manager. DO NOTE THAT: the version brave-bin uses is 1.26* so yea…

For those of you that had problems with Brave and changed to brave-beta as I did, I notice today (29 jul) that the update to brave is now fully working again. For some reason it is no longer called ‘Brave’ but ‘Brave-browser’ (version 1.26.74-1) so it will uninstall ‘brave’ before installing itself. Its functionality is exactly the same as brave was before the problem I posted in the opening post of this thread. So all is back to normal and if you don’t like the constant updates to brave-beta-bin you could remove it.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.