Brave-browser-1.27.109-1 fails to install

I’m trying to install brave-browser from the community repo and it gives me an error about a damaged package (sorry, text is in German):

Fehler: brave-browser: Signatur von "Stefano Capitani <stefano@manjaro.org>" ist ungültig
:: Datei /var/cache/pacman/pkg/brave-browser-1.27.109-1-x86_64.pkg.tar.zst ist beschädigt 
(Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 

Does anyone else have that problem?

I am having the same problem.

empty your pacman cache and retry.

pacman -Scc

or

paccache -ruk0

Just gave that a try and same problem occurs.

Brave doesn’t show up in the first update window to be able to deselect it, either.

Yeah I tried it too, didn’t work. Pacman downloads the package again and the same message keeps popping up. It seems that the file in the repo is corrupt, hope someone can fix it.

Stefano Capitani - ist the problem … how can i send him a coin for a coffe in order to fix that ???

Was the brave browser added to to official repos today?

Temporarily, I was able to complete the rest of the updates by running pamac from the command line:

pamac update --ignore brave-browser brave
1 Like

This has been fixed by @Ste74 already.
For anyone else having this issue, try:

sudo pacman-mirrors -f5 && sudo pamac update
4 Likes

That command worked for me. Thanks.

brave-bin is 1.26.77 in AUR and is working fine. Use it if you would like to

This worked, thank you @Ernest1337 for prividing the answer and thanks @Ste74 for fixing the issue!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.