Botched dual boot

Good Evening, I have botched my GRUB reinstall and i am at a wall. To start off i had a working UEFI dual boot installation Manjaro KDE and WIN10. I upgraded my spinning rust for a SSD in my windows install. After reinstalling windows i attempted to reinstall the grub from manjaro (live). I tried to chroot into the system only to get the “windows did not shut down properly”. I think this is where i screwed up. I attempted a nonEFI grub install (large sigh). After finding out that my windows installation was in hybrid sleep i tried the grub install again. And now i am completely lost as to what to do.

I can run manjaro live and chroot into the root directory. Also i can mount /dev/sda3 as /mnt but i can only mount /dev/sda1 as /boot/efi.

I would really prefer not to have to reinstall manjaro if i can learn something here.

@1slotrk, welcome here.

First, you have to find a way to boot into your Windoze install and shut it down fully (switch off all Fastboot and hibernate features). Little chances to repair your system if your Windoze has only hibernated as it will lock essential parts of your file system. How to do - best ask in a Windoze forum (or hope for some other forum members to assist).

I have shut both of those features off. Also I can get in and out of my windows just fine. Also thank for the warm welcome.

Do you still

error message?

When running a live ISO please enter the following commands and post it here:

inxi -Fxxxza --no-host
sudo parted -l
sudo blkid

Use “~~~” in front and at the end to format the output nicely.

Have you tried chrooting using manjaro-chroot?
https://wiki.manjaro.org/index.php?title=GRUB/Restore_the_GRUB_Bootloader

Can you 100% confirm that both OS are installed in UEFI mode?

inxi -Fxxxza --no-host

           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro 
           misolabel=MANJARO_KDE_202 quiet systemd.show_status=1 apparmor=1 security=apparmor driver=free nouveau.modeset=1 
           i915.modeset=1 radeon.modeset=1 
           Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: Z87-G45 GAMING (MS-7821) v: 1.0 serial: <filter> UEFI: American Megatrends v: 1.9 
           date: 07/21/2014 
CPU:       Info: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 3C (60) 
           stepping: 3 microcode: 28 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64025 
           Speed: 800 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 801 7: 801 8: 801 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] vendor: eVga.com. driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:17c8 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") s-diag: 1055mm (41.5") 
           Monitor-1: DVI-I-1 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") diag: 609mm (24") 
           Monitor-2: HDMI-1 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") diag: 609mm (24") 
           OpenGL: renderer: NV120 v: 4.3 Mesa 20.2.3 direct render: Yes 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:8c20 
           Device-2: NVIDIA GM200 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fb0 
           Sound Server: ALSA v: k5.9.11-3-MANJARO 
Network:   Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 1969:e091 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 6.61 TiB used: 156.8 MiB (0.0%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: DB6Q scheme: GPT 
           ID-2: /dev/sdb vendor: SanDisk model: SSD PLUS 1000GB size: 931.52 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 00RL scheme: GPT 
           ID-3: /dev/sdc vendor: Seagate model: ST4000DM000-1CD168 size: 3.64 TiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 5900 rpm serial: <filter> rev: CC43 scheme: GPT 
           ID-4: /dev/sdd vendor: Kingston model: SA400S37480G size: 447.13 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 71B1 scheme: MBR 
           ID-5: /dev/sde vendor: Seagate model: ST31500541AS size: 1.36 TiB block size: physical: 512 B logical: 512 B 
           speed: 3.0 Gb/s rotation: 5900 rpm serial: <filter> rev: CC95 scheme: MBR 
           ID-6: /dev/sdi type: USB vendor: Lexar model: USB Flash Drive size: 29.82 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1100 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: N/A size: 11.68 GiB used: 156.8 MiB (1.3%) fs: overlay source: ERR-102 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 29.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 750 
Info:      Processes: 251 Uptime: 2m Memory: 15.58 GiB used: 1.10 GiB (7.1%) Init: systemd v: 246 Compilers: gcc: N/A 
           Packages: pacman: 1224 lib: 332 flatpak: 0 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.0

parted -l

Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  525MB   524MB   fat32                 msftdata
 2      525MB   4720MB  4194MB  linux-swap(v1)        swap
 3      4720MB  250GB   245GB   ext4


Model: ATA SanDisk SSD PLUS (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  106MB   105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB   16.8MB               Microsoft reserved partition  msftres
 3      123MB   1000GB  1000GB  ntfs         Basic data partition          msftdata
 4      1000GB  1000GB  523MB   ntfs                                       hidden, diag


Model: ATA ST4000DM000-1CD1 (scsi)
Disk /dev/sdc: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name      Flags
 1      1049kB  4001GB  4001GB  ext4         storage2


Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sdd: 480GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  480GB  480GB  primary  ntfs


Model: ATA ST31500541AS (scsi)
Disk /dev/sde: 1500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  1500GB  1500GB  primary  ext4


Model: Lexar USB Flash Drive (scsi)
Disk /dev/sdi: 32.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3103MB  3107MB  4194kB  primary               esp

blkid

/dev/sda2: UUID="cef85e92-9280-44af-a839-d03387fd97de" TYPE="swap" PARTUUID="77428456-bc89-4e8e-8804-4d908ad93bc3"
/dev/sda3: UUID="ef097c30-9d55-4044-8fe6-bbfbab62e2f8" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="f7b6bde7-7698-2b48-80c9-ef0eec8bfbbb"
/dev/sdb1: UUID="3A44-BAA1" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="75f19ab2-f5c3-49b7-997b-6f76096e30de"
/dev/sdb3: BLOCK_SIZE="512" UUID="2A4E57144E56D7E1" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="375ca82d-bcba-49da-8356-fd9b5a3a03b6"
/dev/sdb4: BLOCK_SIZE="512" UUID="40660D6E660D65CE" TYPE="ntfs" PARTUUID="8515a63d-c45b-4496-9fe9-dc438447f513"
/dev/sdc1: UUID="7c93022f-a023-4bb5-8936-ed35280af2b5" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="storage2" PARTUUID="5119a315-dca5-40bb-bdd7-d56b2f2c9be6"
/dev/sdd1: LABEL="Games" BLOCK_SIZE="512" UUID="42383B0B0009D112" TYPE="ntfs" PARTUUID="e479c673-01"
/dev/sde1: LABEL="Storage3" UUID="a5d19aca-d1e7-4c5f-850b-d7ff92454be0" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="0d39669e-01"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/sdi1: BLOCK_SIZE="2048" UUID="2020-12-07-13-36-18-00" LABEL="MANJARO_KDE_202" TYPE="iso9660"
/dev/sdi2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="EC08-A711" BLOCK_SIZE="512" TYPE="vfat"
/dev/sdb2: PARTLABEL="Microsoft reserved partition" PARTUUID="79dc6e96-a27b-4ab9-b605-f7c3322f26ba"

I would love to say i know 100% how to verify both OSs are in UEFI but i do not. Windows for sure is and to the best of my knowledge manjaro was as well. BTW “~~~” WINNING

Here are my comments:

In your case I would check if a fresher firmware is available for your motherboard.

When you installed Manjaro did you choose the proprietary drivers?

It seems your OS are on different drives which is good. On your Manjaro EFI I miss the boot flag:

Change this and you should assign the disk sda as boot device in your firmware to see if you can boot into Manjaro. If this does not work I would try to restore the boot loader into sda1. Make sure Secure boot is disabled in your firmware, as well.

https://wiki.manjaro.org/index.php?title=GRUB/Restore_the_GRUB_Bootloader

I am on my latest firmware. Check
Yes i did use proprietary drivers, they seem to work better. What is the advantage of FOSS drivers?
I will dig around on how to change that flag and report back. Thanks so much for the help.
Secure boot is already disabled

Results of manjaro-chroot -a

 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
mount: /mnt/boot/efi: special device /dev/disk/by-uuid/D894-250B does not exist.
 --> mount: [/mnt/run/media/games]
fuse: failed to access mountpoint /mnt/run/media/games: No such file or directory

nano /etc/fstab

#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=ef097c30-9d55-4044-8fe6-bbfbab62e2f8 /              ext4    defaults,noatime 0 1
UUID=D894-250B                            /boot/efi      vfat    umask=0077 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=42383B0B0009D112                    /run/media/games     ntfs-3g    user,exec         0 0

Something looks wrong with your /dev/sda1. As long as you have not just truncated the output of sudo blkid it’s missing there. On the other hand it’s shown from parted -l. Also not good is this:

Just double check please by re-entering sudo blkid. Compare the UUID of /dev/sda1 with your /etc/fstab. if the partition /dev/sda1 is borked you could re-create it and try to re-install the grub bootloader.

Hi, @1slotrk
To verify if your Manjaro is in EFI mode:

test -d /sys/firmware/efi && echo efi || echo bios

1 Like

@Wollie, this is my EFI partition seen by parted -l:

1 1049kB 211MB 210MB fat32 msftdata

My system also does not have the boot flag and despite this it works normally… :thinking:

Alrighty, got manjaro to boot back up. I’m in it now. But for some reason the bootloader did not pop up as it normally does. (apparently i can’t embed photos)

https://photos.app.goo.gl/qD2K8k8danyLAVXe6

That is the boot selection screen. Notice UEFI OS and manjaro!!! If i boot from the UEFI OS then it drops me to the grub rescue. If i boot from the manjaro one, i boot straight into manjaro.

FYI the UUID i had listed in fstab was incorrect. Apparently grub had written itself to the hard drive that my old windows install was on. I’m very interested to know why.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.