Borderless maximized windows setting doesn't stick after update

Borderless maximized windows don't work for me anymore with the update. Previously I set BorderlessMaximizedWindows=true in ~/.config/kwinrc , but it doesn't stick. Just reverts after restart.

Is there a new way to apply that globally in KDE?

To be honest, I use Fullscreen for that...
In shortcuts, find the kwin tab and then find fullscreen. I had to reset that to F11 after the update...

So there's two - Meta+PgUp goes maximised, and F11 goes fullscreen with no border.

Don't forget, you can also map that to a mouse shortcut...
maximising fullscreen

I guess they removed the setting for normal maximising, annoying - it just overwrites the config file when you restart kwin...

I keep a separate 'scrub' gesture for removing decorations too...
hide-border

If you are using Latte-Dock make sure you see this:


Probably the same issue.

No, that was an issue that when you had windows borderless as maximised, Latte had problems with them.

I'm sure there was a setting in GUI to do it, or maybe I'm remembering from Cinnamon - with Gnome I had an add-on called 'maximus' which was designed for netbooks, when you maximise the window then the border is hidden.

Okay, I found this - and it works for maximising windows...

Open up Kwin scripts, then 'Get New Scripts'.

One titled 'Hide Titles' actually just hides the decorations... exactly the effect the OP (and myself) is missing.

It doesn't work for vertical maximising, but it's good for normal maximising.

Fullscreen isn't what I want. I have a latte bar at the top of my screen with things like menu and window title in it, so just getting rid of the border & title bar is ideal.

Okay, I found this - and it works for maximising windows...

Open up Kwin scripts, then 'Get New Scripts'.

One titled ' Hide Titles ' actually just hides the decorations... exactly the effect the OP (and myself) is missing.

And this works, thanks! To be honest, I never even noticed the "Get New Scripts" in that section lol.

1 Like

In that case, this option enabled had no effect?

Apparently not, I checked and had it enabled from the start.

You have to tick it on your selected layout as well

No, the problem is that Kwin used to have a setting - which would have the same effect as kwinrc BorderlessMaximizedWindows=true
But if you save that, then restart kwin, it is erased. Kwin doesn't accept it any more.

Forum kindly sponsored by