[Bootsplash] Provided by the kernel

kernel
bootsplash
built-in

#184

Ok I see. Looks like it doesn’t work for everyone. Or maybe you have some errors during the boot. I have to check various options on my side…
This is strange… I’ve never seen anything like running hook [blah-blah-blah]


#186

Is “systemd-bootsplash” needed and what does it do?


#187

Solved the text won’t appear after I added quiet in grub
mkinitcpio.conf
MODULES=“i915”
HOOKS=“base udev autodetect modconf block keyboard keymap resume filesystems bootsplash-manjaro”

etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT=“quiet loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0 resume=UUID=c8afc06e-d7a5-4f56-b14f-fb542d822576 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash"

Its now working good with these changes


#188

AFAIK the sequence of hooks is an important thing. Try to make your HOOKS string look like
HOOKS=(base udev autodetect modconf block keyboard keymap resume filesystems bootsplash-kde), then regenerate initrd with sudo mkinitcpio -P and update grub config with sudo update-grub.


#190

Issue solved by adding i915 in module in mkinitcpio
Now its a smooth boot with bootsplash
https://youtu.be/d1_uKYlHToQ at least its smoother than earlier


#191

@philm make this default in next iso its working good on legacy bios


#192

It is not necessary. It even makes booting on my laptop less smooth - with it I see a tail of logs right before SDDM starts and a mess of text (about services stopping, watchdog, etc) when my notebook is going to reboot. As I understand @philm tried to make a service that stops bootsplash when display manager loads. I guess it may be a good approach for those who have some visual issues with it as I described above. For me it’s not worthwhile. Moreover, I’m using bootsplash for about a year now and I haven’t had any problems with it running in a background (I knew it - switching to different tty clearly stated that splash was on; ESC key always worked though).
Regarding @Shrinivas17081997 problem, damn, I forgot I had that in MODULES. My bad. I have set up my bootsplash so long ago so I just can’t remember everything I did during those cold winter days :cold_face:


#193

Don’t remove quiet from grub


#194

Well, I fixed it with bootsplash-systemd 0.1.1-2. It was always about timing. It is needed, else the splash runs non stop on tty1 :wink:


#195

I got used to it, please! :grinning:
Didn’t know cuz Russian mirrors sync lag is always about a 2-4 hours at least.
OK, I gonna try it :OKAY_FACE:

If you mean that you haven’t removed it, well, me too, and I didn’t notice anything extraordinary.


#196

I noticed.its not showing me any text at startup and at shutdown only bootsplash is shown at startup.


#197

Adding the bootsplash would remove the major gripe people have with silent boot (possibility to mistake long boot with stuck one), wouldn’t it?


#198

There is no speed differences as both technologies use the framebuffer. Boths are included in the kernel. No extra service like userspace plymouth is needed.


#199

I don’t think so,combination of both is good as even if vendor logo isn’t displayed bootsplash will be displayed


#200

I understand

Exactly what I meant. It would be an excellent combination with the planned quiet grub. The animation would make it clear that the boot is not stuck, you can show the console output with a key press, and the fsck issue is taken care of. That would take care of all valid points of criticism of the new feature while also looking very nice.


#201

Plymouth can show up when shutting down. Is bootsplash doing it too?


#202

Yes, you can configure that. Simply install bootsplash-systemd.


#203

I folowed the instructions, installed bootsplash-systemd and even removed the grub kernel “quiet” option.
Works very smooth.

The only thing I wonder - are all boot splashes black and white? I tried the Manjaro elegant and amd spashes.


#204

Installed it with the new quiet boot, works like a charm but it seems that the theme packages are outdated so they look like they don’t have any antialias (kinda horrible considering it’s not pixel art) and there’s no bootsplash-systemd on stable branch, Or maybe it’s just my mirrors?, i guess i’ll just have to wait.

EDIT: I just got over it and grabbed the packages from the manjaro repositories online, the theme issue only happens with manjaro-elegant, the other ones don’t look so pixelated. Maybe i’ll port my plymouth theme to the new kernel bootsplash or do a new one all together.


#205

Why I don’t see bootsplash-theme-manjaro-elegant in the extra repository?