[Bootsplash] Provided by the kernel

kernel
bootsplash
built-in

#203

I folowed the instructions, installed bootsplash-systemd and even removed the grub kernel “quiet” option.
Works very smooth.

The only thing I wonder - are all boot splashes black and white? I tried the Manjaro elegant and amd spashes.


#204

Installed it with the new quiet boot, works like a charm but it seems that the theme packages are outdated so they look like they don’t have any antialias (kinda horrible considering it’s not pixel art) and there’s no bootsplash-systemd on stable branch, Or maybe it’s just my mirrors?, i guess i’ll just have to wait.

EDIT: I just got over it and grabbed the packages from the manjaro repositories online, the theme issue only happens with manjaro-elegant, the other ones don’t look so pixelated. Maybe i’ll port my plymouth theme to the new kernel bootsplash or do a new one all together.


#205

Why I don’t see bootsplash-theme-manjaro-elegant in the extra repository?


#206

I guess bootsplash-theme-vendor should display vendor logo from BGRT, shouldn’t it? I’m asking because I can only see a black screen with animated circle.


#207

I installed and configured bootsplash on my work laptop and it works great. How can I add silent/quiet grub now? This is pure Manjaro laptop, no other OSes. I searched on the forum but I find only references to some withdrawn grub-quiet package.

I know I can configure grub to be hidden but I prefer to have grub accessible with shift so this new feature is very nice.


#208

That’s the way to go. Grub got patched with grub-quiet functionality. Everything you need is described here:


#209

Thanks, copied to my notes. Such instructions shouldn’t be just in Announcement topics as they are make it harder to find such relevant info.

The instruction is contradictory to bootsplash as it recommends to have quiet but since boostplash is replacing quiet then it’s obvious that quiet is not necessary then.

I suspect it’s not working 100% correctly. I suspect that grub theme should be invisible entirely and be replaced by vendor logo? Also I get part of the screen with vendor’s logo, rest is grub screen, so basically it looks like that:

  • vendor logo
  • grub theme
  • vendor logo partially (diagonally) overlays grub theme but grub theme is still visible in some parts of the screen
  • bootsplash
  • SDDM (don’t recall Plasma’s welcome screen, I guess it’s replaced by bootsplash, fine by me).
  • bootsplash when shutting down the system

But in overall I’m pleased and such details won’t ruin my mood ;). So all in all it’s working for me. Shift is also accessing Grub correctly, although I have to keep hitting it many times, because when I tried just to hold it, it didn’t work. Maybe I pushed it too soon or too late but there is no way of knowing since all I can see is vendor logo, so keeping hitting shift is the best way to access it.

On my personal laptop I’ll leave my plymouth as it works in the same way as bootsplash and no bootsplash theme is so personalized as my alienware plymouth :wink: .

Out of curiosity, is there a way to add background to bootsplash themes? It’s a bit sad with this black and white aesthetics.


#210

You can follow my setup which I described in detail when grub-quiet still existed:

==================>Bootsplash<==================

  1. I have a bootsplash hook in /etc/mkinitcpio.conf

HOOKS=(base udev autodetect keyboard keymap consolefont modconf block encrypt resume filesystems bootsplash-xiaomi)

Also if using Intel graphics, add i915 to MODULES.

This is my theme I made combining other people’s work. It contains vendor logo (Xiaomi) and Windows-like animated circle of dots.

  1. My grub settings in etc/default/grub are as follows:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=3
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR=“Manjaro”
GRUB_CMDLINE_LINUX_DEFAULT=“bootsplash.bootfile=bootsplash-themes/xiaomi/bootsplash”
GRUB_CMDLINE_LINUX=“cryptdevice=PARTUUID=a8c19k8e-613d-464f-9b74-b964815fb036:cryptolinux root=/dev/mapper/cryptolinux rootfstype=ext4 resume=/dev/mapper/cryptolinux resume_offset=15028224…”
GRUB_SAVEDEFAULT=true
GRUB_GFXMODE=auto
GRUB_GFXPAYLOAD_LINUX=keep

======================>Vendor Logo<=====================
Grub config is exactly the same as above except GRUB_CMDLINE_LINUX_DEFAULT:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet rd.systemd.show_status=false vt.global_cursor_default=0 loglevel=3 rd.udev.log-priority=3”

Of course after all amendments you need to reinstall grub to EFI, update initramfs and update grub config. Hope this helps.

I was wrong, it matters! >> Btw it doesn’t matter if you have quiet or not when using bootsplash. <<


#211

I can’t do this. Also i fresh installed manjaro 18 kde, i didn’t see defuault bootsplash. i tried this steps but i guess i’m doing something wrong.
First i installed the bootsplash-systemd and botsplash-theme-manjaro from octopi. I can’t see manjaro-elegant theme. When i searched manjaro-elegant, it came with playmouth-theme-manjaro-elegent. anyway i installed pylmouth from aur repo and pylomouth-theme-manjaro elegant.
After this installation i did this steps, but when booting i get error like image, theme can’t found.

Also i tried with plymouth, i added HOOKS=“playmouth” to mkinitcpio, and i chanced to “quite-splash” GRUB_CMDLINE_LINUX_DEFEAULT. it works but it is only one-second maybe fewer, also i’m getting error message on bootting like this: hibernete partion not found.


#212

Read whole post


#213

You can’t use bootsplash and plymouth at the same time, it’s one or the other.


#214

Both are just installed same time, I have edited the group and mkinitcpio settings only by one.


#215

Plymouth is doing the same as bootsplash but it works a bit different and the guide above will not work for it.

Here is the guide for plymouth:

If you install it manually, copy unpacked plymouth directory with plymouth to:

/usr/share/plymouth/themes/

To list all plymouth themes and check if the new one is detected:
plymouth-set-default-theme -l

To change theme:
sudo plymouth-set-default-theme <theme>

To rebuild initrd image:
sudo mkinitcpio -p <kernel present name>

To change theme and rebuild initrid image at the same time:

sudo plymouth-set-default-theme -R <theme>

Whenever you see you should replace it with your theme’s name in small letters.


#216

Ah, that reminded me… When grub is hidden, is the timeout still working? In other words, does it delay the boot?


#217

Got the silent boot from the other thread working, and then tried this. I was ambitious and tried the vendor logo, but it doesn’t appear; I just get the spinny thing.

Can we come up with a different animation so it doesn’t look like Windows? Bleh.


#218

Same here, bootsplash-theme-vendor just shows the loading circle with no logo. I tried bootsplash-theme-manjaro and it’s blank.

EDIT: I installed bootsplash-theme-manjaro-green by @GrayJack and it works. Why would that one work and not the ones in the repo?


#219

Exactly. It makes black screen (which hides grub menu) last for some time.

Religious considerations? :smile:
Create your own theme then.


#220

My theme, bootsplash-theme-manjaro-green uses another one


#221

As far as bootsplash-theme-vendor shows nothing but throbber, I’ve made a workaround called bootsplash-theme-bgrt.
It just dumps BGRT logo from /sys/firmware/acpi/bgrt/image before building a theme file, so if you’ve changed the logo (e.g. HackBGRT), you’ll need to rebuild the package.

Here’s the link: https://github.com/t1meshift/bootsplash-theme-bgrt


#222

For those who don’t like Windows-like spinner, enjoy this one: https://github.com/openmindead/bootsplash-xiaomi
This time it’s gonna be Macish :rofl:
It’s easy to substitute Xiaomi logo with your vendor’s one.

Oh wow, this is awesome! Works just fine. High five, zemlyak! :+1:
@philm pls take a look at this.