Bootloader installation error installing Manjaro 21.1.6 KDE

I am trying to install Manjaro 21.1.6 KDE on my new laptop, a Dell G15. I have Windows 11 pre-installed in the SSD that came with it, and I install a second SSD where I 'm trying to install Manjaro and I got the same error as in this other topic:


Bootloader installation error
The bootloader could not be installed. The installation command
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force
returned error code 1.

I try to run sudo calamares but got in the same error. I’m not a linux ninja but I have Manjaro running in another laptop (Dell Inspiron intel) and a Desktop (custom build AMD). But this is the first time I try dual boot and the first time having problems installing Manjaro. Any help will be appreciated.

That error basically means that the UEFI don’t permit to create a boot entry. Must be related to the UEFI Settings.

$ LANG=C errno 1
EPERM 1 Operation not permitted

Thanks, I got that far, but is there a way to fix it?

Please a bit more information about your system:

inxi --full --admin --filter --width 80 --color=0
sudo parted -l 
test -d /sys/firmware/efi && echo efi || echo bios
efibootmgr -v


To install Manjaro you have to disable Secure Boot in your firmware.

Also, make sure to fully shutdown Windoze by disabling Fast Startup in Windoze.

Thanks! I will post that in a bit.

Thanks, I did that before try to install.

this is the output from the inxi command (I took off Audio, Network and bluetooth):

 Host: manjaro Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc 
 v: 11.1.0 
 parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
 misobasedir=manjaro misolabel=MANJARO_KDE_2116 quiet systemd.show_status=1 
 apparmor=1 security=apparmor driver=nonfree nouveau.modeset=0 i915.modeset=1 
 Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
 Distro: Manjaro Linux base: Arch Linux 
 Type: Laptop System: Dell product: Dell G15 5515 v: 1.4.0 
 serial: <superuser required> Chassis: type: 10 v: 1.4.0 
 serial: <superuser required> 
 Mobo: Dell model: 066VKM v: A00 serial: <superuser required> UEFI: Dell 
 v: 1.4.0 date: 07/20/2021 
 ID-1: BAT1 charge: 86.0 Wh (100.0%) condition: 86.0/86.0 Wh (100.0%) 
 volts: 13.1 min: 11.4 model: Simplo 0x46,0x39,0x35,0x41,0x0B,0x0A,0x0005 
 type: Li-ion serial: 0005 status: Full 
 Info: 8-Core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 
 type: MT MCP arch: Zen 3 family: 19 (25) model-id: 50 (80) stepping: 0 
 microcode: A50000C cache: L2: 4 MiB 
 flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
 bogomips: 102241 
 Speed: 1197 MHz min/max: 1200/3200 MHz boost: enabled Core speeds (MHz): 
 1: 1197 2: 1197 3: 1197 4: 1197 5: 1197 6: 1195 7: 1450 8: 1197 9: 1197 
 10: 1197 11: 1197 12: 1197 13: 1396 14: 1397 15: 1197 16: 1197 
 Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Dell 
 driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
 chip-ID: 10de:2560 class-ID: 0300 
 Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
 loaded: nvidia display-ID: :0 screens: 1 
 Screen-1: 0 s-res: 1920x1080 s-dpi: 143 s-size: 341x191mm (13.4x7.5") 
 s-diag: 391mm (15.4") 
 Monitor-1: DP-0 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
 diag: 395mm (15.5") 
 OpenGL: renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 
 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
 Local Storage: total: 1.4 TiB used: 0 KiB (0.0%) 
 SMART Message: Unable to run smartctl. Root privileges required. 
 ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: A-Data model: IM2P33F3A NVMe 512GB 
 size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
 lanes: 4 type: SSD serial: DL402J32Y6NK rev: 92103061 temp: 29.9 C 
 scheme: GPT 
 ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Seagate 
 model: XPG GAMMIX S70 BLADE size: 953.87 GiB block-size: physical: 512 B 
 logical: 512 B type: SSD serial: 2L3929A8KKLR rev: 3.2.F.2A scheme: GPT 
 ID-3: /dev/sda maj-min: 8:0 type: USB model: USB DISK 2.0 size: 7.21 GiB 
 block-size: physical: 512 B logical: 512 B type: N/A 
 serial: 07086B96441C4C69 rev: PMAP scheme: MBR 
 SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
 Message: No partition data found. 
 Alert: No swap data was found. 
 Message: No sensor data found. Is lm-sensors configured? 
 Processes: 359 Uptime: 4m wakeups: 302 Memory: 62.66 GiB 
 used: 3.01 GiB (4.8%) Init: systemd v: 249 tool: systemctl Compilers: 
 gcc: N/A Packages: pacman: 1229 lib: 331 flatpak: 0 Shell: Bash v: 5.1.8 
 running-in: konsole inxi: 3.3.07

this from parted -l:

Model:  USB DISK 2.0 (scsi) 
Disk /dev/sda: 7745MB 
Sector size (logical/physical): 512B/512B 
Partition Table: msdos 
Disk Flags:  

Number  Start   End     Size    Type     File system  Flags 
2      3475MB  3479MB  4194kB  primary               esp 

Model: IM2P33F3A NVMe ADATA 512GB (nvme) 
Disk /dev/nvme0n1: 512GB 
Sector size (logical/physical): 512B/512B 
Partition Table: gpt 
Disk Flags:  

Number  Start   End    Size    File system  Name                          Flags 
1      1049kB  158MB  157MB   fat32        EFI system partition          boot, esp 
2      158MB   293MB  134MB                Microsoft reserved partition  msftres 
3      293MB   493GB  492GB                Basic data partition          msftdata 
4      493GB   494GB  1038MB  ntfs                                       hidden, diag 
5      494GB   511GB  16.9GB  ntfs                                       hidden, diag 
6      511GB   512GB  1452MB  ntfs                                       hidden, diag 

I wanto to install Manjaro in this ssd:

Model: XPG GAMMIX S70 BLADE (nvme) 
Disk /dev/nvme1n1: 1024GB 
Sector size (logical/physical): 512B/512B 
Partition Table: gpt 
Disk Flags:  

Number  Start   End     Size    File system     Name  Flags 
1      2097kB  317MB   315MB   fat32                 boot, esp 
2      317MB   1015GB  1014GB  ext4            root 
3      1015GB  1024GB  9449MB  linux-swap(v1)        swap

This is test -d:

test -d /sys/firmware/efi && echo efi || echo bios 

and finally, efibootmgr:

Timeout: 0 seconds 
BootOrder: 0005,0000,0001 
Boot0000* EFI PXE 0 for IPv4 (60-18-95-34-37-66)        PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/MAC(601895343766,0)/IPv4(,0,0)RC
Boot0001* EFI PXE 0 for IPv6 (60-18-95-34-37-66)        PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/MAC(601895343766,0)/IPv6([::]:<->[::]:,0,0)RC 
Boot0005* Windows Boot Manager  HD(1,GPT,0a6b0f22-02f6-4aee-88b0-8d3c24b2b12a,0x800,0x4b000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.

sorry for the amount of info…

This kernel is EOL, you should install another still supported kernel and remove 5.13 afterwards. If it’s from live ISO boot then try to download a fresher ISO.

Try to install version 21.0.7
Starting from 21.1.0 I have the same installation error.

Failed to install bootloader

Well, everything looks correct to me… What could be possible is that only the first drive can be addressed for booting (the UEFI could be restricted in such a way). So you need to add a second EFI Partition on /dev/nvme0n1 (instead of /dev/nvme1n1) which will be used for Manjaro or use the EFI Partition of Windows (on your own risk).

I would like tot hank you all, specially megavolt for the help!! The problem was indeed the UEFI restriction to boot from the 2 ssds, only the first one is for boot. I install manjaro in the same ssd as windows and all went smoothly.
thank you so much again!!!