Bootloader doesn't install properly on external SSD

Hi!
I have been trying to install Manjaro XFCE on my 1 TB external SSD, but it doesn’t show up in the UEFI or the Live-USB Bootloader search. I have installed Manjaro before on this external SSD and it has been working without any problems. I plan to use this SSD to have access to all of my files and programs when I don’t have access to my PC.

Partitions I made using GParted (GPT partition table):

UEFI:
New:

Old SSD:
I tried installing it using Architect, that’s why there is the option “Manjaro”, but it doesn’t actually work.

/boot/efi is completely empty I don’t know if that’s how it should be

I am guessing that you’ve installed Manjaro in legacy BIOS mode this time, rather than in UEFI mode. :thinking:

It says EFI next to the gear. :thinking:

I already chrooted into the installation and tried this: sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck but it still doesn’t work. :slightly_frowning_face: