Booting shows two warnings

I get two errors warnings after i boot and this takes more then 20 seconds to boot

[Failed] Failed to start Load/Save #ness of backlight: acpi_video0.
[Failed] Failed to start Load/Save Screen Backlight Brightness of backlight:amdgpu_bl1.
$ inxi -Fzxxxm
System:    Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FX505DT v: 1.0 serial: <filter> UEFI: American Megatrends v: FX505DT.315 date: 09/22/2020 
Battery:   ID-1: BAT0 charge: 29.7 Wh condition: 38.4/48.1 Wh (80%) volts: 11.0/11.7 model: FX50442 type: Li-ion serial: N/A 
           status: Discharging 
Memory:    RAM: total: 5.8 GiB used: 1.86 GiB (32.1%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Info: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen/Zen+ 
           note: check rev: 1 L2 cache: 2 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33548 
           Speed: 1243 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1243 2: 1224 3: 1221 4: 1222 5: 1224 
           6: 1284 7: 1221 8: 1222 
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:1f91 
           Device-2: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 05:00.0 
           chip ID: 1002:15d8 
           Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 3-1:2 chip ID: 13d3:56a2 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: amdgpu,ati,modesetting,nouveau 
           alternate: fbdev,nv,vesa resolution: 1920x1080~120Hz s-dpi: 96 
           OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 5.10.7-3-MANJARO LLVM 11.0.1) v: 4.6 Mesa 20.3.3 
           direct render: Yes 
Audio:     Device-1: NVIDIA driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10fa 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 05:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.10.7-3-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000 
           bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave driver: rtw_8822ce v: N/A 
           port: d000 bus ID: 04:00.0 chip ID: 10ec:c822 
           IF: wlp4s0 state: up mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 27.2 GiB (5.7%) 
           ID-1: /dev/nvme0n1 vendor: Micron model: 2200V MTFDHBA512TCK size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: P1MA0V4 temp: 54.9 C 
Partition: ID-1: / size: 459.5 GiB used: 27.2 GiB (5.9%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 46.4 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: amdgpu temp: 46.0 C device: nouveau temp: N/A 
Info:      Processes: 250 Uptime: 15m wakeups: 1 Init: systemd v: 247 Compilers: gcc: 10.2.0 clang: 11.0.1 Packages: 1339 
           pacman: 1333 snap: 6 Shell: Zsh v: 5.8 running in: yakuake inxi: 3.2.02 

$ systemctl status systemd-backlight@backlight:acpi_video0.service
● systemd-backlight@backlight:acpi_video0.service - Load/Save Screen Backlight Brightness of backlight:acpi_video0
     Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static)
     Active: failed (Result: exit-code) since Mon 2021-02-08 11:52:14 IST; 1min 34s ago
       Docs: man:systemd-backlight@.service(8)
    Process: 844 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:acpi_video0 (code=exited, status=1/FAILURE)
   Main PID: 844 (code=exited, status=1/FAILURE)

Feb 08 11:52:14 ASUS-TUF systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:acpi_video0...
Feb 08 11:52:14 ASUS-TUF systemd-backlight[844]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
Feb 08 11:52:14 ASUS-TUF systemd[1]: systemd-backlight@backlight:acpi_video0.service: Main process exited, code=exited, status=1/FAILURE
Feb 08 11:52:14 ASUS-TUF systemd[1]: systemd-backlight@backlight:acpi_video0.service: Failed with result 'exit-code'.
Feb 08 11:52:14 ASUS-TUF systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.

Also it takes more then 20 seconds to shutdown.
ps: There is a solved solution, will this work, i dont want to break my system ?

Yes, it should. I’ve had to do the same thing in the past and it worked.

Thanks … Will it also decrease my startup time and shutdown time too ?

No, it won’t affect it. However, the less errors there are during boot could speed it up.

One More thing:
My grub file is:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=4c6e43ff-b159-40ca-89c7-1ebd60c1ffdf udev.log_priority=3"

will i have to do:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor"


GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor apparmor=1 security=apparmor resume=UUID=4c6e43ff-b159-40ca-89c7-1ebd60c1ffdf udev.log_priority=3"

Sorry for taking your time.

Add it, don’t remove anything.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.