Booting gets stuck on "job is running for..." on encrypted system


I had Manjaro-stable installed on my laptop for a few months with no problems, but this morning it got stuck in boot. (Not sure how I could extract logs or anything to post here).
I figured I can edit the boot config to get a more verbose output, thus I see it got stuck on
“A start job is running for /dev/mapper/luks-625… ( 60min / no limit)” forever.

Although my drive/partition is encrypted, it’s luks-7… , and the boot process seems to pass the mount and file system check. Hence I’m not sure what luks-625… is about.

I think in my previous session, I’ve gone to hibernate.
I’m not sure how to progress from here, to fix it or even just figure out what’s causing the problem.

Any help is appreciated.

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_GNOME_202 quiet systemd.show_status=1 
  driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.2 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 81BR v: Lenovo ideapad 720S-13ARR 
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 720S-13ARR 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> 
  UEFI: LENOVO v: 6KCN28WW date: 12/19/2017 
  ID-1: BAT0 charge: 20.7 Wh condition: 42.1/48.0 Wh (88%) volts: 7.3/7.7 
  model: LGC 11 L16L4PB3 type: Li-poly serial: <filter> status: Discharging 
  RAM: total: 7.39 GiB used: 3.04 GiB (41.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 11 (17) 
  stepping: N/A microcode: 8101004 L2 cache: 2048 KiB bogomips: 31959 
  Speed: 1369 MHz min/max: 1600/2000 MHz boost: enabled Core speeds (MHz): 
  1: 1369 2: 1367 3: 1368 4: 1366 5: 1455 6: 1367 7: 1485 8: 1426 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate irperf lahf_lm lbrv lm mca mce 
  misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt 
  nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sha_ni skinit smap smca sme smep ssbd 
  sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce topoext 
  tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: Lenovo driver: amdgpu v: kernel bus ID: 03:00.0 chip ID: 1002:15dd 
  Device-2: Chicony EasyCamera type: USB driver: uvcvideo bus ID: 3-1:2 
  chip ID: 04f2:b5da serial: <filter> 
  Display: wayland server: 1.20.10 compositor: gnome-shell 
  driver: amdgpu note: display driver n/a - try sudo/root display ID: 0 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.39.0 
  5.9.11-3-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 03:00.1 chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 03:00.5 
  chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 3000 
  bus ID: 01:00.0 chip ID: 10ec:c821 
  IF: wlp1s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Local Storage: total: 933.39 GiB used: 139.90 GiB (15.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000L2 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 2L1QEXA7 scheme: GPT 
  ID-2: /dev/sda type: USB vendor: Transcend model: TS240GESD240C 
  size: 223.57 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  scheme: GPT 
  ID-3: /dev/sdb type: USB vendor: SanDisk model: USB 3.2Gen1 size: 232.88 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1.00 
  scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / raw size: N/A size: 5.54 GiB used: 173.0 MiB (3.0%) fs: overlay 
  source: ERR-102 label: N/A uuid: N/A 
  ID-2: /run/media/manjaro/f3f54b77-9bf0-4786-8e12-fc2ac4e09a85 
  raw size: 214.47 GiB size: 210.05 GiB (97.94%) used: 139.73 GiB (66.5%) 
  fs: ext4 dev: /dev/dm-0 label: N/A 
  uuid: f3f54b77-9bf0-4786-8e12-fc2ac4e09a85 
  Alert: No Swap data was found. 
  ID-1: /dev/dm-1 size: 8.80 GiB fs: <superuser/root required> label: N/A 
  uuid: N/A 
  ID-2: /dev/nvme0n1p1 size: 260.0 MiB fs: vfat label: SYSTEM_DRV 
  uuid: 1454-5BD5 
  ID-3: /dev/nvme0n1p2 size: 16.0 MiB fs: <superuser/root required> label: N/A 
  uuid: N/A 
  ID-4: /dev/nvme0n1p3 size: 450.69 GiB fs: ntfs label: Windows 
  uuid: F0AA5530AA54F496 
  ID-5: /dev/nvme0n1p4 size: 25.00 GiB fs: ntfs label: LENOVO 
  uuid: 509EFA239EFA0170 
  ID-6: /dev/nvme0n1p5 size: 1000.0 MiB fs: ntfs label: WINRE_DRV 
  uuid: 804E56EC4E56DA8C 
  ID-7: /dev/sda1 size: 300.0 MiB fs: vfat label: NO_LABEL uuid: A997-6409 
  ID-8: /dev/sda2 size: 214.47 GiB fs: crypto_luks label: N/A 
  uuid: 7e0e7abe-765b-485b-ba23-83e5a4752e78 
  ID-9: /dev/sda3 size: 8.80 GiB fs: crypto_luks label: N/A 
  uuid: 625e151f-145f-48fc-8e17-41ec6c5db013 
  ID-10: /dev/sdb1 size: 2.62 GiB fs: iso9660 label: MANJARO_GNOME_202 
  uuid: 2020-12-03-10-06-11-00 
  ID-11: /dev/sdb2 size: 4.0 MiB fs: vfat label: MISO_EFI uuid: 7239-C206 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Device-1: 2-1:2 info: Transcend StoreJet Transcend type: Mass Storage 
  driver: uas interfaces: 1 rev: 3.1 speed: 10 Gb/s chip ID: 2174:2000 
  serial: <filter> 
  Device-2: 2-2:3 info: SanDisk Ultra Fit type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 3.2 speed: 5 Gb/s chip ID: 0781:5583 
  serial: <filter> 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 3-1:2 info: Chicony EasyCamera type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b5da serial: <filter> 
  Hub: 3-2:3 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 05e3:0608 
  Device-1: 3-2.1:4 info: Realtek Bluetooth Radio type: Bluetooth 
  driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s chip ID: 0bda:c024 
  serial: <filter> 
  Device-2: 3-2.2:5 info: Synaptics type: <vendor specific> driver: N/A 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 06cb:0081 serial: <filter> 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 56.2 C mobo: N/A gpu: amdgpu temp: 56.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 297 Uptime: 1h 25m Init: systemd v: 246 Compilers: gcc: N/A 
  Packages: pacman: 1246 lib: 321 flatpak: 0 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.1.08 ```
1 Like

:+1: Welcome to Manjaro! :+1:

  1. Boot a Manjaro live USB.
  2. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  3. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.
P.P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time

1 Like

Thanks for your reply, I had no time earlier, but now I’ve bought another usb stick and booted manjaro from it to get the hardware info you requested.

7e0e… is my manjaro drive/partition when things work
625e… is the one that makes the “job” running forever. maybe that’s the partition everything was stored for hibernate.

1 Like

Can you manually mount that from the Live environment?

If no:

  • What’s the error message?
  • Do you have an unencrypted or an encrypted system backup?


so, I’ve used “Disks” to figure out it’s partition 3 of my my 2nd drive, at /dev/sda3
I’ve tried to casually mount it, but it failed
unkown filesystem type 'crypto_LUKS'
google led to using
sudo cryptsetup luksOpen /dev/sda3 crypted_sda3
which returned
Cannot use device /dev/sda3 which is in use (already mapped or mounted).

Is it mapped already, cause I’ve mounted the whole drive (/dev/sda2 / luks7e0e… ) in the Files tool? I see it in /dev/mapper/luks-625e....
properties from the Files tool say it’s linked to dm-1 but I’m not sure how to open that. (google for “open dm-1” does not return anything useful).

so I think it’s mounted :sweat:

Do you have an unencrypted or an encrypted system backup?

I have no system backup. my main partition is encrypted and I think this 2nd partition is something the installation created (swap or hibernate space?)

I don’t use encryption because it’s an additional layer of problems when something goes wrong and with great security comes great responsibility.

That is definitely not a good idea.

As we’ve reached both my and your limit of knowledge, the only thing I can do for you is add some tags and hope an encryption specialist shows up.


I made a backup of my home directory by using the liveUSB manjaro version :slight_smile:

I figured out, the problematic partition is the partition that manjaro uses to resume from.
I think something went wrong when manjaro went into hibernate and that partition seems to be corrupted to a degree where the system gets stuck accessing it, hence I think, if I would remove it from the boot process, manjaro would finish booting.

Using the liveUSB version of Manjaro, I tried to remove the resume from the original manjaro installation on myh SSD.
I’ve edited /etc/default/grub.conf removing all resume=...
also in /etc/mkinitcpio.conf I’ve removed resume

I’ve also tried, while booting from the SSD, pressing “E” to edit the grub config and remove the whole resume=... parameter

yet, when booting it still tries to access that partition and gets stuck.

Independently from the luks/encryption, could you tell me how I would remove the resume partition using a liveUSB-manjaro please? I found many pages that explain how to remove it to remove hibernate on a working system, but not how I would do it from the liveUSB, cause all the system commands I would run, would only affect the liveUSB system, not my manjaro installation on the SSD.