Booting directly to crt

Hi All
Two days ago I downloaded a fresh iso cinnamon flavour, I installed it on my old hardware

Kernel: 5.19.1-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1 Desktop: Cinnamon
v: 5.4.10 tk: GTK v: 3.24.34 dm: LightDM Distro: Manjaro Linux base: Arch Linux
Type: Desktop System: Hewlett-Packard product: HP Compaq Elite 8300 MT
CPU: Intel Core i5-3470 bits: 64
Graphics: AMD Cedar [Radeon HD 5000/6000/7350/8350 Series]
Monitor-1: HDMI-A-1 mapped: HDMI-0 model: Dell U2412M res: 1920x1200 dpi: 94
Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard driver: e1000e v: kernel
Ram :8 GB Ram

During Efi install every thing went normal but when I restart the PC it just loaded the kernel and ask me for user and password on crt screen and that was very fast it did not load any drivers and the list with green Ok on the side
after login I typed startx and cinnamon loads but no network is working I think also no firewall or any kind
I added networkManager manually to the systemctl by typing
sudo systemctl anable NetworkManager.service
sudo systemctl start NetworkManager.service
done the same to LighDM
now I can use the PC as normal but I think this is not agood thing to run without any services
all the services are running now are from systemctl status:

State: running
Units: 411 loaded (incl. loaded aliases)
Jobs: 0 queued
Failed: 0 units
Since: Tue 2022-08-23 13:40:11 CAT; 2h 43min ago
systemd: 251.4-1-manjaro
CGroup: /
β”‚ └─1 /sbin/init
β”‚ β”œβ”€NetworkManager.service
β”‚ β”‚ └─663 /usr/bin/NetworkManager --no-daemon
β”‚ β”œβ”€accounts-daemon.service
β”‚ β”‚ └─682 /usr/lib/accounts-daemon
β”‚ β”œβ”€colord.service
β”‚ β”‚ └─1008 /usr/lib/colord
β”‚ β”œβ”€cups.service
β”‚ β”‚ β”œβ”€ 5516 /usr/bin/cupsd -l
β”‚ β”‚ └─82738 /usr/lib/cups/notifier/dbus dbus://
β”‚ β”œβ”€dbus.service
β”‚ β”‚ └─627 /usr/bin/dbus-daemon --system --address=systemd: --nofork >
β”‚ β”œβ”€dhcpcd.service
β”‚ β”‚ β”œβ”€631 β€œdhcpcd: [manager] [ip4] [ip6]”
β”‚ β”‚ β”œβ”€632 β€œdhcpcd: [privileged proxy]”
β”‚ β”‚ β”œβ”€633 β€œdhcpcd: [network proxy]”
β”‚ β”‚ β”œβ”€634 β€œdhcpcd: [control proxy]”
β”‚ β”‚ └─705 β€œdhcpcd: [BPF ARP] eno1”
β”‚ β”œβ”€lightdm.service
β”‚ β”‚ β”œβ”€674 /usr/bin/lightdm
β”‚ β”‚ └─681 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -n>
β”‚ β”œβ”€polkit.service
β”‚ β”‚ └─686 /usr/lib/polkit-1/polkitd --no-debug
β”‚ β”œβ”€rtkit-daemon.service
β”‚ β”‚ └─841 /usr/lib/rtkit-daemon
β”‚ β”œβ”€systemd-journald.service
β”‚ β”‚ └─234 /usr/lib/systemd/systemd-journald
β”‚ β”œβ”€systemd-logind.service
β”‚ β”‚ └─629 /usr/lib/systemd/systemd-logind
β”‚ β”œβ”€systemd-networkd.service
β”‚ β”‚ └─252 /usr/lib/systemd/systemd-networkd
β”‚ β”œβ”€systemd-resolved.service
β”‚ β”‚ └─624 /usr/lib/systemd/systemd-resolved
β”‚ β”œβ”€systemd-udevd.service
β”‚ β”‚ └─udev
β”‚ β”‚ └─246 /usr/lib/systemd/systemd-udevd
β”‚ β”œβ”€udisks2.service
β”‚ β”‚ └─1017 /usr/lib/udisks2/udisksd
β”‚ β”œβ”€upower.service
β”‚ β”‚ └─1009 /usr/lib/upowerd
β”‚ └─wpa_supplicant.service
β”‚ └─701 /usr/bin/wpa_supplicant -u -s -O /run/wpa_supplicant
β”‚ β”œβ”€ 863 lightdm --session-child 12 19
β”‚ β”œβ”€ 885 cinnamon-session --session cinnamon
β”‚ β”œβ”€ 928 csd-keyboard
β”‚ β”œβ”€ 929 csd-automount
β”‚ β”œβ”€ 931 csd-xsettings
β”‚ β”œβ”€ 932 csd-a11y-settings
β”‚ β”œβ”€ 933 csd-media-keys
β”‚ β”œβ”€ 938 csd-background
β”‚ β”œβ”€ 939 csd-housekeeping
β”‚ β”œβ”€ 943 csd-screensaver-proxy
β”‚ β”œβ”€ 955 csd-color
β”‚ β”œβ”€ 957 csd-wacom
β”‚ β”œβ”€ 958 csd-clipboard
β”‚ β”œβ”€ 964 csd-power
β”‚ β”œβ”€ 966 csd-print-notifications
β”‚ β”œβ”€ 1002 /usr/lib/cinnamon-settings-daemon/csd-printer
β”‚ β”œβ”€ 1098 cinnamon-launcher
β”‚ β”œβ”€ 1101 cinnamon --replace
β”‚ β”œβ”€ 1145 /usr/lib/caribou
β”‚ β”œβ”€ 1150 parcellite
β”‚ β”œβ”€ 1158 nemo-desktop
β”‚ β”œβ”€ 1159 msm_notifier
β”‚ β”œβ”€ 1160 /usr/bin/telegram-desktop -workdir /home/adil/.local/>
β”‚ β”œβ”€ 1161 nm-applet
β”‚ β”œβ”€ 1164 pamac-tray
β”‚ β”œβ”€ 1165 /usr/bin/python /usr/sbin/blueman-applet
β”‚ β”œβ”€ 1166 cinnamon-killer-daemon
β”‚ β”œβ”€ 1171 /usr/lib/geoclue-2.0/demos/agent
β”‚ β”œβ”€ 1173 /usr/lib/polkit-gnome/polkit-gnome-authentication-age>
β”‚ β”œβ”€ 1411 conky -c /home/adil/.conky/conkyrc0old
β”‚ β”œβ”€ 1736 /usr/bin/python3 /usr/share/system-config-printer/app>
β”‚ β”œβ”€172009 /usr/lib/firefox/firefox
β”‚ β”œβ”€172176 /usr/lib/firefox/firefox -contentproc -parentBuildID >
β”‚ β”œβ”€172223 /usr/lib/firefox/firefox -contentproc -childID 1 -isF>
β”‚ β”œβ”€172350 /usr/lib/firefox/firefox -contentproc -childID 2 -isF>
β”‚ β”œβ”€172424 /usr/lib/firefox/firefox -contentproc -childID 3 -isF>
β”‚ β”œβ”€172432 /usr/lib/firefox/firefox -contentproc -childID 4 -isF>
β”‚ β”œβ”€172465 /usr/lib/firefox/firefox -contentproc -childID 5 -isF>
β”‚ β”œβ”€173897 /usr/lib/firefox/firefox -contentproc -childID 6 -isF>
β”‚ β”œβ”€174130 /usr/lib/firefox/firefox -contentproc -childID 7 -isF>
β”‚ β”œβ”€174776 /usr/lib/firefox/firefox -contentproc -childID 8 -isF>
β”‚ β”œβ”€174957 /usr/lib/firefox/firefox -contentproc -childID 9 -isF>
β”‚ β”œβ”€175339 /usr/lib/firefox/firefox -contentproc -childID 10 -is>
β”‚ β”œβ”€176114 /usr/lib/firefox/firefox -contentproc -childID 11 -is>
β”‚ β”œβ”€176184 /usr/lib/firefox/firefox -contentproc -parentBuildID >
β”‚ β”œβ”€176207 /usr/lib/firefox/firefox -contentproc -parentBuildID >
β”‚ β”œβ”€195844 cinnamon-settings
β”‚ β”œβ”€213569 mate-terminal
β”‚ β”œβ”€213591 bash
β”‚ β”œβ”€215007 systemctl status
β”‚ └─215008 less
β”‚ β”œβ”€at-spi-dbus-bus.service
β”‚ β”‚ β”œβ”€910 /usr/lib/at-spi-bus-launcher
β”‚ β”‚ β”œβ”€916 /usr/bin/dbus-daemon --config-file=/usr/share/defaul>
β”‚ β”‚ └─919 /usr/lib/at-spi2-registryd --use-gnome-session
β”‚ β”œβ”€dconf.service
β”‚ β”‚ └─978 /usr/lib/dconf-service
β”‚ β”œβ”€gnome-keyring-daemon.service
β”‚ β”‚ └─880 /usr/bin/gnome-keyring-daemon --foreground --compone>
β”‚ β”œβ”€obex.service
β”‚ β”‚ └─1275 /usr/lib/bluetooth/obexd
β”‚ β”œβ”€xdg-desktop-portal-gnome.service
β”‚ β”‚ └─1382 /usr/lib/xdg-desktop-portal-gnome
β”‚ β”œβ”€xdg-desktop-portal-gtk.service
β”‚ β”‚ └─1403 /usr/lib/xdg-desktop-portal-gtk
β”‚ └─xdg-permission-store.service
β”‚ └─1371 /usr/lib/xdg-permission-store
β”‚ β”œβ”€870 /usr/lib/systemd/systemd --user
β”‚ └─871 β€œ(sd-pam)”
β”‚ β”œβ”€ 884 /usr/bin/dbus-daemon --session --address=systemd: β†’
β”‚ β”œβ”€1060 /usr/lib/goa-daemon
β”‚ β”œβ”€1067 /usr/lib/goa-identity-service
β”‚ └─7637 /usr/bin/python3 /usr/share/system-config-printer/s>
β”‚ └─1085 /usr/lib/gvfs-afc-volume-monitor
β”‚ β”œβ”€ 896 /usr/lib/gvfsd
β”‚ β”œβ”€ 901 /usr/lib/gvfsd-fuse /run/user/1000/gvfs -f
β”‚ └─1245 /usr/lib/gvfsd-trash --spawner :1.4 /org/gtk/gvfs/e>
β”‚ └─1056 /usr/lib/gvfs-goa-volume-monitor
β”‚ └─1080 /usr/lib/gvfs-gphoto2-volume-monitor
β”‚ └─1322 /usr/lib/gvfsd-metadata
β”‚ └─1069 /usr/lib/gvfs-mtp-volume-monitor
β”‚ └─982 /usr/lib/gvfs-udisks2-volume-monitor
β”‚ └─1332 /usr/bin/pipewire
β”‚ β”œβ”€ 994 /usr/bin/pulseaudio --daemonize=no --log-target=jou>
β”‚ └─1092 /usr/lib/pulse/gsettings-helper
β”‚ β”œβ”€1364 /usr/lib/xdg-desktop-portal
β”‚ └─1398 /usr/lib/pxgsettings org.gnome.system.proxy org.gno>
β”œβ”€1368 /usr/lib/xdg-document-portal
└─1377 fusermount3 -o rw,nosuid,nodev,fsname=portal,auto_u>
β”‚ β”œβ”€ 901 /usr/lib/gvfsd-fuse /run/user/1000/gvfs -f
β”‚ └─1245 /usr/lib/gvfsd-trash --spawner :1.4 /org/gtk/gvfs/exec_spaw/0
β”‚ └─1056 /usr/lib/gvfs-goa-volume-monitor
β”‚ └─1080 /usr/lib/gvfs-gphoto2-volume-monitor
β”‚ └─1322 /usr/lib/gvfsd-metadata
β”‚ └─1069 /usr/lib/gvfs-mtp-volume-monitor
β”‚ └─982 /usr/lib/gvfs-udisks2-volume-monitor
β”‚ └─1332 /usr/bin/pipewire
β”‚ β”œβ”€ 994 /usr/bin/pulseaudio --daemonize=no --log-target=journal
β”‚ └─1092 /usr/lib/pulse/gsettings-helper
β”‚ β”œβ”€1364 /usr/lib/xdg-desktop-portal
β”‚ └─1398 /usr/lib/pxgsettings org.gnome.system.proxy org.gnome.system.proxy.http org.gnome.system.proxy.https org.gnome.system.proxy.ftp org.gnome.system.proxy.socks
β”œβ”€1368 /usr/lib/xdg-document-portal
└─1377 fusermount3 -o rw,nosuid,nodev,fsname=portal,auto_unmount,subtype=portal – /run/user/1000/doc

so is this enough or should I Do something else?


sorry for inconvenient, I am not native English I tried to give as much information about the problem as I can ! if something not clear ask me and I will try to clear it please!

I guess I need to seek help somewhere else !! :dizzy_face: :pensive:

… or you could read a bit, even if it is difficult for you :wink:
Somewhere else they will have the same problem with the lack of information …

This here below could well be your problem - the display manager wasn’t enabled in a recent Cinnamon iso.

Lightdm not running after fresh Manjaro Cinnamon install

If that is the case for you, simply activate it.

All booting processes we are familiar when booting linux are not loaded
I managed to activate LightDm and networkManager, But I think I am at risk of using my PC because no other services are running and of course I do not know which one I should enable, for the reason It is always enabled by default … services, Daemons, and other thing usually comes on booting with the green [OK] on left of it…

… example?! :wink:
What are you missing that should be there?

… with the exception of the display manager in this case
as this was an error when the iso was created.
… if this is/was the problem that you had.

This is just from an old ISO I have I ran it on VM judt to show you what I mean
not exact the things list here but what ever supposed to be loaded when system start !!

I sort of know what you mean, but:
a picture of the boot process of an older iso
does not say anything about what you are missing now
with the actual iso you installed.

An old β€œboot log” is not an example for what may be missing now.

Typically, the boot process is silent - to see those messages you have to press some key during boot or change the boot loader configuration to make it permanent.

the boot process is verbose and what is loading now is just networkManager and VMware network and usbloader , and LightDm
you may see the orignal post for the other init or systemd processes running !! I listed all usually if I do this systemd status on other PC it is like 500 lines or more now it is only 140
so what is not there I do not know
some process to check integrity of my Hdd usually are there, some basic firewall settings
all of these are not running

firewall might be installed, but it is not enabled by default - because not everyone has use for it and a user should know what services he/she needs to have

What are you missing
of which you positively know it should be there?
… you can’t go by β€œfeelings” :wink:

you only listed running services in your first post
fsck service, for instance, will not be constantly running

Did you try an install with another ISO? As pointed it can happen a bad ISO is released, maybe retry again with a slightly older ISO, or a newer one if there is one.

As there are automated process building the ISO it is possible you just installed a bad ISO. Its OK if you want to troubleshoot your new install but, as it is a new install, I would reinstall because what you describe on first boot is not a sign that β€œevery thing went normal”.

1 Like

You got my point I feeling this is not right and not enough to run only this few things as It was always hundreds of lines, but now it is 6 or 7 lines with OK tag and then the LightDm starts!!!

But you didn’t get my point:
you can’t go by feelings.

What is missing that you would expect to be there?

… a firewall in an example of something that is, and should remain, a users choice
it isn’t active by default - if it is even installed.

see also what @omano just said - further up I linked to another thread discussing this very issue

you are taking my words literally take the it as whole !! like it should not be just 6 or 7 lines loading it should be more!!

perhaps - but still and again:
What is missing that should be there? :wink:

I just read the other thread, I would recommend to install the ISO Oberon suggested.

See if you have issues there, then just update the system, problem(s) solved.

Thank you downloading the ISO now, but is thier any script that I can run to verfy what is missing and what should be running and fix that?

No I don’t think so.

You can (and probably should) verify the integrity of the iso you downloaded.
Then, what you get is a system as it was intended by the person who put together the software that this edition will install by default.
You can always change that later - you don’t have to live with the defaults.