Boot or login broken after 'pacman -Rc' and update

Hi I desperately need help.
It’s been a long time since I last updated. I had to manually resolve a couple of dependency conflicts by running pacman -R -c , and it flooded me with questions of “Replace with /extra/5?” which I spammed yes to. It finished updating and of course there was a kernel update as part of that so I rebooted.
Now the login screen has changed (says it can’t find my theme file, presumably it’s looking in a different directory than it used to) and it won’t let me log in. I can type into the pw box but hitting enter gives no response. I tried ctrl-alt-f1 to switch to console but it just says 0.0095081 __common_interrupt: 2.55 No irq handler for vector. the cursor is blinking on the next line but I can’t type anything, so I’m just gonna turn it back off now.

i suspect I’ll need an external boot in order to take care of this so I’m gonna get started on the but I don’t even know what to do from there. what information should I bring up and where should I be looking to diagnose this?

This command is not the normal way to remove things and should be used with care as ‘cascade’ can include packages you did not intend to remove.

We can maybe look in the logs to see what was done;

grep -i removed /var/log/pacman.log

Sounds like the replacement of many kde packages with the -5 suffix due to the upcoming KDE 6.
(ie - normal)

Speaking of kernels … what do you have installed? Possibly end-of-life?

mhwd-kernel -li

And/or check with pacman

pacman -Q linux

And how did you do this update?

Are we sure you are fully up to date?

sudo pacman-mirrors -f && sudo pacman -Syu

All of the above can be done by chroot if needed. To see about those things;

Once there we probably would like some of those outputs.
Maybe also inxi -Fazy

Oh, and if you need a way to paste the outputs see this:

( ex: inxi -Fazy | curl -F 'file=@-' )

The pacman -Rc definitely removed some packages you need. It might be easier to back up important personal files from /home and reinstall from the newest ISO. Rolling releases like Manjaro need to be updated regularly to avoid breaking things.

1 Like

I think so - the '/extra/5/ replacements were a while back…

Personally, if it’s messed up like this, I’d start by restoring a snapshot from my first foray into the update, try to start again from there, and if it wasn’t fixed in an hour or two, I’d just do a fresh install and restore data from my backups.

1 Like

“Bricked” means what it says - the device is good for nothing but a paper-weight.
Obviously that is not the case.
Title edited.


I highly doubt anyone has ever used -Rc in real life. Let me guess, ChatGPT told you to do it that way…the thing is generating text, not understanding it or proofing if it is correct.

packman removal log (skipping to date in question)

[2023-12-19T18:53:12-0500] [ALPM] removed junit (4.13.2-1)
[2023-12-19T18:53:12-0500] [ALPM] removed minecraft-launcher (1:1.0.1221-1)
[2023-12-19T18:53:12-0500] [ALPM] removed jdk-openjdk (20.0.2.u9-3)
[2023-12-19T18:53:12-0500] [ALPM] removed beanshell (2.1.1-1)
[2023-12-19T18:53:12-0500] [ALPM] removed jre-openjdk (20.0.2.u9-3)
[2023-12-19T18:53:58-0500] [ALPM] removed jre-openjdk-headless (20.0.2.u9-3)
[2023-12-19T19:03:45-0500] [ALPM] removed systemd-kcm (1.2.1-7)
[2023-12-19T19:03:45-0500] [ALPM] removed sddm-kcm (5.27.7-1)
[2023-12-19T19:03:45-0500] [ALPM] removed plasma-desktop (
[2023-12-19T19:03:45-0500] [ALPM] removed manjaro-kde-settings (20230529-1)
[2023-12-19T19:03:45-0500] [ALPM] removed kinfocenter (5.27.7-1)
[2023-12-19T19:03:45-0500] [ALPM] removed kgamma5 (5.27.7-1)
[2023-12-19T19:03:46-0500] [ALPM] removed systemsettings (5.27.7-1)
[2023-12-19T19:03:46-0500] [ALPM] removed sddm-breath-theme (22.0.0-2)
[2023-12-19T19:03:46-0500] [ALPM] removed powerdevil (5.27.7-1)
[2023-12-19T19:03:46-0500] [ALPM] removed plasma-pa (5.27.7-1)
[2023-12-19T19:03:46-0500] [ALPM] removed plasma-nm (5.27.7-1)
[2023-12-19T19:03:46-0500] [ALPM] removed khotkeys (5.27.7-1)
[2023-12-19T19:03:46-0500] [ALPM] removed kget (23.08.0-1)
[2023-12-19T19:03:46-0500] [ALPM] removed kdeplasma-addons (5.27.7-1)
[2023-12-19T19:03:46-0500] [ALPM] removed kdeconnect (23.08.0-1)
[2023-12-19T19:03:46-0500] [ALPM] removed plasma-workspace (5.27.7-2)
[2023-12-19T19:03:46-0500] [ALPM] removed kpeoplevcard (0.1+r38.32d50a9-1)
[2023-12-19T19:03:46-0500] [ALPM] removed kpeople (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed prison (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed networkmanager-qt (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed modemmanager-qt (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed libqaccessibilityclient (0.4.1-2)
[2023-12-19T19:17:46-0500] [ALPM] removed krunner (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed threadweaver (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed plasma-framework (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kwayland (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kirigami-addons (0.11.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kimageformats (5.109.0-3)
[2023-12-19T19:17:46-0500] [ALPM] removed kholidays (1:5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kdoctools (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kdiagram (2.8.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kunitconversion (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kdesu (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kcontacts (1:5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kcalendarcore (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed ktexteditor (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kactivities-stats (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed knotifyconfig (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed libkcddb (23.08.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed purpose (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kitemmodels (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed libkdcraw (23.08.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kquickcharts (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed qqc2-desktop-style (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kuserfeedback (1.2.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kactivities (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kcmutils (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kdsoap (2.1.1-1)
[2023-12-19T19:17:46-0500] [ALPM] removed syntax-highlighting (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kdnssd (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed frameworkintegration (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed knewstuff (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed syndication (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kdeclarative (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kpackage (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed bluez-qt (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed baloo (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kidletime (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kfilemetadata (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed attica (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kpty (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kparts (5.109.0-1)
[2023-12-19T19:17:46-0500] [ALPM] removed kio (5.109.0-2)
[2023-12-19T19:17:46-0500] [ALPM] removed kded (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed ktextwidgets (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed sonnet (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kcompletion (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kwallet (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kservice (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed knotifications (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kbookmarks (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kxmlgui (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kitemviews (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kiconthemes (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed karchive (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kconfigwidgets (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed ki18n (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kguiaddons (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kcodecs (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kauth (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kglobalaccel (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kcrash (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kwindowsystem (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kconfig (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kdbusaddons (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kjobwidgets (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kwidgetsaddons (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed kcoreaddons (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed solid (5.109.0-1)
[2023-12-19T19:17:47-0500] [ALPM] removed appstream-qt (0.16.3-1)

kernel queries:

[32mCurrently running:[0m 6.1.68-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux510
   * linux54
   * linux61
linux510 5.10.204-1

(the fact that these are different terrifies me)

and inxi - Fazy:

  Kernel: 6.1.68-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=b372f6d7-b299-4755-bfeb-f9b21ff8ab3c rw 3 quiet apparmor=1
    security=apparmor resume=UUID=e8af64ed-62a4-40f2-b41d-f3e0ce63bfe1
  Console: tty 1 DM: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: X570 Phantom Gaming 4S
    serial: <superuser required> UEFI: American Megatrends v: P4.10
    date: 06/23/2021
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
    desc: 2x16 MiB
  Speed (MHz): avg: 2816 high: 3600 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3600 2: 2800
    3: 2800 4: 2200 5: 2200 6: 3600 7: 2200 8: 2800 9: 2200 10: 3600 11: 3600
    12: 2200 bogomips: 86278
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_rstack_overflow mitigation: safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: Micro-Star MSI driver: amdgpu v: kernel arch: RDNA-1 code: Navi-1x
    process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: DP-1,HDMI-A-1 empty: DP-2,DP-3 bus-ID: 0c:00.0
    chip-ID: 1002:731f class-ID: 0300
  Device-2: ARC USB2.0_CAM1 driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:2 chip-ID: 05a3:2053
    class-ID: 0102 serial: <filter>
  Display: server: v: driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    tty: 240x67
  Monitor-1: DP-1 model: Acer SB220Q serial: <filter> built: 2020
    res: 1920x1080 dpi: 102 gamma: 1.2 size: 476x268mm (18.74x10.55")
    diag: 546mm (21.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-1 model: ViewSonic VA1655-FHD serial: <filter>
    built: 2022 res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast gbm: drv: radeonsi surfaceless: drv: radeonsi
    inactive: wayland,x11
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: mesa v: 23.1.9-manjaro1.1
    note: console (EGL sourced) renderer: AMD Radeon RX 5700 XT (navi10 LLVM
    16.0.6 DRM 3.49 6.1.68-1-MANJARO), llvmpipe (LLVM 16.0.6 256 bits)
  API: Vulkan v: 1.3.269 layers: 4 device: 0 type: discrete-gpu name: AMD
    Radeon RX 5700 XT (RADV NAVI10) driver: mesa radv v: 23.1.9-manjaro1.1
    device-ID: 1002:731f surfaces: N/A
  Device-1: Creative Labs CA0108/CA10300 [Sound Blaster Audigy Series]
    driver: snd_emu10k1 v: kernel bus-ID: 04:00.0 chip-ID: 1102:0008
    class-ID: 0401
  Device-2: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0c:00.1 chip-ID: 1002:ab38
    class-ID: 0403
  Device-3: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-4: ARC USB2.0_CAM1 driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:2 chip-ID: 05a3:2053
    class-ID: 0102 serial: <filter>
  Device-5: JMTek LLC. TKGOU PnP USB Microphone
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 5-4:2 chip-ID: 0c76:1467 class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.1.68-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: pipewire-media-session
    status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: off with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 05:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.39 TiB used: 525.44 GiB (37.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Silicon Power
    model: SPCC M.2 PCle SSD size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: S1111A0L temp: 39.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: Expansion
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B type: USB
    rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 0502 scheme: MBR
  ID-1: / raw-size: 745.02 GiB size: 732.26 GiB (98.29%)
    used: 525.41 GiB (71.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 25.5 MiB (8.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 17.12 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p5 maj-min: 259:5
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: amdgpu temp: 54.0 C
    mem: 58.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 818
  Processes: 217 Uptime: 3h 40m wakeups: 0 Memory: total: 16 GiB
  available: 15.54 GiB used: 755.4 MiB (4.7%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 2123 libs: 471 tools: pamac,trizen pm: flatpak
  pkgs: 0 Shell: Bash (login) v: 5.2.21 running-in: tty 1 inxi: 3.3.31

finally, ran the mirrors/update command, after querying all the mirrors and synchronizing package databases, it says

:: Starting full system upgrade...
there is nothing to do

Thank you for all of your help both here directly and those other tutorials were very helpful. I would like to reiterate in case it’s relevant that when trying to reach chroot from the login page, I get an unresponsive screen with that “no irq handler” line, which is also what appeared on my screen when booting directly into chroot before that cleared and let me login

So … uh … you removed a bunch of plasma.

Theres probably a handful of ways to deal with this … but I might suggest mapare

bash <(curl -s -IA

write kde when prompted.

Extra information:

A list of everything it will install (versions reflect my unstable system in the example)
e2fsprogs 1.47.0-1
coreutils 9.4-2
bzip2 1.0.8-5
device-mapper 2.03.22-2
cryptsetup 2.6.1-3.4
systemd 255.1-1
perl 5.38.1-1
base 3-2
acpi 1.7-3
acpid 2.0.34-1
amd-ucode 20231211.f2e52a1c-1
b43-fwcutter 019-4
btrfs-progs 6.6.3-1
cpupower 6.6-1
run-parts 5.5-1
cronie 1.7.0-4
dhclient 4.4.3.P1-2
dhcpcd 10.0.5-1
diffutils 3.10-1
dmraid 1.0.0.rc16.3-14
nftables 1:1.0.9-1
dnsmasq 2.89-1
dosfstools 4.2-3
ecryptfs-utils 111-8
efibootmgr 18-2
exfatprogs 1.2.2-1
f2fs-tools 1.16.0-2
grub 2.12rc1.r106.g7c8ae7dcb-1
glibc-locales 2.38-7
inetutils 2.4-2
intel-ucode 20231114-1
jfsutils 1.1.15-8
less 1:643-1
logrotate 3.21.0-2
lvm2 2.03.22-2
man-db 2.12.0-1
manjaro-release 23.1.0-1
manjaro-system 20230401-1
zsh 5.9-4
zsh-autosuggestions 0.7.0-2
zsh-syntax-highlighting 0.8.0-1
zsh-completions 0.35.0-1
zsh-history-substring-search 1.1.0-1
ttf-meslo-nerd-font-powerlevel10k 20230403-2
zsh-theme-powerlevel10k 1.19.0-1
manjaro-zsh-config 0.26-1
man-pages 6.05.01-2
mdadm 4.2-2
memtest86+ 6.20-1
memtest86+-efi 6.20-1
mhwd-db 0.6.5-28
mhwd 0.6.5-28
mkinitcpio-openswap 0.1.0-3
nano 7.2-1
nano-syntax-highlighting 2020.10.10+10+g1aa64a8-2
nfs-utils 2.6.4-1
ntfs-3g 2022.10.3-1
os-prober 1.81-1
reiserfsprogs 3.6.27-4
rsync 3.2.7-6
s-nail 14.9.24-2
sof-firmware 2023.09.2-1
spectre-meltdown-checker 0.46+20+g9b7b09a-1
sudo 1.9.15.p4-1
sysfsutils 2.1.1-1
texinfo 7.1-2
usbutils 017-1
vi 1:070224-6
wget 1.21.4-1
which 2.21-6
wireless-regdb 2023.09.01-1
wpa_supplicant 2:2.10-8
liburcu 0.14.0-1
xfsprogs 6.5.0-2
avahi 1:0.8+r189+g35bb1ba-1
mobile-broadband-provider-info 20230416-1
networkmanager 1.44.2-3
vpnc 1:0.5.3.r526.r213-1
stoken 0.92-4
oath-toolkit 2.6.9-1
xdg-utils 1.2.0r25+g0f49cf5-1
openconnect 1:9.12-1
networkmanager-openconnect 1.2.10-1
networkmanager-openvpn 1.10.2-3
networkmanager-pptp 1.2.12-3
networkmanager-vpnc 1.2.8-3
networkmanager-l2tp 1.20.10-1
nss-mdns 0.15.1-1
ntp 4.2.8.p17-1
modemmanager 1.22.0-1
openresolv 3.13.2-2
openssh 9.6p1-1
samba 4.19.3-2
usb_modeswitch 2.6.1-3
alsa-firmware 1.2.4-3
alsa-utils 1.2.10-1
ffmpeg 2:6.1-3
gst-libav 1.22.8-1
gst-plugins-bad 1.22.8-1
gst-plugins-base 1.22.8-1
gst-plugins-good 1.22.8-1
gst-plugins-ugly 1.22.8-1
libcanberra 1:0.30+r2+gc0620e4-3
libdvdcss 1.4.3-1
manjaro-alsa 20221002-1
manjaro-gstreamer 20221002-1
manjaro-pipewire 20231009-1
phonon-qt5-gstreamer 4.10.0-4
grub-btrfs 4.13-1
udisks2 2.10.1-2
kamera 23.08.4-1
mtpfs 1.1-4
udiskie 2.5.0-1
ttf-dejavu 2.37+18+g9b5d1b2f-4
noto-fonts 1:23.12.1-1
adobe-source-sans-fonts 3.052-1
adobe-source-han-sans-jp-fonts 2.004-1
adobe-source-han-sans-kr-fonts 2.004-1
adobe-source-han-sans-cn-fonts 2.004-1
terminus-font 4.49.1-6
archlinux-appstream-data 20231203-1
libhandy 1.8.2-1
dbus-glib 0.112-3
libpamac 11.6.3-1
pamac-cli 11.6.0-3
pamac-gtk3 10.6.0-3
pamac-tray-icon-plasma 0.1.3-2
libpackagekit-glib 1.2.8-1
packagekit 1.2.8-1
packagekit-qt5 1.1.1-1
xf86-input-libinput 1.4.0-1
xorg-server 21.1.10-1
sddm 0.20.0-2
milou 5.27.10-1
kscreenlocker 5.27.10-1
kwin 5.27.10-1
kio-extras 23.08.4-1
plasma-workspace 5.27.10-2
systemsettings 5.27.10-1
sddm-kcm 5.27.10-1
audiocd-kio 23.08.4-1
bluedevil 1:5.27.10-1
kde-gtk-config 5.27.10-1
kdeplasma-addons 5.27.10-2
kgamma 5.27.10-2
mesa-utils 9.0.0-3
dmidecode 3.5-1
kinfocenter 5.27.10-1
kmenuedit 5.27.10-1
kscreen 5.27.10-1
ksshaskpass 5.27.10-1
ksysguard 5.22.0-2
kwallet-pam 5.27.10-1
kwayland-integration 5.27.10-1
qt5-virtualkeyboard 5.15.11-1
kwrited 5.27.10-1
powerdevil 5.27.10-1
xdg-user-dirs 0.18-1
plasma-desktop 5.27.10-1
plasma-nm 5.27.10-1
plasma-pa 5.27.10-1
plasma-simplemenu 1.0.12-1
plasma-browser-integration 5.27.10-1
xdg-desktop-portal-kde 5.27.10-1
plasma-thunderbolt 5.27.10-1
gnome-themes-extra 3.28+r6+g45b1d457-1
oxygen 5.27.10-1
oxygen-icons 1:5.113.0-1
sddm-breath-theme 23.0.0-1
grub-theme-manjaro 20.2-16
breeze-gtk 5.27.10-1
plymouth 22.02.122-15
plymouth-theme-manjaro 2.2-1
ark 23.08.4-1
dolphin 23.08.4-1
dolphin-plugins 23.08.4-1
kate 23.08.4-1
kcalc 23.08.4-1
kfind 23.08.4-1
libfakekey 0.3-2
kcontacts5 5.113.0-1
kpeoplevcard 0.1-2
pulseaudio-qt 1.3-1
kirigami-addons5 0.11.0-7
kdeconnect 23.08.4-1
poppler-data 0.4.12-1
okular 23.08.4-1
kdenetwork-filesharing 23.08.4-1
khelpcenter 23.08.4-1
khotkeys 5.27.10-1
kinit 5.113.0-1
konsole 23.08.4-2
ksystemlog 23.08.4-1
kwalletmanager 23.08.4-1
gwenview 23.08.4-1
partitionmanager 23.08.4-1
spectacle 23.08.4-1
p7zip 1:17.05-2
unarchiver 1.10.8-1
kdegraphics-thumbnailers 23.08.4-1
ffmpegthumbs 23.08.4-1
kimageformats5 5.113.0-1
qt5-imageformats 5.15.11+kde+r12-1
kaccounts-providers 23.08.4-1
sshfs 3.7.3-1
firefox 120.0.1-1
htop 3.2.2-1
qt6-declarative 6.6.1-1
compiler-rt 16.0.6-2
clang 16.0.6-1
llvm 16.0.6-1
shiboken6 6.6.1-1
pyside6 6.6.1-1
python-systemd 235-2
python-manjaro-sdk 1:0.1.1-1
web-installer-url-handler 2.3-1
manjaro-hello 0.7.1-3
manjaro-application-utility 1.3.3-10
manjaro-settings-manager-kcm 0.5.7-19
manjaro-settings-manager-knotifier 0.5.7-19
plasma-systemmonitor 5.27.10-1
powertop 2.15-1
neofetch 7.1.0-2
systemd-kcm 1.2.1-8
plymouth-kcm 5.27.10-1
yakuake 23.08.4-1
manjaro-kde-settings 20230529-1
manjaro-browser-settings 20231111-1
xf86-input-elographics 1.4.3-1
xf86-input-evdev 2.10.6-3
xf86-input-void 1.4.2-1
libva-intel-driver 2.4.1-2
libva-mesa-driver 1:23.3.1-1
libva-vdpau-driver 0.7.4-6
numlockx 1.2-5
xorg-twm 1.0.12-1
xorg-xinit 1.4.2-1
xorg-xkill 1.0.6-1
xorg-mkfontscale 1.2.2-1
perl-file-mimeinfo 0.33-2
power-profiles-daemon 0.13-1
manjaro-hotfixes 2018.08-6

This is because your removal list includes many packages required for KDE desktop, including plasma-desktop itself.

The utility should install everything that would come with a normal plasma ISO, so do note you may have some extras you will wish to remove afterwards.


oh you’re so kind :slight_smile:
actually, after trying to find a response path within the pacman -Syu command that would allow it to resolve the dependency itself, and then trying to use pacman -R to remove the conflicting package, and being told I couldn’t because (x) was dependent on it, and then trying to use -R on that and getting a similar message, I went to the internet to research the initial problem (unresolvable conflict message from pacman upgrade command, not looking up anything about -R) and found three separate forum questions where the found solution was for OP to use pacman -Rc on the conflicting package. by “found solution” I mean not only was it suggested but OP said they used it and it fixed the problem. I then looked up that command in the pacman manual - as I do for every command I find on a random forum - and the manual does say it needs to be used with care, but given that it seemed to solve issues similar to mine multiple times in the past, and that the description of what it does matched with the thing I was trying to do, and that I was going to follow it up with a system upgrade that I thought would be able to replace anything important that was removed, I decided it seemed like the correct path forward.
but no I get it, I’m an idiot who deleted important files from my computer. how could I be so stupid.

ok the mapare command is running. this time I got a bunch more messages saying there were conflicting packages, but when I answered y to removing the old ones, it actually worked.

do you have any ideas for why this would not have been the case previously, or what I should have done to remedy it?

Without actually looking at whats being done my guess is something like this:

You wanted to do some remodeling on your house.
You realized there was some light fixtures in the way.
So you tore down the whole wall.
You didnt need to do that, and now you need to rebuild the wall, but those light fixtures are no longer in the way.

Again, I dont know what the actual original ingredients were. It could have been some old unsupported packages that did need removing. Or maybe it was one of the ‘manual intervention’ things mentioned in the update announcements. ex:

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.