Boot Options still shows ubuntu, eventhough it's not installed anymore

I had Ubuntu installed as the main OS when I started with linux a few months ago. Overtime, I completely switched to Manjaro.


  1. The boot options still has Ubuntu in the list .

  2. I don’t know if it’s a problem, but:
    My harddisk size is 500 GB. The filesystem says: 416 GiB free of 453 GiB
    The files I keep on my disk are no more than 1GB. And Manjaro (acc. Google) takes around 20-30 GB .
    What’s going on with the rest of the space?

  3. My system lags a lot. It worked super smooth with Mint Cinnamon, but it lags real bad now.

If these are any help:

> [zen@zen-loves-none ~]$ df
> df: /run/user/1000/doc: Operation not permitted
> Filesystem      Size  Used Avail Use% Mounted on
> dev             886M     0  886M   0% /dev
> run             895M  1.2M  894M   1% /run
> /dev/sda2       454G   14G  417G   4% /
> tmpfs           895M   58M  838M   7% /dev/shm
> tmpfs           895M     0  895M   0% /sys/fs/cgroup
> tmpfs           895M   46M  850M   6% /tmp
> /dev/sda1       300M  280K  300M   1% /boot/efi
> tmpfs           179M   28K  179M   1% /run/user/1000

This is because you haven’t “uninstalled” ubuntu (even I don’t think there’s a way to do it), instead just removed the files and installed Manjaro over it.
Enter these commands to remove ubuntu entry:

  1. sudo su
    Enter the password.
  2. find /boot/efi -name ubuntu -exec rm -r {} +

Don’t know why it is showing like that.
Maybe, not sure, you have swapfile reserving some amount of space. Open system monitor and check for swap memory.

It depends on the desktop environment. I assume that yours is KDE Plasma, which consumes more CPU and memory than Cinnamon.

It says: no such file or directory. And ubuntu’s still in the boot options list.

The Drives and Partition section output from inxi -Fxz:
Drives: Local Storage: total: 465.76 GiB used: 14.01 GiB (3.0%) ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB Partition: ID-1: / size: 453.38 GiB used: 14.00 GiB (3.1%) fs: ext4 dev: /dev/sda2 ID-2: swap-1 size: 3.84 GiB used: 6.2 MiB (0.2%) fs: swap dev: /dev/sda3

Sorry for my assumption. Let me update my answer above.

Check where the “ubuntu” folder in “EFI” partition is (it must be somewhere in this partition only) and then remove it:

  1. sudo su
    Enter the password
  2. find /boot/efi -name ubuntu -exec rm -r {} +

I don’t know why, maybe Manjaro reserves some space. But it should not create any problem.

First … I am going to guess ‘500’ is just what it says on the tin, right?

Second … GB and GiB are not the same thing …


Oh there is also something called “Gibibyte”! I didn’t know this.

I . . didn’t know that


EFI directory is simply a directory it has nothing to do with boot options.
You have to remove the boot entry using efibootmgr command.

What efibootmgr does is clearing out the boot option from your motherboard.
So even if you would wipe that whole disk it would still shop up.
UEFI entries are stored on a memory chip.


Someone on Reddit suggested using efibootmgr:

sudo efibootmgr -b /*bootNum*/ -B

It worked.

Didn’t get to try the other option you suggested, but thanks for the trouble!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.