Boot menu borked after updating

Hi all,

As of writing, i have installed the latest big update for my Manjaro KDE. Pretty big update, but afterwards, i noticed that my boot menu (grub) doesn’t show up anymore. I need it because i dual-boot Windows for work.

What i’ve noticed is that it’s sorta there, but just invisible. It keeps a black screen for 5 seconds, that’s how long i always had it, and then just auto selects my Manjaro install and boots into it. Pushing buttons doesn’t stop the auto-select. Searched the web but found nothing like this, and i’m absolutely unclear as to how to start troubleshooting, so if anyone thinks of something, please let me know. The way it is right now is just borked and almost has me just re-installing, but i want to avoid that if possible.

1 Like

I also encountered the same problem after the update. After a few searches, I realized this problem may causing by the grub menu was being hidden. Then I check out my grub configuration file and found the GRUB_TIMEOUT_STYLE was changed from menu to hidden.

All I need to do is change the hidden to menu and save it.

sudo nano /etc/default/grub
# change GRUB_TIMEOUT_STYLE=menu
sudo update-grub
# reboot

I hope it can help you.

FYI: you can find out some grub setting on here

1 Like

To add to what hackerzgz posted, changing GRUB_TIMEOUT_STYLE from menu to hidden will bring the boot menu back. Increasing the value for GRUB_TIMEOUT= will keep the boot menu longer before booting into the default OS. The GRUB_TIMEOUT= value is seconds.

No, it’s the other way around. :stuck_out_tongue:

Thank you all! Applied it, gonna try it out in a few minutes. I’m curious as to how this change was made? Previous updates didn’t do it, and i never authorized it explicitely.

So many people don’t do this - but it really is worth reading the forum announcement in detail if you notice that there is a large update incoming - takes only a few minutes but may save you hours of grief later. I only ever run large updates after a day or two - force of habit :slight_smile:

Unfortunately, the problem remains. A black screen where the menu is supposed to be, for exactly the length of time i’ve allotted it. In the last split-second it shows up though, but dissapears immediately and boots into Manjaro. I’m stumped.

Getting closer. A second update-grub made the menu show up again. However, a new problem arises; it doesn’t show my Windows boot anymore, just lists my Linux twice now.

I am also facing the same problem. I followed the steps given above by @hackerzgz and I got the following output

Blockquote Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings …
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

What should I do now ?

In the release announcement you find:

If you need dual-boot you can reactivate os-prober the easiest with the following command combination in a terminal: sudo echo GRUB_DISABLE_OS_PROBER=false >> /etc/default/grub && sudo update-grub

I guess I don’t know the proper way to implement the listed command. I keep getting permission denied. I’ve gotten to the point where I can see the grub menu; however, it only has Manjaro listed. I have a UEFI dual-boot with two drives. Win 10 on one and Manjaro on the other.

The command

is equivalent to adding a line with GRUB_DISABLE_OS_PROBER=false to your /etc/default/grub then execute sudo update-grub (and reboot).

Thank you for your quick clarification jeancf. I was able to handle that nad it worked perfectly.

You should be able to boot into windows by using you motherboards bios boot menu instead of grub, if you really need to get into windows for now.

To kinda clear up what others are trying to instruct, you need to edit your “boot configuration file” that grub uses when it boot. They recently disabled a feature that I’m assuming did this automatically previously.

The steps I would take in terminal would be

sudo nano /etc/default/grub

This is going to allow you to edit your boot settings in a text editor.

If you don’t see this line in that file


Add it to the end of the file we just opened, or make sure it’s “uncommented” (without #)

Hit CTRL + X
Save modified buffer with y, hit enter
Hit enter on file path popup which then kicks you back into terminal

sudo update-grub
(This applies the setting we just added above)

Reboot. Hopefully it shows up now

I’m not sure why, but after I upgraded Manjaro, grub’s time out option was changed. Even though I don’t know why, after booting into my Live USB environment, I found this thread and this worked as my solution:

Thanks, @hackerzgz ! :100:

Use this to de-cloak the GRUB menu

sudo sed -i 's/TIMEOUT_STYLE=hidden/TIMEOUT_STYLE=menu/g' /etc/default/grub

If the GRUB menu has been hidden then it is likely that the new setting for os-prober has been added to GRUB configuration but is commented out

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

To uncomment this option

sudo sed -i 's/#GRUB_DISABLE_OS_PROBER=false/GRUB_DISABLE_OS_PROBER=false/g' /etc/default/grub


sudo update-grub && reboot