Boot manjaro ISO from encrypted drive


no such device: /miso/manjaro.iso
file /miso/manjaro.iso not found
no server is specified
you need to load the kernel first

Have you done this?

Yes, I have…

final summary:
with all the information in
plus all the help here in the topic and some private troubleshooting with @bedna I still failed to get it going. Maybe it is just not possible. I will mark @linux-aarhus answer as solution, since that was his take from the beginning anyway.
I will have a look at ventoy. Maybe that will lead to a satisfying solution. Thanks to everybody, who tried to help!

I did play around a little as well.
It definitely works when the system is not encrypted!

With an encrypted system and the same configuration, the initrd cannot find the iso file - this is likely due to the fact, that the / file system of the real system, where the iso is stored, only becomes available after the switch root.

Perhaps when the initrd is configured differently?
But I don’t think so.

I see:
running hook [miso]

running hook [miso_loop_mnt]

device did not show up after 30 seconds -
and back in the emergency shell of the initrd …

Thanks for trying!

Without any question…
Like I wrote, it is far out of my league, but my guess is, that it can only be solved through a proper GRUB config (if it is even possible…)
Since we are still at the stage of the bootloader, I don’t see, why any other configuration (except the GRUB config) in my running system would have any effect on what I was trying. Or is the initrd of my running OS fixed for all GRUB menu entries?

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.