Boot issues, tty accessible

when I started my PC today, I choose my usual kernel in GRUB and ended up with a blinking cursor - instead of the login screen. I tried all alternative boot-options, all leading to the same situation. Since this is not the first time this happened, I supsected the graphics driver (I use the non-free nvidia drivers). So I uninstalled them and installed video-vesa instead. Same result.

Below is my system info, including a journalctl-log that show some failures. Can you please help me to troubleshoot? I do not umderstand the journslctl output…

Thank you.

post output from:
mhwd-kernel -li && mhwd -l -li
find /etc/X11/ -name "*.conf"

kernel 6.0 is EOL ( no more support ) as nvidia drivers for this kernel version
if possible add kernel 6.1 & 6.2

sudo mhwd-kernel -i linux61 
sudo mhwd-kernel -i linux62

reboot and remove kernel 6.0

sudo mhwd-kernel -r linux60

also you should use nvidia drivers ( current ) not nouveau

sudo mhwd -a pci nonfree 0300

you may need to add on boot

and think about update your UEFI motherboard

Installing kernel 6.1 went smoorth. 6.2 gave some feedback about my win boot partitions and the unknown device type nvme0n1 (there is only 1 disk in my pc). To be on the safe side, here is a screenshot.

After installing the kernel, I boot into 6.2.9-1 (still not GUI) and remove kernel 6.0.

Inan attempt to install nvidia ends like this:

I do not understand what to do with this iommu=pt. Could you pls elaborate?

Is this what you suggest?

so you will have to remove kernel EOL ( end of Life – no more support )

sudo mhwd-kernel -r linux519 
sudo mhwd-kernel -r linux60

boot on kernel 5.15

sudo mhwd-kernel -i linux61
sudo mhwd-kernel -i linux62

check after if some file ghosts stays ( keep only linux 515 , 6.1 and 6.2 )

for iommu=pt see this

I have now installed the kernels you recommended. All other kernels are removed.

The symlinks seem ok:

I’d rather get your confirmation, before srewing up my grub:would this be ok?

Rebooting => same situation.

Attempting to install nvidia-drivers, it refuses to do so because of to files: one is related to wayeland, one to the nvidia/utils. I move them by adding “.bak” to the filename, and restart the installation. During installation, the screen turns black, and I eventually have to perform a hard shutdown. However, afterwards the GUI starts, pretending nothing happened.

Thank you very much for zour support, Stephane. Though I have backups in place, the thought of having to reinstall everything and download 2TB of data from backup… ouch…

did you removed the vesa config? post output from:
find /etc/X11/ -name "*.conf"

(base) [dejhost@Workstation ~]$ find /etc/X11/ -name "*.conf"

Should I remove the vesa.conf?

yes remove the conf, but first check with:
mhwd -li
and only video nvidia should be listed, if you still have video vesa remove it…