Boot flag not set for Manjaro Gnome


#1

I wanted to report that the “boot flag” not set for Manjaro Gnome.

On two different machines, I had to boot with Gparted Live to set the boot flag manually.

(both of these were non-UEFI machines)


#2

The boot flag wasn’t set here either, but it wasn’t necessary. My system boots also without the boot flag (BIOS Legacy, NVMe).


#3

I have older computer that last 7-8 installations all failed with newer Calamares for exact the same reason as @jimdunn mentioned. First I didn’t know what was the problem and I was keep downloading, verifying, flashing USB and trying again with different lightweight versions until someone mentioned boot flag. I tried it (set it up manually with the gparted) and it worked. I tried two more times, same outcome and I posted bug report for Calamares. Month ago or so. Someone else had the same problem and this is not the third known time that this is happening.

I tried architect-manjaro installer on that same old machine and installation was then OK.

So there is no doubt in my mind, there is some kind of bug in Calamares that occasionally triggers and system is then not bootable.


#4

You could try with Manjaro-Architect, that one worked for me. More work involved, mode decisions to make during install, but gives you more control over what it will be installed, how your system will be set (community work):


#5

Maybe someone could tell us when exactly the boot flag is needed, because apparently it isn’t always needed? But then it also doesn’t seem to hurt if you always enable it…

On both my laptop and my main computer, the boot flag is not needed. Setup is the same: BIOS-Legacy, GPT + bios_grub (ef02) partition.


#6

If everything is set up properly, boot flag is not needed for linux.
It has been mentioned many times before, hope this subject gets laid to rest. I mean “Die!” :grinning:
Links
[1]
[2]
[3]
[4]


#7

It is true that “if everything is set up properly” but the point of starting this thread was to point out that when selecting the “Automatic Erase Disc” option, that my machine didn’t boot. Thus, the installer should “check” to see if the boot flag is required or not before moving on.

(I notice that any time Deepin is installed on a machine, the next distro installed has boot issues)


#8

I am not sure where this “Automatic Erase Disc” is. But if this is on the installer, I’ve never used it. I always used ‘manual’ or ‘advanced’ partitioning, sorry.

But, if it is what I think it does, this may have made your whole disk not ‘pre-partitioned’ as neither msdos partitioning and neither gpt partitioning. If that is the case, we will need to set the disk right first before we created any partiions in it. [1]. And that may be the problem you are seeing. Your disk is not set right. And any subsequent OS install (as you point out) will also have the same problem.

But if you got it working, we are fine with it.
Oh, we appreciate your help in informing us how you fix the issue you’re facing.
Cheers, take care, and welcome to Manjaro.

[1] - to set up disk partitioning, use gparted, at ‘device tab’ (at top of gui table), select ‘msdos’ or ‘gpt’ partitioning.
Note this will erase everything and partitions in disk. Then only create partitions in it.