Boot delay: random: crng init done


#1

Hi all.

Occasionally the boot process get’s stuck at “Started TLP system startup/shutdown” for 10-120 seconds. A log review reveals the boot process is actually being delayd by the kernel itself.

|13.05.2018 10:22:12:929|NetworkManager|<info>  [1526199732.9299] manager: startup complete|
|13.05.2018 10:23:50:044|kernel|random: crng init done|
|13.05.2018 10:23:50:044|kernel|random: 7 urandom warning(s) missed due to ratelimiting|

Please take a look at this system boot log. I’ve already tried kernel 4.14 at 4.16 with similar experiences. This issue appeared about a month ago.

Log
|13.05.2018 10:22:06:639|tlp|Setting battery charge thresholds...done.|
|---|---|---|
|13.05.2018 10:22:06:641|systemd|Started TLP system startup/shutdown.|
|13.05.2018 10:22:07:325|systemd|Startup finished in 10.805s (firmware) + 2.611s (loader) + 3.385s (kernel) + 932ms (initrd) + 3.006s (userspace) = 20.742s.|
|13.05.2018 10:22:07:326|kernel|fbcon: inteldrmfb (fb0) is primary device|
|13.05.2018 10:22:07:326|kernel|cryptd: max_cpu_qlen set to 1000|
|13.05.2018 10:22:07:326|kernel|input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input21|
|13.05.2018 10:22:07:327|kernel|input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input22|
|13.05.2018 10:22:07:327|kernel|input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input23|
|13.05.2018 10:22:07:327|kernel|input: HDA Intel HDMI HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.0/sound/card0/input24|
|13.05.2018 10:22:07:327|kernel|input: HDA Intel HDMI HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.0/sound/card0/input25|
|13.05.2018 10:22:07:327|kernel|AVX2 version of gcm_enc/dec engaged.|
|13.05.2018 10:22:07:327|kernel|AES CTR mode by8 optimization enabled|
|13.05.2018 10:22:07:327|kernel|IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready|
|13.05.2018 10:22:07:327|kernel|intel_rapl: Found RAPL domain package|
|13.05.2018 10:22:07:327|kernel|intel_rapl: Found RAPL domain core|
|13.05.2018 10:22:07:327|kernel|intel_rapl: Found RAPL domain uncore|
|13.05.2018 10:22:07:327|kernel|intel_rapl: Found RAPL domain dram|
|13.05.2018 10:22:07:327|kernel|IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready|
|13.05.2018 10:22:07:327|kernel|IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready|
|13.05.2018 10:22:07:327|kernel|psmouse serio3: synaptics: queried max coordinates: x [..5708], y [..4660]|
|13.05.2018 10:22:07:328|kernel|psmouse serio3: synaptics: queried min coordinates: x [1392..], y [1108..]|
|13.05.2018 10:22:07:328|kernel|psmouse serio3: synaptics: Your touchpad (PNP: SYN3008 SYN0100 SYN0002 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.|
|13.05.2018 10:22:07:329|kernel|psmouse serio3: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd00123/0x840300/0x26800/0x0, board id: 2767, fw id: 1530451|
|13.05.2018 10:22:07:329|kernel|input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio3/input/input18|
|13.05.2018 10:22:07:329|kernel|Console: switching to colour frame buffer device 170x48|
|13.05.2018 10:22:07:329|kernel|i915 0000:00:02.0: fb0: inteldrmfb frame buffer device|
|13.05.2018 10:22:07:360|systemd|Created slice system-systemd\x2dbacklight.slice.|
|13.05.2018 10:22:07:361|systemd|Starting Load/Save Screen Backlight Brightness of backlight:intel_backlight...|
|13.05.2018 10:22:07:369|systemd|Started Load/Save Screen Backlight Brightness of backlight:intel_backlight.|
|13.05.2018 10:22:12:929|NetworkManager|<info>  [1526199732.9299] manager: startup complete|

[...DELAY...]

|13.05.2018 10:23:50:044|kernel|random: crng init done|
|13.05.2018 10:23:50:044|kernel|random: 7 urandom warning(s) missed due to ratelimiting|
|13.05.2018 10:23:50:056|sddm|Initializing...|
|13.05.2018 10:23:50:070|sddm|Logind interface found|
|13.05.2018 10:23:50:071|sddm|Starting...|
|13.05.2018 10:23:50:072|sddm|Adding new display on vt 1 ...|
|13.05.2018 10:23:50:074|sddm|Loading theme configuration from ""|
|13.05.2018 10:23:50:074|sddm|Display server starting...|
|13.05.2018 10:23:50:074|sddm|Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{21e877d8-b060-4de1-bac6-2b6cd213c340} -background none -noreset -displayfd 17 -seat seat0 vt1|
|13.05.2018 10:23:50:840|sddm|Setting default cursor|
|13.05.2018 10:23:50:849|sddm|Running display setup script  "/usr/share/sddm/scripts/Xsetup"|
|13.05.2018 10:23:50:852|sddm|Display server started.|
|13.05.2018 10:23:50:852|sddm|Socket server starting...|
|13.05.2018 10:23:50:852|sddm|Socket server started.|
|13.05.2018 10:23:50:854|sddm|Loading theme configuration from "/usr/share/sddm/themes/breath/theme.conf"|
|13.05.2018 10:23:50:855|sddm|Greeter starting...|

#2

from Stable announce

Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

closed #3

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.