Boost.Python Fehler in Job "bootloader"


#8

/dev/loop0: TYPE=“squashfs”
/dev/loop1: TYPE=“squashfs”
/dev/loop2: TYPE=“squashfs”
/dev/loop3: TYPE=“squashfs”
/dev/sda1: LABEL=“SYSTEM” UUID=“5C98-2447” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“a96f9457-8ac0-4c4d-bb12-0c4a9c0d42ed”
/dev/sda2: PARTLABEL=“Microsoft reserved partition” PARTUUID=“435921c2-2ca8-464e-a93c-b3c457ef527e”
/dev/sda3: LABEL=“OS” UUID=“9E9E9B689E9B382B” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“0dc4ab12-0fb9-4928-91dc-fde232b093f5”
/dev/sda4: LABEL=“RECOVERY” UUID=“5A24E70C24E6E9C9” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“3a1303df-c43a-430c-8522-d68cbee85a36”
/dev/sda5: UUID=“58908144-2d58-44ab-860b-8b042699f1ba” TYPE=“swap” PARTUUID=“7fb48074-7aad-4c43-81e9-f6a148f95910”
/dev/sda6: UUID=“1c3dd776-bcb9-466e-be2b-a2a7d82e4e67” TYPE=“ext4” PARTUUID=“688209d2-5152-4186-b939-fd37a9f72c4a”
/dev/sdb1: UUID=“2017-04-02-13-59-14-00” LABEL=“MJRO1701” TYPE=“iso9660”
/dev/sdb2: SEC_TYPE=“msdos” LABEL=“MISO_EFI” UUID=“DEFC-ECE4” TYPE="vfat"
Vielen Dank das Sie sich die Mühe machen. Im Endeffekt bin ich doch ein ziemlicher Linux Neuling.
Viele Grüße Xerx


#9

Hallo Xerx,
jetzt nochmal vom USB-Stick booten, Terminal aufmachen und diese Befehle eingeben:
mount /dev/sda1 /mnt/boot/efi manjaro-chroot /dev/sda6 pacman -Syu efibootmgr exit sudo modprobe efivarfs manjaro-chroot /dev/sda6 mount -t efivarfs efivarfs /sys/firmware/efi/efivars grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck update-grub exit
runterfahren, ohne Stick hoffentlich erfolgreich neu booten.
Ich hoffe, ich habe nichts vergessen und übersehen, weil ich das mangels Windows und UEFI nicht nachvollziehen kann. Also alles ohne Garantie und mach vielleicht vorher ein Backup, das kann nie schaden.

Viele Grüße gosia


#10

Wie kommt man überhaupt von UEFI weg?


#11

sudo mount /dev/sda1 /mnt/boot/efi
mount: Einhängepunkt /mnt/boot/efi ist nicht vorhanden

Leider eine Fehlermeldung.
Viele Grüße Xerx


#12

Hallo Xerx,

Schade, aber einen Versuch haben wir noch:
Statt

so anfangen:
manjaro-chroot /dev/sda6 mkdir /boot/efi mount /dev/sda1 /boot/efi
und dann weiter wie oben mit
pacman -Syu efibootmgr exit sudo modprobe efivarfs
usw. …
und ich sehe gerade, die Zeile
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
soll ein einziger Befehl sein, also von grub-install bis –recheck als einen Befehl ohne Zeilenumbruch eingeben. Wird hier leider umgebrochen, so daß es wie zwei Befehle aussieht.

Viele Grüße gosia


#13

Hallo schurli81,

Gute Frage. Bei meinem neuen Laptop habe ich damals einfach die gesamte Festplatte platt gemacht: Windows weg -> EFI weg -> und im Bios umgestellt -> alles mit ext4 formatiert
Keine Ahnung, ob das immer so geht und wahrscheinlich gibt es elegantere Wege.

Viele Grüße gosia


#14
sudo manjaro-chroot /dev/sda6
==> ERROR: Can't create chroot on non-directory /dev/sda6

Leider Funktioniert es wieder nicht. Ich könnte auch einfach auf Manjaro 17.0.2 warten vielleicht haben sie da das Problem gelöst. Oder ich installiere eine andere Distro mit KDE (vielleicht Kubuntu) und von da könnte man wahrscheinlich auch Manjaro installieren.

Viele Grüße Xerx


#15

Wenn ich die Festplatte im ext4 Format formatiere und im BIOS Legancy Boot Aktiviere, reicht das?


#16

Hallo Xerx,
sorry, das war mein Fehler. Nimm statt dessen
sudo manjaro-chroot -a
da sucht das System automatisch. Kann nur etwas länger dauern (ein paar Sekunden). Dann hoffentlich weiter im Takt mit
mkdir /boot/efi

Viele Grüße gosia


#17

Hallo schurli81,

Sagen wir mal so, bei mir hat das gereicht. Kenne mich aber mit dem UEFI-Zeugs nicht so aus, daß ich das für alle garantieren kann. Kannst ja mit Clonezilla vorher alles retten und dann ausprobieren. Ich will ja nicht schuld sein :wink:

Viele Grüße gosia


#18
sudo manjaro-chroot -a
==> Detected systems:
 --> 0) ManjaroLinux
==> Select system to mount [0-0] : 
0
==> ERROR: You can't mount 0!

Wieder eine neue Fehlermeldung :disappointed_relieved:
Viele Grüße Xerx


#19

Danke für deine Hilfe! Wenn ich den Boot-Stick auf fat32 formatiere reicht dann das


#20

Hallo Xerx,
tut mir leid, jetzt weiss ich auch nicht weiter. Vielleicht doch mal eine andere Manjaro-Version probieren?

Viele Grüße gosia


#21

Trotzdem Danke für deine Hilfe gosia. Kann man die pre-release Version von 17.0.2 vielleicht benutzen? Oder ich warte bis die stable Version heraus kommt. Bekommt man vielleicht noch die Version 16 und macht dann einfach ein Systemupgrade?

Gruß Xerx

Edit: habe gerade Manjaro 16.10.3 ausprobiert. Es funktioniert nicht über Usb. Könnte daran liegen das die Hardware zu neu ist. Der Laptop läuft mit einer Kaby Lake Intel Cpu. Dafür bräuchte man Kernel 4.10 am besten.


#22

Hallo Xerx,

Das ist ein wenig wie bei Fragen an Sender Jerewan, “im Prinzip ja, aber…” Also ausprobieren, mehr als das es nicht funktioniert kann ja nicht passieren. Und da Manjaro ein Rolling Release ist, dauert es meist nur ein, zwei Wochen, bis aus der pre-release Version eine stabile Version wird.

Solche Fragen, die Hardware betreffen, kann zumindest ich nur beantworten, wenn ich solch ein Teil auch schon mal im Rechner hatte. Aber superneue Hardware kann natürlich problematisch sein, schon wegen der Treiber.
Und installieren geht auch mit älteren Versionen, die man dann per Update auf den neuesten Stand bringt. Aber wenn dann nagelneue Hardware ins Spiel kommt, die es beim Erscheinen der älteren Version noch gar nicht gab, wird es schon schwierig.

Viele Grüße gosia


#23

Habe dasselbe Problem: “boost.Python-Fehler” und Installationsabbruch kurz vorm Ende. Frage mich nun ebenfalls, ob es an der Version 17.0.1 liegen könnte … ? (bei mir Desktop XFCE)


#24

Meine Hardware ist nicht superneu und dennoch dieser Fehler.


#25

Hallo new3ric,
ich glaube auch nicht so sehr, daß es an der Hardware liegt. Aber wenn Du das dasselbe Problem hast, hast Du dann dann mal die Sache mit dem efibootmgr pobiert?


Ansonsten kann auch ein Installationsversuch mit der ISO vom Manjaro-Architect helfen:

Da soll besser als mit Calamares funktionieren.

Viele Grüße gosia


#26

Hallo gosia,
nachdem ich etwas in den Foren rumgelesen und gegoogelt habe, glaube ich, dass dieser boost.python Fehler, der schon seit letztem Jahr Probleme macht und haeufiger vorkommt, so eine Art Bug im Zusammenhang mit Calamares zu sein scheint. Ich wuerde gern mal mit Thus oder CLI zu installieren versuchen, ist aber nicht an Bord!
eric


#27

Hallo eric,

Mag sein, obwohl es auch dafür Lösungsansätze gibt (m. chroot).
Aber warum nicht einen Versuch mit Manjaro-Architect wagen? Wird nicht nur von mir, sondern auch von führenden Manjaro-Experten empfohlen

Viele Grüße gosia