Boost Python error during installation

Installing Manjaro KDE 17.02 receive this error please advise, thanks

Installation Failed
Boost.Python error in job “bootloader”.
<class ‘subprocess.CalledProcessError’>
Command ‘grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force’ returned non-zero exit status 1.
Traceback:
File “/usr/lib/calamares/modules/bootloader/main.py”, line 334, in run
prepare_bootloader(fw_type)

File “/usr/lib/calamares/modules/bootloader/main.py”, line 305, in prepare_bootloader
install_grub(efi_directory, fw_type)

File “/usr/lib/calamares/modules/bootloader/main.py”, line 236, in install_grub
"–force"])

File “”, line 2, in

Boot up installed OS [1] using this in UEFI mode and when booted at terminal,
first verify there is /boot/efi

findmnt /boot/efi

Then

sudo grub-install
sudo update-grub

If there is any error,

sudo pacman-mirrors -g
sudo pacman -S grub
sudo grub-install
sudo update-grub

[1] - boot up installed OS, not livecd OS

I get this error no such device: /EFI/Manjaro/grubx64.efi
Please advise. Also, why can’t I use the gui installer for this computer? Thanks.

At each step provide output when booted to installed OS.
First, can you boot up to installed OS? Not livecd.

i’ll continue when you reply.

If you can boot up to installed OS (please reply if you can or not)
Then any output in
findmnt /boot/efi

If none, you did not set mount point of $esp to /boot/efi
and that’s why it fail at installation.
Reply too if any output at installed OS.

If all okay up to here, when you do
"grub-install" it will create " /boot/efi/EFI/Manjaro/grubx64.efi"

If you don’t get to here, it means you have failed in above steps, probably step 1 itself (not booting to installed OS).
or probably you did not boot in

Thannks for working with me. I cannot boot to installed OS.

Okay. I need to know where we are so we can talk the same thing.
The commands are valid only at the installed OS.
If you cannot boot to installed OS (it’s easier to fix there), lets boot up to livecd and hope we can work from there.


Boot up livecd. open the file manager, dolphin.
Check at the installed OS partition, the boot directory.
First thing see if the boot directory has kernels and initramfs files.
vmlinuz-4.9-x86_64
initramfs-4.9-x86_64.img

If these are not there, there is nothing we can do but to reinstall.
And don’t try anything else, it won’t work.

If these are there, confirm it. print out these for us.
Next, at the ;livecd terminal, provide

sudo blkid
sudo parted -l

Small ‘L’ in ‘parted -l’, and explain these partitions, like sda2 is Manajo OS partition, sda3 is swap…etc.
We’ll take it from there.
Hang in there, we’re here. (but my sleeping time is close by)

Good luck.

Got it!! Thanks for your help. I reinstalled and followed your initial feedback.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.