Boatload of e22 errors in xsesionerrors


#21

Ah, but you should look again. I know that person had lots of other errors as well but if you search for ‘localestring_get()’ 3rd hit, you will see the exact same error as in you screenshot and the explanation for that error as well.

Your latest screenshot (previous post) everything looks fine and is the same as mine (except for the different countries) but I do see one difference and do not know if it is important.
Your localectl status:

System Locale: LANG=en_US.UTF-8

My localectl status:

System Locale: LANG=en_ZA.UTF-8
               LC_COLLATE=C

My /etc/locale.conf file only contains:

LANG=en_ZA.UTF-8
LC_COLLATE=C

See if you need to add the last line and if it makes a difference.


#22

I don’t understand your reference to “3rd hit” but skip that. I have that single C in the output of locale -a and was wondering at the time wtf that was. My config doesn’t have the LC_COLLATE=C at all. No idea if related but doubt the locale was involved here.

Today, while the electrician installed a new service to the house (4 hours no electric), I used pamac to remove all things xfce - took the scorched earth path - and errors are all gone in .xsession-errors.
Might have gone too far since e-22 is now having other issues, polkit being the most glaring - can’t. use pamac. But I installed entrance login via pacman. Also installed polkit-gnome and hammered it into startups but that hasn’t made any differnce yet. I’ll start a new thread for that - where do e-22 issues go?

Thanks for your help and aj too…


#23

P.S.

How to mark solved?

Nothing at bottom left of page :confused:


#24

Each post has a checbox that you can mark as “Solution”, choosing the post that first describes the solution to your issue.
Now you have to find that!! Which post was your solution??


#25

You’ll need to install polkit-efl for true polkit integration.
For some odd reason, polkit-gnome hasn’t worked in quite some time for me either.


#26

Thanks for that - I wasn’t signed in so couldn’t see it.

And AJ, if you’re reading this, accept my aplogies for my getting boloxed up and forgetting what I had posted about dupe entries - I wasn’t ready for having a myriad of ways to handle software and had too many issues in my head at once.


#27

No issues here. I’ll be setting up a box this weekend for the sole purpose of working on E/EFL once again. All my current systems are working on other projects, and can’t be diverted from their assigned tasks. Hopefully, the enlightenment sites (git, phabricator, main site, etc.) will be back up by then. :wink:


#28

When you visit the link I posted you search for ‘localestring_get()’. (In FireFox you hit Cntrl-F to open a search dialog.) It should by itself find the 1st occasion. There should be a down arrow for Find Next. One click on it and you will have the 2nd hit. One more click on the arrow and you will have the 3rd hit. At the location of the 3rd hit is some explanation regarding the error.

There is not enough Enlightenment users here in Manjaro to have our own catagory. We tend to sneak our posts in everywhere, even into Off-topic and Showcase. Technically E is not a Community Edition but we have not yet been reprimanded for posting here.

And that may well be the case for a long time to come.
I think you should consider starting fresh and build your E22 from a clean slate. If @AJSlye is willing to produce a NuLogicOS ISO you may decide to wait for it. Or you can search this forum for @fassil and try his ISOs. Or you can use Manjaro-Architect to build it to your own preferences.


#29

:sweat_smile::joy::rofl:
So you don’t know that Search Engine results (specially Google) depend on various factors, including user’s info, cookies etc…
This is not an errorless way of linking. Why not a direct link?


#30

I did post a direct link in post #19:

This is not for searching with a search engine but for searching within the linked page (^F).


#31

Silly me - i searched in the sourceforge search box.


#32

manjaro AND e22 at once is too much for these old bones.


#33

Do I need to compile polkit-efi me self?


#34

Nope it’s in my repo.
You will need to add it to your startup applications though.


#35

Which installer?
pamac won’t aithenticate
pacman says no tengo

You’d think enlightenment would have its own installer what with all the other stuff…


#36

Polkit-efl not an official module/application of Enlightenment/EFL.
When it comes to many things E, they have no official release versioning.
However, I do provide git snapshots in my repository

sudo pacman -s polkit-efl-git

#37

ave maria…

efi, efl picky picky :male_detective:

this rate a green check mark or do you only get 1 per post?