Boatload of e22 errors in xsesionerrors


#1

Hi folks - New to the forum and manjaro, a slack refugee. Its late at night for me on the left coast of the USA so I’ll just do a quick synopsis of what I did - the problem has to be something simple I’m totally unaware of. Search of google and this forum drew nothing but I don’t know what I am looking at so its hard to search.
My objective is to have a linux OS running e22 (I’ve run Bodhi for years). I am a noob to arch but not their wikis. I ran into e22 instructions here, kindly posted by AJS in a post back in Apr, I’m assuming this year. I added nulogic to the repositories but was immediately confused so I followed his alternative:
sudo pacman -Syu
sudo pacman -S python-efl python-elmextensions enlightenment

python-elmextensions wasn’t available but the other 2 installed. Runs well enough to give me some hope but somethings wrong.
q1 - Might that have been a dependency?

My screenshot doesn’t seem to work, so here is a paste of an error that repeats over and over (2 days, 2 xsessionerror files full of these):

eina_btlog << EOF
/usr/lib/libeina.so.1 0x7f7035b7c4de 0x7f7035b53000
/usr/lib/libeina.so.1 0x7f7035b7d221 0x7f7035b53000
/usr/lib/libeina.so.1 0x7f7035b7e663 0x7f7035b53000
/usr/lib/libeina.so.1 0x7f7035b951e2 0x7f7035b53000
/usr/lib/libefreet.so.1 0x7f7035b36b70 0x7f7035b2b000
/usr/lib/efreet/v-1.21/efreet_icon_cache_create 0x560ff04e034a 0x560ff04dc000
/usr/lib/efreet/v-1.21/efreet_icon_cache_create 0x560ff04e0a9c 0x560ff04dc000
/usr/lib/efreet/v-1.21/efreet_icon_cache_create 0x560ff04de798 0x560ff04dc000
/usr/lib/libc.so.6 0x7f7035968223 0x7f7035944000
/usr/lib/efreet/v-1.21/efreet_icon_cache_create 0x560ff04df50e 0x560ff04dc000
EOF

q2 - whats up with eina?

lenovo T530 intel core i5 Intel/nVidia combo graphics (Optimus?)

I just wanted this to soak overnight in the hopes it was something known right off…

thanks for now- good night.

Jeff G.


#2

Can you give some background on what you did to get to the point where you are now, eg:

1 - What is your base install ?
Some Manjaro ISO (Xfce, KDE …) ?
Manjaro-Architect ?

2 - How do you start Enlightenment ?
Display Manager ?
enlightenment_start from tty ?
startx from tty ? (modified .xinitrc including exec enlightenment_start)

I also get the errors that you show when I do ‘enlightenment_start from tty’. This does not start the X session and instead starts a Wayland session, which still should work (apart from the errors shown).

However, if you do ‘startx from tty’ it should start the X session and then E cleanly. If not then something is missing from your X setup. Scan through ~/.local/share/xorg/Xorg.0.log for any errors. (Maybe if X fails it still continue and starts the Wayland session ??)

Later: (I read your post again)

q1 - python-elmextensions is not required as far as I know.
If you want it, you can get the PKGBUILD from:
https://sourceforge.net/p/nulogicos/PKGBUILD/ci/master/tree/python-elmextensions/
You will have to compile/build it yourself. If you want, I can help but lets leave this for later.

q2 - This is what I was trying to help with in the top of this post.
I am, however, not familiar with Intel/nVidia combo graphics (Optimus?)
(‘eina’ means ‘ouch’ in my home language.)


#3

Manjaro-xfce 18 stable
no architect I’m aware of…

I start from the Display Manager with lightdm givng me a login. I have used startx once or twice so far after a logoff due to some misbehavior, both with xfce and e22. But I’ve only been using manjaro for 5 days and haven’t explored it all yet. I had gone to slack to try and avoid systemd and to get out from under e17 on bodhi - it was getting too flaky and didn’t work well with my AMD desktop.
Wayland?? Out of my league, as is systemd, although I’m being dragged kicking and screaming into systemd.

I wouldn’t know if I wanted it or not - sorry.

This morning I was reading an interesting post alluding to this Intel/nVidia combo. I’ve never looked at it much until now - Manjaro is the 1st distro I’ve run that sports that optimus manager. My laptop has always just worked and I’ve been buried in slackware since I got it. Odd, I’ve never seen any complaint nor seen optirun used in slack.

So for now, seems my screen shot doesn’t store on Desktop like its told, it locks up irretrievably, something called Window Manager doesn’t do anything with an application error and the old lie “Error log will be saved to blah-blah”. Don’t know if thats an enlightenment quirk or one of linux in general - I’ve never seen any of these logs anywhere.
I liked e17 with Bodhi but it just seemed to get stuck. Also, advice given for problems with enlightenment was always “delete the .e folder”. I wanted away from that so here I am.

Thanks for listening, Bertie - i should be over in the noob corner but it seemed the enlightenment info was good here.


#4

I suspect you may have a combination of enlightenment, xfce, or other desktop packages installed.

I suspect you may also be trying to use xfce’s screen shot utility, in E you would use “take shot” from any of the E menus (main and windows).

I’m not sure what Window Manager is at all, there is no such application in E, could be coming from LXDE/QT land as I remember a setting to change the window manager used called that in those desktops.


#5

“I suspect you may have a combination of enlightenment, xfce packages installed.”

That might throw those errors? Sounds plausable - how to remove xfce - a simple uninstall software from the package app? Thats too easy. Let you know, thanks…

re: screenshot
That is my bad. I used the e screen shot and thought it went to Desktop but it ended up in home, 2 floors up. The 2 columns to the left on the savew screen threw me.

Thats actually the 2nd one - the 1st, bird on the wire.

Aside, what the heck are those M$ programs doing in /menu/office?


#6

Vacations :joy:


#7

That package installs the online web apps for office 360, kinda self explanatory (ms-office-online).
My son has to use office 360 for his school work, he is in middle school (8th grade).
He runs Netrunner rolling on his desktop and has removed Libre-office, and installed that package for that reason. I’m sure there are other people that need office 360 for work or school as well. I find it quite a refreshing change that Manjaro actually offers this package.

Pamac will show multiple entries for a single package, this I believe is due to it’s use of appstream data. Octopi does not do this:

You should be able to remove all the xfce4 packages via it’s group listings in pamac.


#8

I see that the errors I get have a pertinent reference to Wayland while yours seem to refer to a localestring_get() that fails. So my suspecting a failed X session was probably wrong. By the way, is your locale set up correctly ? (There is a section on locale in the Manjaro (and Arch) wiki.)

Apart from the xsessionerrors, is your E22 working well or is it flaky ?

(Past midnight here on the dark continent so I have to retire for now.)


#9

Been out working on the garage - the wife beat me off the computer with a broom…

I was unaware of MS360 on line. I was also unaware of any online web apps for office 360. I am not an admin nor a programmer so have little use for MS save ability to remove it from a new or used box. I’ll agree with you about Manjaro offering it - personally I really don’t care for the software anymore - haven’t since W2000 Pro - and have zero interest in using it on the cloud.
For me, octopi is a rare sea animal with 3.141592653589793 arms. Last I used KDE, openbox, or xfce was before the turn of the century.
I have xfce as an option to e22 right now - I’ll give pamac a try.

Thanks for the info…


#10

Pamac is what was in your screen shot.
I was just explaining why there was more than one entry for a single package in it.


#11

How did you know I was wondering in the back of my head why I had 2 xfce terminals listed?? I unstalled 1 and both deleted so I went back to lxterm. I don’t recollect asking here…

Earlier you posted:
“I suspect you may have a combination of enlightenment, xfce packages installed.”

Using pamac I see a lot of xfce stuff and I suspect e is using some. The errors are piling up today - xsessiion-error log is at 966400 - a tad absurd. Do you suggest wiping out everything xfce?


#12

gday

I was having some setting issues early on but that was due to following laptop clock and I suspect the cmos battery is failing so I changed that to NTP or whatever that is. Other locale errors aren’t immediately apparent but I’ll need to go through that - I’ve never had locale problems per se. I’m afraid I couldn’t say anything intelligent about Wayland and I need to understand systemd - it is a learning pricss all these ctl things.
As noted in a post to AJ, today the xsession-error file has inflated to 966500 in size so far. I’m loking into systemd to be able to see syslog.
Yeah, like a noob…


#13

BTW, Bertie, e22 is a tad flaky. Thing comes immediately to mind is windows remember doesn’t and neither do locks. Given the myriad of settings, I know there are more I’ve noted mentally as “not critical but see about later”. There have been a couple total lock ups, something e17 had all the time.
Bodhi always said “delete the e folder and do it agaiin” :expressionless:


#14

E22 should not be flaky or experience lockups. (I cannot find the xsession-error file on my system.) I am just wondering if there may be some incompatibility between Xfce and E22 that is causing this. It is often advised here in the forum to separate different DEs to different users in order to avoid such problems. You can now do any of the following:
1 - If it is a setup problem(s) find and fix it (locale ?).
(Maybe quick or it can be a ■■■■■■■ to find.)
2 - Remove Xfce as proposed by @AJSlye.
3 - Install E22 from scratch using Manjaro-Architect.
(You will have some initial study to do - search this forum and see the wiki.)
(May need more than one attempt to get it right.)
I suggest you do 2 first an see if there is any improvement.


#15

am looking at locales right now but don’t know what could be the problem - just running locale-gen to see what happens…
.xsessions-error should be in your home folder under user…
was going to do the xfce thing after locale…
10-4
out


#16

you been here?

https://docs.enlightenment.org/api/eina/doc/html/group__Eina__Safety__Checks__Group.html


#17

I really need to make an installable ISO for NuLogicOS.
I just haven’t had time between the work I do for Blue Systems, and all the networking jobs that I’ve had come in lately.


#18

Beats not working at all -sounds like a good New Years resolution…


#19

First, you should just enter locale in a terminal and examine the output. If it is ok, then nothing more to be done. If not, you uncomment your preference in /etc/locale.gen and only then do sudo locale-gen . Then see which locales are available: locale-a . Then either select one via sudo localectl set-locale LANG=… or by editing /etc/locale.conf . Then reboot.

However, I am not saying the locale is the problem. I just looked at the error in your screenshot
Error<1055> ... localestring_get() safety check failed
and wondered …

Later:
Found some confirmation
https://sourceforge.net/p/enlightenment/mailman/message/35106090/
(Long thread because of other errors but search for ‘localestring_get()’ 3rd hit.)


#20

Bertie, congrats on digging up that forum but near as I can tell, there is nothing there that relate to me - near as I can tell…
locale commands:

Most of the thread referenced talks about xrandr which I’m not using on this laptop.

RE: xfce
later today, need to go to store for cat and people food, then honey dos till dark. Guess I picked a wrong week to switch distros…