Bluetooth speakers connecting only in headset mode and mono output


#1

Hello there forum!

I’m having an uncomfortable issue with my bluetooth speakers in Manjaro. I can recall using them on the previous version on Manjaro (XFCE version) but today that I’m trying to use them in the current GNOME version I’m getting a weird situation.

The thing is that the speakers can only connect in Headset mode with Mono output sound. It is impossible to enable the A2DP mode now.

Here is what I get when I startup (dmesg | grep Bluetooth)

[    3.179112] Bluetooth: Core ver 2.22
[    3.179132] Bluetooth: HCI device and connection manager initialized
[    3.179137] Bluetooth: HCI socket layer initialized
[    3.179139] Bluetooth: L2CAP socket layer initialized
[    3.179146] Bluetooth: SCO socket layer initialized
[    3.428670] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    3.428672] Bluetooth: BNEP filters: protocol multicast
[    3.428677] Bluetooth: BNEP socket layer initialized
[    8.190818] Bluetooth: RFCOMM TTY layer initialized
[    8.190829] Bluetooth: RFCOMM socket layer initialized
[    8.190836] Bluetooth: RFCOMM ver 1.11

When I pair the speakers, I get this kind of errors:

[  948.229404] input: 25:5B:00:00:21:38 as /devices/virtual/input/input16
[  951.006478] Bluetooth: hci0: last event is not cmd complete (0x0f)

Everytime I try to set the mode to A2DP, I get the same error in the console. If I try to edit the config and the connection via gnome-bluetooth, I get this error:

Failed to change profile to a2dp_sink

…and the same output in the terminal.

What could it be wrong?

Here’s my inxi -Fsz

System:
  Host: vaio Kernel: 4.19.2-1-MANJARO x86_64 bits: 64 Desktop: Gnome 3.30.1 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Sony product: VPCEH2M0E v: C106JKAD serial: <filter> 
  Mobo: Sony model: VAIO serial: <filter> BIOS: INSYDE v: R0180Z9 
  date: 04/28/2011 
Battery:
  ID-1: BAT0 charge: 28.7 Wh condition: 28.7/48.8 Wh (59%) 
CPU:
  Topology: Dual Core model: Intel Core i5-2430M bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 798 MHz min/max: 800/3000 MHz Core speeds (MHz): 1: 802 2: 806 
  3: 849 4: 885 
Graphics:
  Device-1: NVIDIA GF119M [GeForce 410M] driver: nvidia v: 390.87 
  Display: x11 server: X.org 1.20.3 driver: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce 410M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.87 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  driver: snd_hda_intel 
  Device-2: NVIDIA GF119 HDMI Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k4.19.2-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k 
  IF: wlp7s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 
  IF: enp19s0 state: down mac: <filter> 
  Device-3: Qualcomm Atheros AR3011 Bluetooth type: USB driver: btusb 
Drives:
  Local Storage: total: 223.57 GiB used: 100.49 GiB (44.9%) 
  ID-1: /dev/sda vendor: SanDisk model: Ultra II 240GB size: 223.57 GiB 
Partition:
  ID-1: / size: 210.75 GiB used: 100.49 GiB (47.7%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.44 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 45 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 225 Uptime: 19m Memory: 3.83 GiB used: 1.63 GiB (42.5%) 
  Shell: bash inxi: 3.0.27 

Thanks in advance!


Bluetooth headphones connect, doesn't appear in sound settings
#2

From what i understand from archwiki


#3

Thanks, I’ll take a look into that and share my experience.


#4

Thanks for this! I’ve been trying to figure out for months what the problem was. I found the below instructions to be a little simpler and easier to understand.

https://wiki.archlinux.org/index.php/Bluetooth_headset#Connecting_works,_but_I_cannot_play_sound


#5

I’m glad you were luckier than me @water1974

I’m stuck on the mono output though. I could manage to connect and set the audio manually with bluetoothctl and pavucontrol but still no AD2P for me :frowning:

“Possible solutions” on the wiki article @bogdancovaciu shared sadly do not work either. I’m not going into the bluez5/alsa approach because it implies using the AUR.

I’ll give it another try one of these days but it seems it is a known bug, or at least the behaviour shouldn’t be like this. It’s not a big deal as I can still use the speakers with my smartphone (which is actually the main use).

Thanks for your help!