Bluetooth problem

Some help needed a few days ago i had my bluetooth headphones connected and they started running out of battery (normally i would turn them off) so i turned on the other pair of headphones and got distorted sound out of them, restarted the laptop ever since then i cannot connect to bluetooth devices. What i have tried check the kernel is not 5.8, make sure the service is on, reloaded old time shift images, tried to connect different devices, install blueman, nothing has worked so looking on the google

inxi -Fazy
System:
  Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=8d1e2e78-8f42-442a-b16e-4d37b8c2a361 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05 
  serial: <filter> Chassis: type: 10 v: Lenovo Legion 5 15ARH05 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> 
  UEFI: LENOVO v: EUCN19WW date: 05/12/2020 
Battery:
  ID-1: BAT0 charge: 58.3 Wh condition: 61.3/60.0 Wh (102%) volts: 17.2/15.4 
  model: Celxpert L19C4PC0 type: Li-poly serial: <filter> status: Unknown 
  cycles: 2 
CPU:
  Topology: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600103 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 92666 
  Speed: 1397 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1396 5: 1397 6: 1396 7: 1397 8: 1397 9: 1397 
  10: 1397 11: 1397 12: 1397 13: 1397 14: 1397 15: 1397 16: 1396 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Lenovo 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1f95 
  Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus ID: 05:00.0 
  chip ID: 1002:1636 
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-3:2 chip ID: 13d3:56ff 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: amdgpu,modesetting,nouveau FAILED: ati alternate: fbdev,nv,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: AMD RENOIR (DRM 3.37.0 5.7.19-2-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.7 direct render: Yes 
Audio:
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 10de:10fa 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: N/A alternate: snd_pci_acp3x bus ID: 05:00.5 chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.7.19-2-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 2000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 
  bus ID: 04:00.0 chip ID: 8086:2723 
  IF: wlp4s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.14 TiB used: 412.28 GiB (35.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HBHQ-000L2 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 3L1QEXH7 scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: LFM1 scheme: GPT 
Partition:
  ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) 
  used: 121.68 GiB (52.1%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 42.1 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: amdgpu temp: 33 C device: nouveau temp: 25 C 
Info:
  Processes: 341 Uptime: 23m Memory: 15.07 GiB used: 2.79 GiB (18.5%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 1343 lib: 363 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 


sudo systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Tue 2020-09-22 20:44:49 NZST; 17s ago
       Docs: man:bluetoothd(8)
   Main PID: 2270 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 18427)
     Memory: 1.3M
     CGroup: /system.slice/bluetooth.service
             └─2270 /usr/lib/bluetooth/bluetoothd

Sep 22 20:44:49 borche-82b5 systemd[1]: Starting Bluetooth service...
Sep 22 20:44:49 borche-82b5 bluetoothd[2270]: Bluetooth daemon 5.54
Sep 22 20:44:49 borche-82b5 systemd[1]: Started Bluetooth service.
Sep 22 20:44:49 borche-82b5 bluetoothd[2270]: Starting SDP server
Sep 22 20:44:49 borche-82b5 bluetoothd[2270]: Bluetooth management interface 1.16 initialized
Sep 22 20:44:49 borche-82b5 bluetoothd[2270]: Endpoint registered: sender=:1.43 path=/MediaEndpoint/A2DPSink/sbc
Sep 22 20:44:49 borche-82b5 bluetoothd[2270]: Endpoint registered: sender=:1.43 path=/MediaEndpoint/A2DPSource/sbc
  • Kernel: 5.7.19-2-MANJARO is EOL so 5.4 LTS or 5.8 or 5.9-rc6 should be your first step.

  • Also after doing that, un-pair all devices and re-pair them.

  • just in case you now have multiple Bluetooth managers installed, what’s the output of:

    systemctl list-units --type=service --all | grep blue
    

:thinking:

bluetooth.service                                     loaded    active   running Bluetooth service  

I have unpaired all devices i cannot add any of them i tried 5.8 its the same, i’ll try 5.4 and 5.9

  • Only one Bluetooth Manager installed: Good!

  • Only one device can be active, so unpairing and deleting all devices should get rid of the one causing your issue.

What do you still see in your UI and which version of the kernel are you running on now?

I’m running KDE normally in the bottom bar theres a bluetooth icon which is missing one reason i installed blueman, in the KDE settings there is no bluetooth, running 5.7.19

I have posted a question regarding Bluetooth. Can someone please look in to it?

Get rid of 5.7 ASAHP. Have you tried 5.4 and 5.9RC3 already?

That is crucial information and should have been posted in your original question. Does that also happen if you create a new user and log in there?

:innocent:

woke up this morning read these posts before trying anything tried to pair the head phones with blueman, paired and sounded normal but still no bluetooth icon in the bottom KDE tray, so not sure what fixed the problem still running 5.7 and same user account

between the last un-pair everything and re-pairing did you reboot???

With kernel 5.7 I had bluetooth problems and had to switch to 5.4.

i unpaired everything rebooted and then tried pairing again and no devices could be found after that i posted on here and the facebook forum, when waking up this morning read the new replies on here before trying anything suggested tried to pair again and it worked

i tried 5.4 5 minutes ago it would not boot into manjaro just got a black screen so sticking with 5.7

As I see the Lenovo Legion 5 15ARH05 is brand-new, just a few months old. Then older kernels aren’t the solution.

yup i only have had luck running 5.6-5.8 for some reason does not even want to install 5.9 RC4 it says failed no error description in show more but i am fine with 5.7

I can only hope, a newer working kernel fix the problem for you. :sweat_smile:

yup newer kernels usually fix any problems , but for this i cannot say what the solution was