Bluetooth pairing and connecting problems

Hi there,

I am happily using Manjaro for over a month now, the only real problem I am encountering is connecting my laptop to my bluetooth headphones. Sometimes I cannot connect if I can it disconnects quickly or the sound is terrible. A few times they worked quite well so it is possible but it makes it harder to found out my problem. I tried removing my headphones in the bluetoothctl but cannot pair now.

➜  ~ bluetoothctl
Agent registered
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# agent on
Agent is already registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# devices
Device 28:11:A5:79:89:F7 LE-Bose QC35 II
[bluetooth]# pair 28:11:A5:79:89:F7
Attempting to pair with 28:11:A5:79:89:F7
Failed to pair: org.bluez.Error.ConnectionAttemptFailed

This is what I get while trying to pair.

[  785.120143] Bluetooth: hci0: last event is not cmd complete (0x0f)

This message is repeated a lot after running dmesg.

# lsusb  | grep -i bluetooth
Bus 002 Device 003: ID 13d3:3474 IMC Networks Atheros AR3012 Bluetooth

This is my bluetooth dongle in my laptop.

I hope someone has a suggestion to try :slight_smile:

Not sure, but maybe you have to install this

Thanks for the reply! When I try to install it via pamac for kernel 4.19 it gives me the error that the file conflicts with /usr/lib/modules/4.19.16-1-MANJARO/kernel/drivers/bluetooth/btusb.ko.xz

The package is also marked as outdated but thanks for searching anyway!

@d7rk Are you trying to tell that there are just a lot of problem with bluetooth on linux or what is the meaning of your message? :thinking::slightly_smiling_face:

@LinuxLoverForever I already tried this troubleshooting indeed without any luck unfortunately :slightly_frowning_face: .

To my surprise it worked flawlessly today with the GUI. I am listening via the bluetooth headphones now and its all great :grinning:. I am afraid that the next time I try, all same errors occur. Is there something I can check now so I can compare it to next time I try to connect?

I’m afraid, I have the same problem. It seems to be connected with an update in the past days. Bluetooth pairing is freezing most times. I’m using Gnome in Wayland Mode, maybe I should try to switch that off?

It is working great for some time now on my laptop. I use the cinnamon desktop environment.

What I changed in my approach is being very patient with the bluetooth. Start the bluetooth GUI manager and wait 10 seconds. Set my headphone in the connect to another devices modus and tick on my headphones in the GUI. It is important to tick the switch only one time because otherwise it will disconnect quickly after the connection because 2 requests are open.

Please see if this patience changes your behavior otherwise I will close this thread :slight_smile:

1 Like

Thanks for your info, Jarf10. So, this issue does not seem to be related to one desktop or protocol. Since I’m not using Atheros, I believe it’s independant of the driver too. For those reading here, on an arch site I found the the hint, to delete the Bluetooth device and reconnect it again. Might be worth a try …

1 Like

I’m glad you’re up and running. I’ve come into Manjaro (easy updates for a year and half already) from Ubuntu and still use windows as well (work) and really, my experience has always been a little iffy on all platforms. I’m on KDE and I find that many times I must go into system settings and actually toggle back and forth between the built in speakers and my bluetooth device to hear sound, even after pairing successfully. I’ve also seen some wonkyness with updates from time to time, but simply restarting after an update and then deleting and re-pairing usually fixes most issues. Lastly, I also second the need for patience with bluetooth.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.