Bluetooth pairing a new device doesn't work on Kernel 5.8

Whatever is previously paired works, but new devices fail to pair. If I reboot into kernel 5.4, I can add new devices, then boot back on 5.8 and they will work. It has been like that in all 5.8 versions.

As I understand, 5.8 is a major release, with the largest number of commits in a long time. It is worrying to see such an important release breaking important stuff.

My bluetooth device is reported as:

Bluetooth 9460/9560 Jefferson Peak (JfP)
|Class|224|(Wireless)|
|Subclass|1|(Radio Frequency)|
|Protocol|0||
|USB Version|2.00||
|Vendor ID|0x8087|(Intel Corp.)|
|Product ID|0xaaa|(Bluetooth 9460/9560 Jefferson Peak (JfP))|
|Revision|0.00||
|Speed|12 Mbit/s||
|Channels|0||
|Max. Packet Size|64||

And if you pair the new devices in 5.4 kernel for example, does then work on 5.8 kernel too?
What happens if you make the pairing from terminal while in 5.8 kernel?

  • 5.4 is an LTS release whereas 5.8 is not so minor bugs are to be expected in non-LTS releases.
  • If you want to ensure this bug does not eventually find itself into an LTS version, you should file a bug with the kernel team.

:sob:

Yes, if I pair on 5.4 and reboot into 5.8, it works. I don’t know how to pair from terminal, only from GUI. I doubt it is a GUI issue though.

So that’s your current workaround until the issue gets solved on 5.8 in the future…

(not perfect, but better than nothing and thank you for informing us: we might be able to tell other people to do the same)

Therefore, I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

:innocent:
P.S. In the future, please mark a solution like this:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

P.P.S. :+1: for the “Newbie at Linux for the last 15 years.” That’s how I feel sometimes…