Bluetooth not working properly after trying other os

I wanted to try kde neon, so made a bootable stick and tried with ventoy, after restarting into manjaro kde, bluetooth was acting crazy and still does, doesn’t connect to mouse, and any audio devices, any devices at all.
i tried to restart bluetooth in terminal and went back in ventoy kde neon to start and stop bluetooth.
Still nothing made it work how it should
i used

sudo systemctl start bluetooth.service
sudo systemctl status bluetooth.service
sudo systemctl restart bluetooth.service

Generated on 2023-04-26 16:07:1682514463

#################### inxi -Fxzc0 ########################

  Kernel: 6.1.25-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1 Desktop: KDE Plasma
    v: 5.27.4 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82EY v: IdeaPad Gaming 3 15ARH05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required> UEFI: LENOVO v: FCCN13WW
    date: 06/29/2020
  ID-1: BAT0 charge: 22.5 Wh (54.9%) condition: 41.0/45.5 Wh (90.1%) volts: 11.6 min: 11.4
    model: Sunwoda L19D3PF4 status: not charging
  Info: 6-core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
    rev: 1 cache: L1: 384 KiB L2: 3 MiB L3: 8 MiB
  Speed (MHz): avg: 1505 high: 2311 min/max: 1400/3000 boost: enabled cores: 1: 2311 2: 1397
    3: 1397 4: 1397 5: 1774 6: 1397 7: 1396 8: 1397 9: 1400 10: 1400 11: 1397 12: 1397
    bogomips: 71890
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU117M vendor: Lenovo driver: nvidia v: 530.41.03 arch: Turing bus-ID: 01:00.0
  Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 bus-ID: 05:00.0
    temp: 43.0 C
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:3
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1 driver: X:
    loaded: modesetting,nvidia dri: radeonsi gpu: amdgpu resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
    direct-render: Yes
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A bus-ID: 05:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 05:00.6
  API: ALSA v: k6.1.25-1-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.70 status: off
  Server-3: PulseAudio v: 16.1 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
    v: kernel port: 3000 bus-ID: 03:00.0
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo
    driver: rtw_8822ce v: N/A port: 2000 bus-ID: 04:00.0
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-3:2
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
    hardware: no software: yes address: see --recommends
  Local Storage: total: 238.47 GiB used: 62.04 GiB (26.0%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZALQ256HAJD-000L2 size: 238.47 GiB temp: 32.9 C
  ID-1: / size: 233.38 GiB used: 62.04 GiB (26.6%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 54.9 C mobo: N/A gpu: amdgpu temp: 43.0 C
  Fan Speeds (RPM): N/A
  Processes: 298 Uptime: 3m Memory: 7.14 GiB used: 2.96 GiB (41.4%) Init: systemd Compilers:
  gcc: 12.2.1 clang: 15.0.7 Packages: 1525 Client: KDE Plasma v: 5.27.4 inxi: 3.3.26
1 Like

yes this is normal. be aware that your pairing keys are changed every time starting a different os because the other os generates new keys. you need to repairing your bluetooth devices.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.