Bluetooth not working on Dell laptop


#1

Hi, I’m using a Dell laptop and want to connect my Bluetooth speakers (Ultimate Ears), but when I run rfkill list I don’t get any output mentioning Bluetooth. The output is:

[sandy@sandy-pc ~]$ rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

I’ve also installed bluez-hid2hci as suggested here:
https://wiki.archlinux.org/index.php/Bluetooth
But it doesn’t help.

Here some other outputs which might be useful:

[sandy@sandy-pc ~]$ systemctl status bluetooth
● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2018-12-06 02:41:29 +01; 1h 48min ago
     Docs: man:bluetoothd(8)
 Main PID: 1181 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4677)
   Memory: 1.9M
   CGroup: /system.slice/bluetooth.service
           └─1181 /usr/lib/bluetooth/bluetoothd

Dez 06 02:41:29 sandy-pc systemd[1]: Starting Bluetooth service...
Dez 06 02:41:29 sandy-pc bluetoothd[1181]: Bluetooth daemon 5.50
Dez 06 02:41:29 sandy-pc systemd[1]: Started Bluetooth service.
Dez 06 02:41:29 sandy-pc bluetoothd[1181]: Starting SDP server
Dez 06 02:41:30 sandy-pc bluetoothd[1181]: Bluetooth management interface 1.14 initialized
[sandy@sandy-pc ~]$ bluetoothctl
Agent registered
[bluetooth]# power on
No default controller available
[sandy@sandy-pc ~]$ inxi -Fxz
System:
  Host: sandy-pc Kernel: 4.14.85-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.12.4 Distro: Manjaro Linux 
Machine:
  Type: Portable System: Dell product: Inspiron N5030 v: N/A 
  serial: <filter> 
  Mobo: Dell model: 07K12X serial: <filter> BIOS: Dell v: A02 
  date: 09/13/2010 
CPU:
  Topology: Dual Core model: Pentium T4500 bits: 64 type: MCP arch: Penryn 
  rev: A L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 9178 
  Speed: 1197 MHz min/max: 1200/2300 MHz Core speeds (MHz): 1: 1197 2: 1197 
Graphics:
  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Dell 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.3 driver: intel resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express v: 2.1 Mesa 18.2.6 
  direct render: Yes 
Audio:
  Device-1: Intel 82801I HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.14.85-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet vendor: Dell 
  driver: atl1c v: 1.0.1.1-NAPI port: df00 bus ID: 09:00.0 
  IF: enp9s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter 
  vendor: Wistron NeWeb DNXA-95 802.11bgn driver: ath9k v: kernel port: df00 
  bus ID: 0c:00.0 
  IF: wlp12s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 66.39 GiB (14.3%) 
  ID-1: /dev/sda vendor: Samsung model: HM501II size: 465.76 GiB 
Partition:
  ID-1: / size: 449.16 GiB used: 66.39 GiB (14.8%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 146 Uptime: 1h 47m Memory: 3.82 GiB used: 1.48 GiB (38.7%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.27

#2

please post:

lsusb | grep -i bluetooth

#3

No output, that means

[sandy@sandy-pc ~]$ lsusb | grep -i bluetooth
[sandy@sandy-pc ~]$

#4

I have the same issue on my Lenevo Ideapad.

Bluetooth has worked previously.


#5

It should show up in that command, and in rfkill. Considering it’s not detected at all, that would lead me to think the correct firmware is missing.

dmesg  | grep -i 'firmware\|blue'

#6
[sandy@sandy-pc ~]$ dmesg  | grep -i 'firmware\|blue'
[    0.143440] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.248234] acpi PNP0A03:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
[    0.337101] pci 0000:09:00.0: [Firmware Bug]: disabling VPD access (can't determine size of non-standard VPD format)
[   15.266894] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.

What should I do to solve the problem?


#7

I’ve tried the two answers here, but it doesn’t work.

What about trying some AUR packages? Or editing /etc/bluetooth/main.conf? Might that help?


#8

Have you tried kernel 4.19 yet?

There has been Atheros firmware issues on other adapters that have been fixed by switching to kernel 4.19. Testing out different kernels should be one of the first things you try when experiencing hardware issues.


#9

I’ve tried it now, but almost no changes. The output of rfkill list is the same. But with dmesg | grep -i 'firmware\|blue' I get

[sandy@sandy-pc ~]$ dmesg  | grep -i 'firmware\|blue'
[    0.533994] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.677268] acpi PNP0A03:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
[    0.764790] pci 0000:09:00.0: [Firmware Bug]: disabling VPD access (can't determine size of non-standard VPD format)
[   21.066567] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.
[ 4322.084518] Bluetooth: Core ver 2.22
[ 4322.084565] Bluetooth: HCI device and connection manager initialized
[ 4322.084572] Bluetooth: HCI socket layer initialized
[ 4322.084576] Bluetooth: L2CAP socket layer initialized
[ 4322.084596] Bluetooth: SCO socket layer initialized
[ 4336.731895] audit: type=1130 audit(1544722093.269:101): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 4336.767563] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 4336.767566] Bluetooth: BNEP filters: protocol multicast
[ 4336.767572] Bluetooth: BNEP socket layer initialized