Bluetooth not able to find devices

I followed the instructions on arch wiki for bluetooth and installed the relevant packages, but I am unable to find devices and I am also unable to find this device on other devices.

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  • An inxi --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  • The exact commands / methodology you used to install the relevant packages is also important. Please provide those / that too.

:innocent:

I installed these packages: bluez & bluez-utils .

Status of bluetooth service:

â—Ź bluetooth.service - Bluetooth service
Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor>
Active: active (running) since Wed 2020-09-23 01:01:48 PKT; 20s ago
Docs: man:bluetoothd(8)
Main PID: 114263 (bluetoothd)
Status: “Running”
Tasks: 1 (limit: 9373)
Memory: 1.1M
CGroup: /system.slice/bluetooth.service
└─114263 /usr/lib/bluetooth/bluetoothd
Sep 23 01:01:48 tayyab-laptop systemd[1]: Starting Bluetooth service…
Sep 23 01:01:48 tayyab-laptop bluetoothd[114263]: Bluetooth daemon 5.54
Sep 23 01:01:48 tayyab-laptop systemd[1]: Started Bluetooth service.
Sep 23 01:01:48 tayyab-laptop bluetoothd[114263]: Starting SDP server
Sep 23 01:01:48 tayyab-laptop bluetoothd[114263]: Bluetooth management interfac>
Sep 23 01:01:48 tayyab-laptop bluetoothd[114263]: Endpoint registered: sender=:>
Sep 23 01:01:48 tayyab-laptop bluetoothd[114263]: Endpoint registered: sender=:>

I can neither find this device on other devices, nor am i able to find other devices on this devices

You missed this bit:

(everything starts there as now I have no clue about your hardware, modules, kernel version, …)

Output of inxi --admin --verbosity=7 --filter --no-host

System: Kernel: 5.4.60-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=ffa77822-46e3-4033-a7bb-81cbe64a7235 rw quiet apparmor=1
security=apparmor resume=UUID=c74f3d56-f2e5-4e3e-91d5-019ceb928ef6 udev.log_priority=3
Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel, plank wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine: Type: Portable System: Dell product: Inspiron 3520 v: N/A serial: Chassis: type: 8 serial:
Mobo: Dell model: N/A v: A04 serial: BIOS: Dell v: A04 date: 09/28/2012
Battery: ID-1: BAT0 charge: 20.9 Wh condition: 25.6/48.8 Wh (52%) volts: 12.5/11.1 model: Samsung SDI DELL 7XFJJA2
type: Li-ion serial: status: Charging
Memory: RAM: total: 7.65 GiB used: 1.68 GiB (22.0%)
RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU: Topology: Dual Core model: Intel Core i3-3110M bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58)
stepping: 9 microcode: 21 L2 cache: 3072 KiB bogomips: 19161
Speed: 1721 MHz min/max: 1200/2400 MHz Core speeds (MHz): 1: 2270 2: 2047 3: 2090 4: 2041
Flags: acpi aperfmperf apic arat arch_perfmon avx bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de
ds_cpl dtes64 dtherm dts epb ept erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs lahf_lm lm mca
mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse
pse36 pti pts rdtscp rep_good sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:0166
Device-2: Suyin type: USB driver: uvcvideo bus ID: 1-1.5:4 chip ID: 064e:812a
Display: x11 server: X . Org 1.20.8 driver: intel unloaded: modesetting alternate: fbdev,vesa display ID: :0.0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.1.6 compat-v: 3.0 direct render: Yes
Audio: Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel
bus ID: 00:1b.0 chip ID: 8086:1e20
Sound Server: ALSA v: k5.4.60-2-MANJARO
Network: Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Dell Wireless 1704 802.11n + BT 4.0 driver: wl
v: kernel modules: bcma port: f040 bus ID: 07:00.0 chip ID: 14e4:4365
IF: wlp7s0 state: up mac:
IP v4: type: dynamic noprefixroute scope: global broadcast:
IP v6: type: noprefixroute scope: link
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: e000
bus ID: 09:00.0 chip ID: 10ec:8136
IF: enp9s0 state: down mac:
WAN IP:
Drives: Local Storage: total: 465.76 GiB used: 214.80 GiB (46.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s serial: rev: 4B6Q scheme: MBR
Optical-1: /dev/sr0 vendor: TSSTcorp model: DVD±RW SN-208BB rev: D300 dev-links: cdrom
Features: speed: 24 multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
RAID: Message: No RAID data was found.
Partition: ID-1: / raw size: 44.20 GiB size: 43.25 GiB (97.86%) used: 31.19 GiB (72.1%) fs: ext4 dev: /dev/sda7 label: N/A
uuid: ffa77822-46e3-4033-a7bb-81cbe64a7235
ID-2: /media/tayyab/Data raw size: 226.76 GiB size: 222.20 GiB (97.99%) used: 169.79 GiB (76.4%) fs: ext4
dev: /dev/sda5 label: Data uuid: 4090cb74-ebe3-4d6f-8b39-e0da8c328f57
ID-3: /run/media/tayyab/WindowsData raw size: 19.53 GiB size: 19.53 GiB (100.00%) used: 13.61 GiB (69.7%) fs: ntfs
dev: /dev/sda3 label: WindowsData uuid: 16EF971F32E119C9
Swap: Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 10.00 GiB used: 212.5 MiB (2.1%) priority: -2 dev: /dev/sda6 label: N/A
uuid: c74f3d56-f2e5-4e3e-91d5-019ceb928ef6
Unmounted: ID-1: /dev/sda1 size: 100.0 MiB fs: vfat label: N/A uuid: 3A96-3F47
ID-2: /dev/sda2 size: 155.17 GiB fs: ntfs label: N/A uuid: DC8AB08A8AB06326
ID-3: /dev/sda4 size: 1 KiB fs: <superuser/root required> label: N/A uuid: N/A
ID-4: /dev/sda8 size: 10.00 GiB fs: ext4 label: N/A uuid: 349f7635-3e84-40e7-9f2e-f9f85d59a42b
USB: Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002
Hub: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 8087:0024
Device-1: 1-1.4:5 info: Broadcom BCM43142 Bluetooth 4.0 type: driver: btusb interfaces: 4
rev: 2.0 speed: 12 Mb/s chip ID: 0a5c:21d7 serial:
Device-2: 1-1.5:4 info: Suyin type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s
chip ID: 064e:812a
Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002
Hub: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 8087:0024
Device-1: 2-1.6:3 info: Realtek RTS5138 Card Reader Controller type: Mass Storage driver: ums-realtek interfaces: 1
rev: 2.0 speed: 480 Mb/s chip ID: 0bda:0138 serial:
Sensors: System Temperatures: cpu: 54.0 C mobo: 38.0 C
Fan Speeds (RPM): cpu: 3461
Info: Processes: 340 Uptime: 2d 8h 50m Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1474 lib: 411
Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05

So that’s good:

output of:

rfkill list
bluetooth --help

please?

rfkill list

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
13: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

bluetooth --help

bluetooth = on

OK, that’s as far as I can help you because I’m running KDE: you don’t have a hardware problem, but a UI problem.

One last-ditch probe that works for all DEs:

  • Do you also have the problem if you create a new user and log in there???

:thinking:

Still the same problem from new user. I’ve even tried using manjaro from live usb.

YES!! It’s finally working, Alhumdulillah. :innocent:

removed package: manjaro-firmware
and installed bcm43142a0-firmware

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.